Bug 73306 - sysklogd ships with inefficient default settings for Postfix
Summary: sysklogd ships with inefficient default settings for Postfix
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-02 19:56 UTC by Petri T. Koistinen
Modified: 2014-03-17 02:30 UTC (History)
3 users (show)

Fixed In Version: 1.4.1rh-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 19:51:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petri T. Koistinen 2002-09-02 19:56:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-12.5 i686; Nav)

Description of problem:
# tail -11 /etc/postfix/README_FILES/LINUX_README 
LINUX SYSLOGD PERFORMANCE
=========================

LINUX syslogd uses synchronous writes by default. Because of this,
syslogd can actually use more system resources than Postfix.  To
avoid such madness, disable synchronous mail logfile writes by
editing /etc/syslog.conf and by prepending a - to the logfile name:

    mail.*                          -/var/log/mail.log

Send a "kill -HUP" to the syslogd to make the change effective.
# cat /etc/syslog.conf | grep maillog
mail.*                                                /var/log/maillog
# rpm -qf /etc/syslog.conf
sysklogd-1.4.1-8
# rpm -q postfix          
postfix-1.1.7-2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Read interesting files randomly. ;-)

	

Additional info:

Comment 1 Petri T. Koistinen 2003-05-17 16:07:37 UTC
This is performance issue, I guess.

Comment 2 Petri T. Koistinen 2004-03-01 17:13:55 UTC
Is this still a issue? It can't be so hard to fix this that it takes 2
years to fix. It's only matter of adding one minus sign to
/etc/syslog.conf file.

My /etc/syslog.conf has these lines:

# Log all the mail messages in one place.
mail.*                                   -/var/log/maillog

and it have been working well for years.


Comment 3 Chris Ricker 2004-03-26 13:57:46 UTC
For starters, this should be filed against syslog, not postfix....

Comment 4 John Dennis 2004-03-31 22:34:25 UTC
agreed, this is not a postfix issue but rather a sysklogd issue,
reassigneing to notting

Comment 5 Alan Cox 2004-06-18 17:59:30 UTC
Seems a sensible fix

Comment 6 Bill Nottingham 2004-06-28 19:51:46 UTC
Fixed in 1.4.1rh-21.


Note You need to log in before you can comment on or make changes to this bug.