Bug 733067 - conversion of constraint overlay settings to cn=config is incorrect
Summary: conversion of constraint overlay settings to cn=config is incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap
Version: 15
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jan Vcelak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 722923
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 15:50 UTC by Jan Vcelak
Modified: 2013-03-04 01:29 UTC (History)
4 users (show)

Fixed In Version: openldap-2.4.24-5.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of: 722923
Environment:
Last Closed: 2011-11-17 23:41:58 UTC


Attachments (Terms of Use)

Description Jan Vcelak 2011-08-24 15:50:53 UTC
+++ This bug was initially created as a clone of Bug #722923 +++

Created attachment 513620 [details]
Slapd configuration file for slaptest

Description of problem:
Bad slaptest translate for constraints size and count. Slaptest encode only size or count parametr without value.

Version-Release number of selected component (if applicable):
openldap-servers-2.4.23-15.el6.

How reproducible:
always

Steps to Reproduce:
slaptest -f /etc/openldap/slapd.conf -F /etc/openldap/slapd.d/
  
Actual results:
File /etc/openldap/slapd.d/cn\=config/olcDatabase\=\{1\}bdb/olcOverlay\=\{0\}constraint.ldif has bad base64 decoced olcConstraintAttribute

objectClass: olcOverlayConfig
objectClass: olcConstraintConfig
olcOverlay: {0}constraint
olcConstraintAttribute:: anBlZ1Bob3RvIHNpemUg
olcConstraintAttribute:: c24gY291bnQg
structuralObjectClass: olcConstraintConfig
entryUUID: 23c9fe22-458b-1030-8c85-1b3b9d785baa
creatorsName: cn=config
createTimestamp: 20110718131106Z
entryCSN: 20110718131106.023140Z#000000#000#000000
modifiersName: cn=config
modifyTimestamp: 20110718131106Z

Command output of decoded olcConstraintAttribute:: c24gY291bnQg
echo "c24gY291bnQg" | base64 -d
result: sn count

Expected results:
Command output of decoded olcConstraintAttribute::
sn count 5 

Additional info:
Bug was reported as ITS#6986 (http://www.openldap.org/its/index.cgi/Documentation?id=6181)

Similar problem with extra parametr restrict. Restrict must be in "" and the prefix "restrict=" is repeated. Problem was reported as ITS#6181.

--- Additional comment from pm-rhel@redhat.com on 2011-07-18 15:42:23 CEST ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from jvcelak@redhat.com on 2011-08-10 11:11:15 CEST ---

(In reply to comment #0)
> Additional info:
> Bug was reported as ITS#6986
> (http://www.openldap.org/its/index.cgi/Documentation?id=6181)

This seems to be a different/wrong report.

--- Additional comment from dspurek@redhat.com on 2011-08-10 12:12:56 CEST ---

I am sorry for bad link. The link for bug ITS#6986 is http://www.openldap.org/its/index.cgi/Software%20Bugs?id=6986.

--- Additional comment from jvcelak@redhat.com on 2011-08-11 15:50:40 CEST ---

Upstream resolution available. The patch applies cleanly and seems to work.

http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=c0b669e

Comment 1 Fedora Update System 2011-08-24 19:33:17 UTC
openldap-2.4.26-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openldap-2.4.26-2.fc16

Comment 2 Fedora Update System 2011-08-24 19:38:57 UTC
openldap-2.4.24-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/openldap-2.4.24-4.fc15

Comment 3 Fedora Update System 2011-08-26 19:03:50 UTC
Package openldap-2.4.24-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openldap-2.4.24-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openldap-2.4.24-4.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-09-12 18:55:12 UTC
openldap-2.4.26-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openldap-2.4.26-3.fc16

Comment 5 Fedora Update System 2011-09-12 19:01:59 UTC
openldap-2.4.24-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/openldap-2.4.24-5.fc15

Comment 6 Fedora Update System 2011-11-05 01:25:15 UTC
openldap-2.4.26-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-11-17 23:41:58 UTC
openldap-2.4.24-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.