Bug 73308 - Redmond95 theme crashes galeon
Redmond95 theme crashes galeon
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: galeon (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-02 16:35 EDT by Tim Clymo
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 13:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2002-09-02 16:35:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Galeon bug? Or gtk-engines (or even gtk2-engines). Let's start with galeon for
now...

Anyway, galeon doesn't get on well with the redmond95 theme - it crashes with:

Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 5017 error_code 3 request_code 2 minor_code 0



Version-Release number of selected component (if applicable):



How reproducible:
Always

Steps to Reproduce:
1.Start galeon
2.Go to theme chooser tool from control center
3.Select Redmond95 application theme
	

Actual Results:  Galeon crashed and wouldn't restart

Expected Results:  Galeon continues to work (it doesn't seem to have a problem
with any of the other three themes)

Additional info:
rpm -q galeon gtk2-engines gtk-engines
galeon-1.2.5-6
gtk2-engines-1.9.0-4
gtk-engines-0.11-13
Comment 1 Christopher Blizzard 2002-11-11 13:20:40 EST
This will be fixed with the release of Mozilla 1.2.
Comment 2 Kedar Soman 2003-04-27 14:25:56 EDT
I think it galeon crahses while changing font rendering from best shape to
monochrome. (Sorry for this incomplete hint, but I think I played with themes
also before going to fonts. So I am not sure it it's the same problem above, or
could be other problem.)
Once it crashed, it gave me problems to run netscape also.
Tried logging out and logging in and then tried to remove and install galeon
again. Somehow I am able to run it right now with this error messages in terminal.

** CRITICAL **: file mozilla.cpp: line 134 (gboolean mozilla_preference_set (con
st char *, const char *)): assertion `new_value != NULL' failed.

The above message appears six times when I fire up galeon.
But then it seems to run fine

Comment 3 Christopher Blizzard 2003-05-05 13:33:22 EDT
This should be fixed in our next release.

Note You need to log in before you can comment on or make changes to this bug.