Bug 73310 - redhat-config-bind fails immediately
Summary: redhat-config-bind fails immediately
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-bind   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-09-02 21:16 UTC by Warren Togami
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-24 23:15:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/alchemist/switchboard/dns.switchboard.adl (1.81 KB, text/plain)
2002-09-03 22:45 UTC, Warren Togami
no flags Details

Description Warren Togami 2002-09-02 21:16:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
[root@laptop root]# redhat-config-bind
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-bind-gui", line 74, in ?
    cfg = dnsdata.DNS()
  File "/usr/share/redhat-config-bind/dnsdata.py", line 541, in __init__
    raise fdlg
NameError: global name 'fdlg' is not defined

Version-Release number of selected component (if applicable):
redhat-config-bind-1.8.1-17

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-bind

Actual Results:  
Fails immediately with above error.

Expected Results:  
Should work.

Comment 1 Daniel Walsh 2002-09-03 15:59:29 UTC
This would only happen if you database somehow became corrupt.  Do you have any
idea what happened?  The code should be raising a database corrupt exception.  I
will fix it after release but would like to know how you got into this state. 
You will need to uninstall the package and reinstall to clean the corruption.


Comment 2 Warren Togami 2002-09-03 16:56:13 UTC
I had never run this application before nor had I touched any files related to
BIND.  It somehow came in my custom install of Null.  When I discovered that it
failed to run, I upgraded it to this version from Rawhide which had the same
problem.

I just now tested uninstalling the package and re-installing
redhat-config-bind-1.8.1-17.  Still crashes with the above error.

Also tested re-installing all bind related packages.  No change.


Comment 3 Daniel Walsh 2002-09-03 19:13:07 UTC
/etc/alchemist/switchboard/dns.switchboard.adl is the file that is causing the
problem.  Could you send it to me?

Comment 4 Warren Togami 2002-09-03 22:45:38 UTC
Created attachment 74786 [details]
/etc/alchemist/switchboard/dns.switchboard.adl

Comment 5 Warren Togami 2002-11-24 23:15:05 UTC
Unable to reproduce in Red Hat 8.0.  CLOSE?



Note You need to log in before you can comment on or make changes to this bug.