Bug 73312 - up2date-2.9.68-1 needs rhnlib >=0.9-1 but its not available!
Summary: up2date-2.9.68-1 needs rhnlib >=0.9-1 but its not available!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-02 22:08 UTC by Nigel Smith
Modified: 2015-01-08 00:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 15:05:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Smith 2002-09-02 22:08:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; .NET 
CLR 1.0.3705)

Description of problem:
There are now lots of updated rpm's on the 'null' channel of rhn.
Using my existing up2date-2.9.55-2 to download them.
Most of them installed ok.
But when I run up2date again, it says:

Unresolvable chain of dependencies:
up2date2.9.68-1    requires rhnlib >= 0.9-1

However the only rhnlib on the null channel is rhnlib-0.8-13

Version-Release number of selected component (if applicable):
up2date-2.9.55-2
rhnlib-0.8-13

How reproducible:
Always

Steps to Reproduce:
1.Run up2date on a standard null 7.3.94 install to get the latest updates from 
the null channel on rhn
	

Additional info:

Comment 1 Adrian Likins 2002-09-02 23:06:03 UTC
should be fixed now, rhnlib didnt get pushed when it was supposed to

Comment 2 Nigel Smith 2002-09-02 23:36:38 UTC
Ok, thanks for the quick response, but now I have a problem with the package 
signature:

Fetching package list for channel: redhat-beta-null-i386...
Fetching Obsoletes list for channel: redhat-beta-null-i386...
Fetching rpm headers...
Testing package set / solving RPM inter-dependencies...
rhnlib-0.9-1.noarch.rpm:     Retrieved.
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 897da07a
An exception occured: rpm.error
The package rhnlib-0.9-1 is not signed with a GPG signature.  Aborting...
The package rhnlib-0.9-1 does not have a GPG signature.
 Aborting...


Comment 3 Nigel Smith 2002-09-03 10:14:57 UTC
Ok, I used #up2date --configure 
and changed option '25. useGPG' from Yes to No.
I have now succesfully installed:
rhnlib-0.9-1
up2date-gnome-2.9.68-1
up2date-2.9.68-1

I'm not sure how worried I should be that the updates are missing
a signature. I guess its because it's Beta & not a release version.

Comment 4 Jay Turner 2003-02-14 15:05:02 UTC
This is resolved now.


Note You need to log in before you can comment on or make changes to this bug.