Bug 733144 - links to non-default subtabs don't work
links to non-default subtabs don't work
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-24 17:50 EDT by John Mazzitelli
Modified: 2012-02-07 14:31 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:31:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-08-24 17:50:18 EDT
Click a link in a timeline that is supposed to take you to a subtab for a resource.

Notice it does take you there, but the GWT framework immediately switches you to the left-most subtab under the tab you wanted to do. If you hit the "back" button in your browser, then you go to the page that the timeline tried to get you to.

I think this has to do with the bookmarkability of our links. If you go directly to these subtab links, it isn't working - certainly not when linked from the timeline view.
Comment 1 Jay Shaughnessy 2011-08-29 12:56:18 EDT
master commit 03ebe5d1e03ac836c8618df6761f248d3ef364a8

The problem occurred, I believe, when you navigated from resource A,
default tab/subtab to resource A, non-default tab/subtab.

An easy example of this would be 1) Favorites Button->resources->A,
bringing you to A->Summary-Activity and then 2) Click on the alert def
name for a recent alert in the alerts portlet.

This scenario manged to generate a smartgwt tabbing event that did not 
play well with others.  As a response, I've expanded the net ignoring 
certain smatgwt tabbing events to catch this as well. 

TEST Notes:  Tree/Tab/Subtab nav should be well exercised (tree/context
menu/tabs/subtabs) to ensure thia change solves the problem without 
causing others.
Comment 2 Venkat 2011-08-30 08:59:04 EDT
Verified that the timeline links navigate to the correct subtab for a
resource.

Tried with Tree/tab/sub tab navigations, now it is working properly.

Verified on this build:
RHQ
Version: 4.1.1-BETA1
Build Number: 6db75f8
Comment 3 Mike Foley 2012-02-07 14:31:06 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE
Comment 4 Mike Foley 2012-02-07 14:31:06 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.