Bug 733148 - /sbin/ifup: line 20: /etc/init.d/functions: No such file or directory
/sbin/ifup: line 20: /etc/init.d/functions: No such file or directory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
16
ppc64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Alphappc
  Show dependency treegraph
 
Reported: 2011-08-24 17:57 EDT by Mark Hamzy
Modified: 2012-03-14 09:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 11:54:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2011-08-24 17:57:32 EDT
Description of problem:
Booting Fedora-20110817-ppc64-netinst.iso and using the following options
boot: linux vnc=1 selinux=0 systemd.log_target=kmsg systemd.log_level=debug rd.break

When you are in the shell, disable Anaconda's loader from starting:

switch_root:/# sed -i -e 's,/sbin/loader,/bin/bash,' /sysroot/lib/systemd/system/loader.service
switch_root:/# exit

Then, when you are dropped into bash, try and bring up the ethernet card.

bash-4.2# ifup eth0
/sbin/ifup: line 20: /etc/init.d/functions: No such file or directory
./network-functions: line 10: /etc/init.d/functions: No such file or directory
./network-functions: line 150: is_false: command not found
/etc/sysconfig/network-scripts/ifup-eth: line 18: /etc/init.d/functions: No such file or directory
./network-functions: line 10: /etc/init.d/functions: No such file or directory
./network-functions: line 150: is_false: command not found
./network-functions: line 10: /etc/init.d/functions: No such file or directory
./network-functions: line 10: /etc/init.d/functions: No such file or directory

Also, you cannot start sshd:

bash-4.2# service sshd start
/sbin/service: line 3: /etc/init.d/functions: No such file or directory
Comment 1 Martin Gracik 2011-08-26 04:19:04 EDT
The /etc/init.d/functions is part of initscripts package. We don't explicitly specify to install initscripts in the ramdisk, but shouldn't it be brought in as a dependency of ifup or sshd if it is needed?
Comment 2 Karsten Hopp 2011-08-30 09:17:30 EDT
The /etc/init.d link to /etc/rc.d/init.d/ is missing in images built with lorax-treebuilder

ln -sf rc.d/init.d /etc/init.d   fixes ifup eth0 for me
Comment 3 Will Woods 2011-08-30 11:25:55 EDT
initscripts gets pulled in by gfs2-utils at the moment, so it's in there.

As for the missing link.. I'll try to figure out why it's not getting created (or why it's getting accidentally deleted).
Comment 4 Will Woods 2011-08-30 11:32:06 EDT
Also, in theory (or maybe in the Glorious Future) you should be starting sshd using systemctl instead of the initscript, and ifup should be communicating directly with NetworkManager.. no idea if that's the reality yet, though.
Comment 5 Will Woods 2011-09-09 10:41:41 EDT
This should be fixed in treebuilder - runtime-cleanup.tmpl has the following:

removefrom chkconfig --allbut /etc/init.d

which should leave the /etc/init.d link to /etc/rc.d/init.d (as mentioned in comment #2).

Can someone confirm that it's fixed?
Comment 6 Will Woods 2011-09-22 11:54:55 EDT
since this seems to work in the treebuilder branch, I'm closing as NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.