Bug 733161 - Error creating partition (ext. USB HDD formatted Ext4)
Summary: Error creating partition (ext. USB HDD formatted Ext4)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udisks
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 23:00 UTC by nomnex
Modified: 2013-03-06 04:07 UTC (History)
4 users (show)

Fixed In Version: udisks-1.0.3-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-18 00:59:11 UTC


Attachments (Terms of Use)
/var/log/message (1.04 MB, text/plain)
2011-08-29 00:34 UTC, nomnex
no flags Details
audit.log (3.96 MB, text/x-log)
2011-08-29 08:34 UTC, nomnex
no flags Details

Description nomnex 2011-08-24 23:00:17 UTC
Description of problem:

I want to use gnome-disk-utility to format my USB HDD. The formatting seems to perform fine, but there is an error message. It worries me, since the disk hosts my backup data. 

Version-Release number of selected component (if applicable):

Disk uitlity 3.0 on Fedora 15 LXDE

How reproducible:

Always

Steps to Reproduce:
1. Plug-in a USB disk drive
2. Format it in Ext4
  
Actual results:

Error creating partition

An error occurred while performing an operation on "80 GB Hard Disk" (SAMSUNG MP0804H): The operation failed

Detail:

Error creating file system: helper exited with exit code 1: cannot create directory /var/run/udisks/job-mkfs-ZxDO88: No such file or directory

Expected results:

To be able to format my USB drive with this GUI tool, without worrying.

Additional info:

Just after formatting the device, I changed the permission (chown root:root > user:user). it returned a SELniux bug report: Process /usr/bin/palimpsest was killed by signal 11 (SIGSEGV)

See: https://bugzilla.redhat.com/show_bug.cgi?id=728816

I believe these to bug are interconnected?

URGENT QUESTION/ADVICE:
Can I use the USB HDD as is (ignoring the error) to backup my files, or should I reformat the disk using gpart?

Comment 1 nomnex 2011-08-24 23:01:59 UTC
There is an upstream bug report marked as won't fix https://bugs.freedesktop.org/show_bug.cgi?id=24265

Is it a Fedora problem?

Comment 2 David Zeuthen 2011-08-25 14:16:49 UTC
The problem is that /var/run/udisks, as owned by the udisks package, is hidden because the OS started mounting /var/run as a tmpfs. The fix, I've been told, is to use the /etc/tmpfiles.d mechanism

Comment 3 Miroslav Grepl 2011-08-25 14:23:05 UTC
what avc do you see in your /var/log/audit/audit.log related to this issue?

Comment 4 David Zeuthen 2011-08-25 14:25:50 UTC
Sorry, I erronously assigned it to selinux - my bad. Back to udisks.

Comment 5 Fedora Update System 2011-08-25 16:15:56 UTC
udisks-1.0.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/udisks-1.0.3-3.fc15

Comment 6 nomnex 2011-08-26 11:02:06 UTC
thanks for the update David, I will install it, once it's been pushed.

(In reply to comment #2)
> because the OS started mounting /var/run as a tmpfs. The fix, I've been told,
> is to use the /etc/tmpfiles.d mechanism

that won't be necessary with the update, I presume, but do you have the link for reference: How do I change /var/... to /etc/... thanks.

Comment 7 David Zeuthen 2011-08-26 14:39:05 UTC
(In reply to comment #6)
> thanks for the update David, I will install it, once it's been pushed.
> 
> (In reply to comment #2)
> > because the OS started mounting /var/run as a tmpfs. The fix, I've been told,
> > is to use the /etc/tmpfiles.d mechanism
> 
> that won't be necessary with the update, I presume, but do you have the link
> for reference: How do I change /var/... to /etc/... thanks.

The update contains the /etc/tmpfiles.d/udisks.conf file that does the right thing. You don't need to do anything.

Comment 8 Fedora Update System 2011-08-26 18:54:25 UTC
Package udisks-1.0.3-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing udisks-1.0.3-3.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/udisks-1.0.3-3.fc15
then log in and leave karma (feedback).

Comment 9 nomnex 2011-08-29 00:34:35 UTC
Created attachment 520265 [details]
/var/log/message

I have installed udisks-1.0.3-3.fc15 and reformatted the USB HDD

there is still an error message:

Error creating file system: helper exited with exit code 1: cannot create directory /var/run/udisks/job-mkfs-nHaN1M: No such file or directory

I attached the message log (usb operation is at the end of the file).

Comment 10 nomnex 2011-08-29 08:34:40 UTC
Created attachment 520317 [details]
audit.log

Comment 11 Daniel Walsh 2011-08-29 16:35:05 UTC
I would bet /var/run/udisks needs to be created by systemd?

Comment 12 David Zeuthen 2011-08-29 17:21:12 UTC
(In reply to comment #11)
> I would bet /var/run/udisks needs to be created by systemd?

No, udisks 1.0.4 and later (fc16 only) will actually create this itself at startup in the udisks-daemon process (1.0.3-3.fc15 is creating it via /etc/tmpfiles.d e.g. systemd).

Comment 13 David Zeuthen 2011-08-29 17:22:13 UTC
(In reply to comment #9)
> Created attachment 520265 [details]
> /var/log/message
> 
> I have installed udisks-1.0.3-3.fc15 and reformatted the USB HDD
> 
> there is still an error message:
> 
> Error creating file system: helper exited with exit code 1: cannot create
> directory /var/run/udisks/job-mkfs-nHaN1M: No such file or directory
> 
> I attached the message log (usb operation is at the end of the file).

 1. Please try this after a reboot
 2. Please try this with selinux in permissive mode

Comment 14 nomnex 2011-09-01 05:14:16 UTC
(In reply to comment #13)
 
>  1. Please try this after a reboot

Fixed the issue. Tested with a USB hd and a USB stick both formatted ext4/fat32.

>  2. Please try this with selinux in permissive mode

It was not necessary.

Thanks again for your time and advice (your last msg.)

Comment 15 Fedora Update System 2011-09-18 00:59:05 UTC
udisks-1.0.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.