Bug 733168 - Persistent store plugin uses inconsistent kibibyte abbreviations
Summary: Persistent store plugin uses inconsistent kibibyte abbreviations
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 01:28 UTC by Paul Colby
Modified: 2011-08-25 22:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 22:26:25 UTC


Attachments (Terms of Use)
Patch against http://anonsvn.jboss.org/repos/rhmessaging/store/trunk r4471. (2.52 KB, patch)
2011-08-25 01:28 UTC, Paul Colby
no flags Details | Diff
Patch against http://anonsvn.jboss.org/repos/rhmessaging/store/tags/qpid-0.10-release/cpp r4468. (2.66 KB, patch)
2011-08-25 01:30 UTC, Paul Colby
no flags Details | Diff

Description Paul Colby 2011-08-25 01:28:42 UTC
Created attachment 519745 [details]
Patch against http://anonsvn.jboss.org/repos/rhmessaging/store/trunk r4471.

Description of problem:
Currently, the qpidd C++ broker's help text show's KiB in some places and kiB in others.  It would be nice it these were consistent.  The inconsistent ones come from the rhm_store plugin.

How reproducible:
  Always.

Steps to Reproduce:
1. qpidd --help | grep -i '[kmt]i\?b'

Actual results:
  --num-jfiles N (8)            Default number of files for each journal
                                of read pages (1 read page = 64kiB)
                                KiB. Allowable values - powers of 2: 1, 2, 4,
  --tpl-num-jfiles N (8)        Number of files for transaction prepared list
                                64kiB)
                                list write page cache in KiB. Allowable values
  --cluster-size N (1)       Wait for N cluster members before allowing clients

Expected results:
  --num-jfiles N (8)            Default number of files for each journal
                                of read pages (1 read page = 64KiB)
                                KiB. Allowable values - powers of 2: 1, 2, 4,
  --tpl-num-jfiles N (8)        Number of files for transaction prepared list
                                64KiB)
                                list write page cache in KiB. Allowable values
  --cluster-size N (1)       Wait for N cluster members before allowing clients

Additional info:
  I'll attached a two very simple diff's that would address the issue - one diff against the 0.10 tag, and one against the current trunk (r4471).

Comment 2 Paul Colby 2011-08-25 01:32:44 UTC
This issue was originally reported at https://issues.apache.org/jira/browse/QPID-3420, but moved here since the persistent store plugin in not owned by the Qpid project directly.

Comment 3 Kim van der Riet 2011-08-25 12:40:33 UTC
Thanks for the patch. Fixed on trunk r.4472

Comment 4 Paul Colby 2011-08-25 22:26:25 UTC
You're very welcome :)

I'll close the issue now.


Note You need to log in before you can comment on or make changes to this bug.