Bug 733178 - g-s-e-cpu-temperature not working with gnome-shell-3.1
Summary: g-s-e-cpu-temperature not working with gnome-shell-3.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-cpu-temperature
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 753503 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 02:36 UTC by Jens Petersen
Modified: 2011-12-01 18:12 UTC (History)
7 users (show)

Fixed In Version: gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-17 23:43:17 UTC


Attachments (Terms of Use)

Description Jens Petersen 2011-08-25 02:36:35 UTC
Description of problem:
I am not sure about all the changes between gnome-shell 3.0
and 3.1 but it seems extensions for 3.0 no longer work with 3.1. :-(
I tried naively bumping shell-version and adding js-version
in metadata.json but this doesn't seem to be enough anyway.
In fact the only extension I know works for gnome-shell-3.1.4
is ibus-gnome3 in the Fedora 16 development tree.

Version-Release number of selected component (if applicable):
gnome-shell-extension-cpu-temperature-0-0.1.git712153f.fc16, etc

How reproducible:
100%

Steps to Reproduce:
1. install F16 Alpha
2. install gnome-shell-extension-cpu-temperature
3. restart gnome-shell
  
Actual results:
no CPU temp shown.

Expected results:
CPU temp extension to work

Additional info:
The latest build for F16 is also older than the current F15 package.

Comment 1 Steve 2011-11-08 10:10:51 UTC
I can confirm this bug.

Comment 2 Steve 2011-11-09 10:00:14 UTC
gnome-shell-3.2.1-2.fc16.x86_64
gnome-shell-extension-cpu-temperature-0-0.1.git712153f.fc16.noarch

Comment 3 Alex Lancaster 2011-11-09 18:44:27 UTC
Yes, I installed the f15 package: 

gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15.noarch

then upgraded to f16 via preupgrade.  Now it looks like the package has been orphaned because f15 stable > f16 stable, e.g.:

sudo package-cleanup --enablerepo=updates-testing --orphans

gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15.noarch

Please fix this broken update path ASAP.

Comment 4 Fabian Affolter 2011-11-13 22:17:24 UTC
*** Bug 753503 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2011-11-14 19:10:33 UTC
gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16

Comment 6 Steve 2011-11-14 21:34:22 UTC
Seems not to work here. The extension does not appear in the panel.

Comment 7 Alex Lancaster 2011-11-15 00:03:47 UTC
(In reply to comment #6)
> Seems not to work here. The extension does not appear in the panel.

Did you try restarting gnome-shell?  You might also want install the gnome-tweak-tool, that allows you to toggle each extension on and off.   I think the package adds the extension, but it is "off" by default.

Works for me after toggling it on in tweak tool and then either logging in and out, or after "Alt-F2 r".

Comment 8 Steve 2011-11-15 07:01:04 UTC
Yes it works after installing gnome-tweak-tool and enable gnome-shell-extension-cpu-temperature.

Comment 9 Fedora Update System 2011-11-16 00:29:48 UTC
Package gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15958
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-11-17 23:43:17 UTC
gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 NM 2011-12-01 18:12:02 UTC
gnome-shell --version returns: GNOME Shell 3.2.1
and
Installed Packages
Name        : gnome-shell-extension-cpu-temperature
Arch        : noarch
Version     : 0
Release     : 0.3.git1f471c7.fc16
Size        : 8.7 k
Repo        : installed
From repo   : updates
Summary     : A gnome-shell extension to show the current temperature of CPU
URL         : https://github.com/xtranophilist/gnome-shell-extension-cpu-temperature/
License     : GPLv3+
Description : Gnome Shell Extensions that adds an applet on the panel which reveals
            : current CPU temperature in Degree Celsius and Fahrenheit.


No applet appears even after togling gnome-tweak-tool and reloading the shell via "Alt-F2 r". 
I am on: 
Linux a1.home 3.1.2-1.fc16.x86_64 #1 SMP Tue Nov 22 09:00:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Any advise ?
Thanks.


Note You need to log in before you can comment on or make changes to this bug.