Bug 73321 - Upgrade fails on ro-mounted /usr
Summary: Upgrade fails on ro-mounted /usr
Status: CLOSED DUPLICATE of bug 71676
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bitmap-fonts   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 51193
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-02 23:46 UTC by Enrico Scholz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 23:47:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-02 23:46:59 UTC
Description of Problem:

When having /usr shared between some hosts, the upgrade of bitmap-fonts fails in
a %post scriptlet and results in multiple installed packages:

| $ rpm -U bitmap-fonts-0.2-2.noarch.rpm
| Can't save cache in "/usr/share/fonts/ja/TrueType"
| Can't save cache in "/usr/share/fonts/ko"
| Can't save cache in "/usr/share/fonts/ko/TrueType"
| Fehler: %post(bitmap-fonts-0.2-2) scriptlet failed, exit status 3
|
| $ rpm -q bitmap-fonts
| bitmap-fonts-0.1-2
| bitmap-fonts-0.2-2

See bug #51193 also.


Version-Release number of selected component (if applicable):

bitmap-fonts-0.2-2


How Reproducible:

100% 


Steps to Reproduce:
1. setup system so that /usr is NFS-mounted (ro)
2. add /usr to rpm's %_netsharepath
3. try to install bitmap-fonts

Comment 1 Owen Taylor 2002-11-01 01:33:09 UTC

*** This bug has been marked as a duplicate of 71676 ***


Note You need to log in before you can comment on or make changes to this bug.