Bug 733233 - /api/users/:username/owners in an improper controller
Summary: /api/users/:username/owners in an improper controller
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-25 08:39 UTC by Garik Khachikyan
Modified: 2015-01-04 21:58 UTC (History)
2 users (show)

Fixed In Version: katello-0.1.79-1-13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:31 UTC


Attachments (Terms of Use)

Description Garik Khachikyan 2011-08-25 08:39:02 UTC
Description of problem:
Listing the rake routes shows that /api/users/:username/owners is specified in api/organizations controller.
I think the best place for it would be in: api/users
If it's possible from coding POV, could you refactor it there please?

Version-Release number of selected component (if applicable):
katello-0.1.70-1.git.7.ca8d03c.fc14.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install python-katello package from: https://github.com/gkhachik/python-katello following the "SETUP" instructions there
2. Run python -c "from katello.utils import KatelloHelper; KatelloHelper.dump_routes('api/organizations')"
3. you see it listed there
  
Actual results:
the call specified is located in api/organizations

Expected results:
the call should be under: api/users

Additional info:

Comment 1 Ivan Necas 2011-09-20 08:26:57 UTC
Fixed in commit 311bf3bd

Comment 2 Garik Khachikyan 2011-09-23 11:22:11 UTC
# VERIFIED

One can see now: 
---
GET    /api/users/:username/owners(.:format) {:action=>"list_owners", :controller=>"api/users"}
---

thanks Ivan for the fix.

Checked against: katello-0.1.83-1.git.48.02111ba.fc15.noarch

Comment 5 Mike McCune 2013-08-16 18:21:41 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.