Bug 733266 - [cli] createUser - disabled=True does not work (requires: true)
Summary: [cli] createUser - disabled=True does not work (requires: true)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-25 10:04 UTC by Garik Khachikyan
Modified: 2019-09-25 21:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Garik Khachikyan 2011-08-25 10:04:46 UTC
Description of problem:
in the katello-cli "user create" method the parameter disabled takes the value "true" for preparing disabled user. The "True" case just does not work.
but intuitively (as the tool is in Python itself) it was expected to accept True (as well).
I would suggest to make disabled.lower() :)

Version-Release number of selected component (if applicable):
recent katello rpm build: katello-0.1.70-1.git.7.ca8d03c.fc15.noarch

How reproducible:
always

Steps to Reproduce:
1. katello shell 
2. user create --name test --password <pass> --disabled True
3. user list
note, that your user is created with Disabled "False" there.
  
Actual results:
"--disabled True" does not work,

Expected results:
Would be better to have both: true and True working as --disabled values.

Additional info:

Comment 1 Ivan Necas 2011-09-20 08:02:17 UTC
Fixed in 2e48d51dd0e7291dbba8cc04d1b425dc6a653747

Also added checking for the correct value so that this option won't accept anything else except "true" or "false" ignoring case.

Comment 2 Garik Khachikyan 2011-09-23 11:41:12 UTC
# VERIFIED

fixed - now the true|false with its ignorecase(s) are accepted,anything else gives:katello: error: option --disabled: invalid boolean value: <value>

Checked against: katello-cli-0.1.10-1.git.278.85760dc.el6.noarch

Comment 5 Mike McCune 2013-08-16 18:18:55 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.