Bug 733282 - FTBFS: multiple definition of `__lshrdi3' on ppc
Summary: FTBFS: multiple definition of `__lshrdi3' on ppc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: 16
Hardware: powerpc
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 11:14 UTC by Jiri Skala
Modified: 2014-11-09 22:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-11 11:18:21 UTC


Attachments (Terms of Use)
This patch fixes FTBFS issue (1.33 KB, patch)
2011-08-25 11:14 UTC, Jiri Skala
no flags Details | Diff

Description Jiri Skala 2011-08-25 11:14:26 UTC
Created attachment 519812 [details]
This patch fixes FTBFS issue

Description of problem:
Build on ppc arch fails due to multiple definiction of '__lshrdi3' function. This was introduced by kexec-tools-2.0.2 upstream tarball that adds purgatory/arch/ppc/crt.S file. The file contains mentioned duplicity.

I've attached patch that fixes this issue (removes '__lshrdi3' from crt.S).

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. build kexec-tools-2.0.2-26.fc16.src.rpm on pppc arch
2.
3.
  
Actual results:
fails

Expected results:
build is done

Additional info:
1. ppc64 works fine
2. !!!WARNING!!! There is incorrect path in 'Source0' definition of spec file (kexec-tools -> kexec).

Comment 1 Américo Wang 2011-11-11 06:58:57 UTC
Karsten, I noticed that you checked in a different patch. Is the patch from Jiri still needed?

Thanks.

Comment 2 Karsten Hopp 2011-11-11 11:18:21 UTC
I didn't know (and check) that there was a bugzilla open for this when IBM asked me for the latest kexec-tools so I just went ahead and fixed it. My patch does the same, and removes the duplicate __lshrdi3 from the PPC assember files.

As kexec-tools builds now, I'll close this bz.


Note You need to log in before you can comment on or make changes to this bug.