Bug 733308 - Adding test to beaker failed
Summary: Adding test to beaker failed
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: command line
Version: 0.7
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 12:38 UTC by Branislav Náter
Modified: 2019-05-22 13:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 05:06:48 UTC


Attachments (Terms of Use)

Description Branislav Náter 2011-08-25 12:38:41 UTC
Description of problem:
With new version of beaker-client I'm not able to add test to beaker using "make bkradd" command

Version-Release number of selected component (if applicable):
beaker-client-.7.0-1.el6eso.noarch
beaker-0.7.0-1.el6eso.noarch

How reproducible:
always

Steps to Reproduce:
1. run "make bkradd" in test directory
  
Actual results:
<snip>
/mnt/testarea/rhts-build-rlnVu8xj/install ~/tests/e2fsprogs/Regression/bz679931-mkfs-extN-problems-on-devices-with-physical-sector
Traceback (most recent call last):
  File "/usr/bin/bkr", line 9, in <module>
    load_entry_point('bkr.client==0.7.0', 'console_scripts', 'bkr')()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 299, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2229, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.6/site-packages/bkr/client/main.py", line 26, in <module>
    BeakerCommandContainer.register_module(bkr.client.commands, prefix="cmd_")
  File "/usr/lib/python2.6/site-packages/kobo/plugins.py", line 192, in register_module
    __import__(module.__name__, {}, {}, module_list)
  File "/usr/lib/python2.6/site-packages/bkr/client/commands/cmd_job_watch.py", line 62, in <module>
    from bkr.client.message_bus import ClientBeakerBus
  File "/usr/lib/python2.6/site-packages/bkr/client/message_bus.py", line 3, in <module>
    from bkr.common.message_bus import BeakerBus
  File "/usr/lib/python2.6/site-packages/bkr/common/message_bus.py", line 22, in <module>
    class BeakerBus(object):
  File "/usr/lib/python2.6/site-packages/bkr/common/message_bus.py", line 50, in BeakerBus
    headers_exchange = config.get('global', 'headers_exchange')
  File "/usr/lib64/python2.6/ConfigParser.py", line 541, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'headers_exchange' in section: 'global'
~/tests/e2fsprogs/Regression/bz679931-mkfs-extN-problems-on-devices-with-physical-sector
Finished building test package
rm testinfo.desc

Expected results:
test successfully added to beaker

Additional info:
after downgrade to beaker-client-0.6.17-1.el6eso.noarch "make bkradd" works flawlessly

Comment 1 Petr Šplíchal 2011-08-31 10:30:13 UTC
Seems to be a global problem, even "bkr help" fails with the same
traceback...

Comment 2 Marian Csontos 2011-08-31 11:48:30 UTC
You may try to follow this:

> Also if any beaker clients are using it, they will have
> to disable it by adding the following in their config file
> 
> QPID_BUS=False

Source: https://engineering.redhat.com/trac/rhat/wiki/DisableQPID

My more generic advice is: Stay away!

beaker-client-0.7 was not released to public and 
qpid was disabled.

Disable the beaker-stage repo, please.

Comment 3 Marian Csontos 2011-08-31 11:52:56 UTC
Ray, are you aware of the issue?

This must be fixed before new client is released.

IMO default value should be provided for all non-essential configuration options.

Is this covered by test suite?

Comment 4 Raymond Mancy 2011-08-31 23:12:32 UTC
No and No. Looking at it.

Comment 5 Raymond Mancy 2011-08-31 23:18:39 UTC
But yes, the 'solution' is actually to delete the file /etc/beaker/message_bus.conf. 

The next release of beaker will interact with the configs slightly differently, and that offending block of code will be gone.

Comment 6 Raymond Mancy 2011-09-02 05:06:48 UTC
This is solved by 734669


Note You need to log in before you can comment on or make changes to this bug.