Bug 733312 - Filters remove packages from repo, not just filter during sync
Summary: Filters remove packages from repo, not just filter during sync
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Sprint 27
Assignee: Sayli Karmarkar
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks: pulp-verified
TreeView+ depends on / blocked
 
Reported: 2011-08-25 12:56 UTC by Chris St. Pierre
Modified: 2015-03-23 01:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-24 20:10:50 UTC


Attachments (Terms of Use)

Description Chris St. Pierre 2011-08-25 12:56:21 UTC
Description of problem:

If you set a filter on a repository, packages matching the filter that are already in the repo are removed during sync.  This is at odds with the description of filters on the wiki, which suggests that they only prevent packages from being synced.

This makes it difficult (impossible?) to peg a package at a particular version -- e.g., if I want a specific kernel, I add that kernel version to a repo, then set a filter on 'kernel.* for the repo.  But at the next sync, all kernel packages will be removed from the repo.

Version-Release number of selected component (if applicable):

0.0.223

How reproducible:

Always

Steps to Reproduce:

1.  Create a new repo with a local feed.
2.  Sync the repo.
3.  Add a filter to the repo that matches a package in the repo.
4.  Sync the repo.
  
Actual results:

Packages matching the filter are removed from the repo.

Expected results:

No packages should be removed from the repo; new packages matching the filter should not be added, but nothing should be removed.

Additional info:

Comment 1 Sayli Karmarkar 2011-08-25 21:30:07 UTC
Fixed. Looks like when comparing existing packages in a pulp repo against source packages, we were using filtered package list instead of unfiltered package list. That is why local sync was removing packages that are already synced, thinking that they were deleted from source repo.

Comment 2 Jeff Ortel 2011-08-26 20:09:31 UTC
build: 0.228

Comment 3 Preethi Thomas 2011-08-30 13:12:19 UTC
verified
[root@preethi ~]# rpm -q pulp
pulp-0.0.228-1.fc15.noarch

[root@preethi ~]# pulp-admin repo add_filters --id=pulp-clone1 --filter=black-filter1 
Successfully added filters ['black-filter1'] to repository [pulp-clone1]

[root@preethi ~]# pulp-admin repo content --id=pulp-clone1
+------------------------------------------+
           Contents of pulp-clone1
+------------------------------------------+

Packages in pulp-clone1: 

pulp-cds-0.0.223-4.el6.noarch.rpm
grinder-0.0.110-1.el6.noarch.rpm
python-oauth2-1.2.1-3.el6.noarch.rpm
pulp-0.0.223-4.el6.noarch.rpm
python-isodate-0.4.4-2.el6.noarch.rpm
pulp-client-lib-0.0.223-4.el6.noarch.rpm
ruby-gofer-0.44-1.el6.noarch.rpm
pulp-common-0.0.223-4.el6.noarch.rpm
pulp-admin-0.0.223-4.el6.noarch.rpm
python-qpid-0.7.946106-1.el6.noarch.rpm
mod_wsgi-3.2-3.sslpatch.el6.x86_64.rpm
python-gofer-0.44-1.el6.noarch.rpm
python-rhsm-0.96.4-1.el6.noarch.rpm
pulp-consumer-0.0.223-4.el6.noarch.rpm
python-webpy-0.32-8.el6.noarch.rpm
gofer-0.44-1.el6.noarch.rpm

Errata in pulp-clone1: 

 none

Files in pulp-clone1: 

 none

[root@preethi ~]# pulp-admin repo sync --id=pulp-clone1 -FSync for repository pulp-clone1 started
Sync: Finished
0/16 new items downloaded
16/16 existing items processed

Item Details: 
Rpms: 14/16

[root@preethi ~]# pulp-admin repo content --id=pulp-clone1
+------------------------------------------+
           Contents of pulp-clone1
+------------------------------------------+

Packages in pulp-clone1: 

pulp-cds-0.0.223-4.el6.noarch.rpm
grinder-0.0.110-1.el6.noarch.rpm
python-oauth2-1.2.1-3.el6.noarch.rpm
pulp-0.0.223-4.el6.noarch.rpm
python-isodate-0.4.4-2.el6.noarch.rpm
pulp-client-lib-0.0.223-4.el6.noarch.rpm
ruby-gofer-0.44-1.el6.noarch.rpm
pulp-common-0.0.223-4.el6.noarch.rpm
pulp-admin-0.0.223-4.el6.noarch.rpm
python-qpid-0.7.946106-1.el6.noarch.rpm
mod_wsgi-3.2-3.sslpatch.el6.x86_64.rpm
python-gofer-0.44-1.el6.noarch.rpm
python-rhsm-0.96.4-1.el6.noarch.rpm
pulp-consumer-0.0.223-4.el6.noarch.rpm
python-webpy-0.32-8.el6.noarch.rpm
gofer-0.44-1.el6.noarch.rpm

Errata in pulp-clone1: 

 none

Files in pulp-clone1: 

 none

[root@preethi ~]# pulp-admin repo remove_filters --id=pulp-clone1 --filter=black-filter1 
Successfully removed filters ['black-filter1'] from repository [pulp-clone1]

[root@preethi ~]# pulp-admin repo add_filters --id=pulp-clone1 --filter=white-filter1 
Successfully added filters ['white-filter1'] to repository [pulp-clone1]

[root@preethi ~]# pulp-admin repo sync --id=pulp-clone1 -FSync for repository pulp-clone1 started
Sync: Finished
0/16 new items downloaded
16/16 existing items processed

Item Details: 
Rpms: 2/16

[root@preethi ~]# pulp-admin repo content --id=pulp-clone1+------------------------------------------+
           Contents of pulp-clone1
+------------------------------------------+

Packages in pulp-clone1: 

pulp-cds-0.0.223-4.el6.noarch.rpm
grinder-0.0.110-1.el6.noarch.rpm
python-oauth2-1.2.1-3.el6.noarch.rpm
pulp-0.0.223-4.el6.noarch.rpm
python-isodate-0.4.4-2.el6.noarch.rpm
pulp-client-lib-0.0.223-4.el6.noarch.rpm
ruby-gofer-0.44-1.el6.noarch.rpm
pulp-common-0.0.223-4.el6.noarch.rpm
pulp-admin-0.0.223-4.el6.noarch.rpm
python-qpid-0.7.946106-1.el6.noarch.rpm
mod_wsgi-3.2-3.sslpatch.el6.x86_64.rpm
python-gofer-0.44-1.el6.noarch.rpm
python-rhsm-0.96.4-1.el6.noarch.rpm
pulp-consumer-0.0.223-4.el6.noarch.rpm
python-webpy-0.32-8.el6.noarch.rpm
gofer-0.44-1.el6.noarch.rpm

Errata in pulp-clone1: 

 none

Files in pulp-clone1: 

 none

[root@preethi ~]#

Comment 4 Ashley Penney 2012-01-25 14:49:04 UTC
Exactly the same thing is happening to me.  I add a filter and resync and check the repo differences:

[root@per5-ops-pulp1 ~]# ./diff-repos.sh ops-live-rhel-6-x86_64-os ops-unstable-rhel-6-x86_64-os
--- ./1	2012-01-25 14:33:28.228307114 +0000
+++ ./2	2012-01-25 14:33:35.979307960 +0000
@@ -1585,31 +1585,6 @@
 hplip-libs-3.9.8-33.el6.x86_64.rpm
 hsqldb-1.8.0.10-8.el6.x86_64.rpm
 htdig-3.2.0-0.10.b6.el6.x86_64.rpm
-httpd-2.2.15-15.el6.x86_64.rpm
-httpd-2.2.15-5.el6.x86_64.rpm
-httpd-2.2.15-9.el6_1.2.x86_64.rpm
-httpd-2.2.15-9.el6_1.3.x86_64.rpm
-httpd-2.2.15-9.el6.x86_64.rpm
-httpd-devel-2.2.15-15.el6.i686.rpm
-httpd-devel-2.2.15-15.el6.x86_64.rpm
-httpd-devel-2.2.15-5.el6.i686.rpm
-httpd-devel-2.2.15-5.el6.x86_64.rpm
-httpd-devel-2.2.15-9.el6_1.2.i686.rpm
-httpd-devel-2.2.15-9.el6_1.2.x86_64.rpm
-httpd-devel-2.2.15-9.el6_1.3.i686.rpm
-httpd-devel-2.2.15-9.el6_1.3.x86_64.rpm
-httpd-devel-2.2.15-9.el6.i686.rpm
-httpd-devel-2.2.15-9.el6.x86_64.rpm
-httpd-manual-2.2.15-15.el6.noarch.rpm
-httpd-manual-2.2.15-5.el6.noarch.rpm
-httpd-manual-2.2.15-9.el6_1.2.noarch.rpm
-httpd-manual-2.2.15-9.el6_1.3.noarch.rpm
-httpd-manual-2.2.15-9.el6.noarch.rpm
-httpd-tools-2.2.15-15.el6.x86_64.rpm
-httpd-tools-2.2.15-5.el6.x86_64.rpm
-httpd-tools-2.2.15-9.el6_1.2.x86_64.rpm
-httpd-tools-2.2.15-9.el6_1.3.x86_64.rpm
-httpd-tools-2.2.15-9.el6.x86_64.rpm
 hunspell-1.2.8-16.el6.i686.rpm
 hunspell-1.2.8-16.el6.x86_64.rpm
 hunspell-ar-0.20080110-4.1.el6.noarch.rpm
@@ -2203,125 +2178,6 @@
 kdewebdev-libs-3.5.10-14.el6.x86_64.rpm
 kdm-4.3.4-19.el6.x86_64.rpm
 kdm-4.3.4-22.el6.x86_64.rpm
-kernel-2.6.32-131.0.15.el6.x86_64.rpm
-kernel-2.6.32-131.12.1.el6.x86_64.rpm
-kernel-2.6.32-131.17.1.el6.x86_64.rpm
-kernel-2.6.32-131.21.1.el6.x86_64.rpm
-kernel-2.6.32-131.2.1.el6.x86_64.rpm
-kernel-2.6.32-131.4.1.el6.x86_64.rpm
-kernel-2.6.32-131.6.1.el6.x86_64.rpm
-kernel-2.6.32-220.2.1.el6.x86_64.rpm
-kernel-2.6.32-220.4.1.el6.x86_64.rpm
-kernel-2.6.32-220.el6.x86_64.rpm
-kernel-2.6.32-71.14.1.el6.x86_64.rpm
-kernel-2.6.32-71.18.1.el6.x86_64.rpm
-kernel-2.6.32-71.18.2.el6.x86_64.rpm
-kernel-2.6.32-71.24.1.el6.x86_64.rpm
-kernel-2.6.32-71.29.1.el6.x86_64.rpm
-kernel-2.6.32-71.7.1.el6.x86_64.rpm
-kernel-2.6.32-71.el6.x86_64.rpm
-kernel-debug-2.6.32-131.0.15.el6.x86_64.rpm
-kernel-debug-2.6.32-131.12.1.el6.x86_64.rpm
-kernel-debug-2.6.32-131.17.1.el6.x86_64.rpm
-kernel-debug-2.6.32-131.21.1.el6.x86_64.rpm
-kernel-debug-2.6.32-131.2.1.el6.x86_64.rpm
-kernel-debug-2.6.32-131.4.1.el6.x86_64.rpm
-kernel-debug-2.6.32-131.6.1.el6.x86_64.rpm
-kernel-debug-2.6.32-220.2.1.el6.x86_64.rpm
-kernel-debug-2.6.32-220.4.1.el6.x86_64.rpm
-kernel-debug-2.6.32-220.el6.x86_64.rpm
-kernel-debug-2.6.32-71.14.1.el6.x86_64.rpm
-kernel-debug-2.6.32-71.18.1.el6.x86_64.rpm
-kernel-debug-2.6.32-71.18.2.el6.x86_64.rpm
-kernel-debug-2.6.32-71.24.1.el6.x86_64.rpm
-kernel-debug-2.6.32-71.29.1.el6.x86_64.rpm
-kernel-debug-2.6.32-71.7.1.el6.x86_64.rpm
-kernel-debug-2.6.32-71.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.0.15.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.12.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.17.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.21.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.2.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.4.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-131.6.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-220.2.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-220.4.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-220.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.14.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.18.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.18.2.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.24.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.29.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.7.1.el6.x86_64.rpm
-kernel-debug-devel-2.6.32-71.el6.x86_64.rpm
-kernel-devel-2.6.32-131.0.15.el6.x86_64.rpm
-kernel-devel-2.6.32-131.12.1.el6.x86_64.rpm
-kernel-devel-2.6.32-131.17.1.el6.x86_64.rpm
-kernel-devel-2.6.32-131.21.1.el6.x86_64.rpm
-kernel-devel-2.6.32-131.2.1.el6.x86_64.rpm
-kernel-devel-2.6.32-131.4.1.el6.x86_64.rpm
-kernel-devel-2.6.32-131.6.1.el6.x86_64.rpm
-kernel-devel-2.6.32-220.2.1.el6.x86_64.rpm
-kernel-devel-2.6.32-220.4.1.el6.x86_64.rpm
-kernel-devel-2.6.32-220.el6.x86_64.rpm
-kernel-devel-2.6.32-71.14.1.el6.x86_64.rpm
-kernel-devel-2.6.32-71.18.1.el6.x86_64.rpm
-kernel-devel-2.6.32-71.18.2.el6.x86_64.rpm
-kernel-devel-2.6.32-71.24.1.el6.x86_64.rpm
-kernel-devel-2.6.32-71.29.1.el6.x86_64.rpm
-kernel-devel-2.6.32-71.7.1.el6.x86_64.rpm
-kernel-devel-2.6.32-71.el6.x86_64.rpm
-kernel-doc-2.6.32-131.0.15.el6.noarch.rpm
-kernel-doc-2.6.32-131.12.1.el6.noarch.rpm
-kernel-doc-2.6.32-131.17.1.el6.noarch.rpm
-kernel-doc-2.6.32-131.21.1.el6.noarch.rpm
-kernel-doc-2.6.32-131.2.1.el6.noarch.rpm
-kernel-doc-2.6.32-131.4.1.el6.noarch.rpm
-kernel-doc-2.6.32-131.6.1.el6.noarch.rpm
-kernel-doc-2.6.32-220.2.1.el6.noarch.rpm
-kernel-doc-2.6.32-220.4.1.el6.noarch.rpm
-kernel-doc-2.6.32-220.el6.noarch.rpm
-kernel-doc-2.6.32-71.14.1.el6.noarch.rpm
-kernel-doc-2.6.32-71.18.1.el6.noarch.rpm
-kernel-doc-2.6.32-71.18.2.el6.noarch.rpm
-kernel-doc-2.6.32-71.24.1.el6.noarch.rpm
-kernel-doc-2.6.32-71.29.1.el6.noarch.rpm
-kernel-doc-2.6.32-71.7.1.el6.noarch.rpm
-kernel-doc-2.6.32-71.el6.noarch.rpm
-kernel-firmware-2.6.32-131.0.15.el6.noarch.rpm
-kernel-firmware-2.6.32-131.12.1.el6.noarch.rpm
-kernel-firmware-2.6.32-131.17.1.el6.noarch.rpm
-kernel-firmware-2.6.32-131.21.1.el6.noarch.rpm
-kernel-firmware-2.6.32-131.2.1.el6.noarch.rpm
-kernel-firmware-2.6.32-131.4.1.el6.noarch.rpm
-kernel-firmware-2.6.32-131.6.1.el6.noarch.rpm
-kernel-firmware-2.6.32-220.2.1.el6.noarch.rpm
-kernel-firmware-2.6.32-220.4.1.el6.noarch.rpm
-kernel-firmware-2.6.32-220.el6.noarch.rpm
-kernel-firmware-2.6.32-71.14.1.el6.noarch.rpm
-kernel-firmware-2.6.32-71.18.1.el6.noarch.rpm
-kernel-firmware-2.6.32-71.18.2.el6.noarch.rpm
-kernel-firmware-2.6.32-71.24.1.el6.noarch.rpm
-kernel-firmware-2.6.32-71.29.1.el6.noarch.rpm
-kernel-firmware-2.6.32-71.7.1.el6.noarch.rpm
-kernel-firmware-2.6.32-71.el6.noarch.rpm
-kernel-headers-2.6.32-131.0.15.el6.x86_64.rpm
-kernel-headers-2.6.32-131.12.1.el6.x86_64.rpm
-kernel-headers-2.6.32-131.17.1.el6.x86_64.rpm
-kernel-headers-2.6.32-131.21.1.el6.x86_64.rpm
-kernel-headers-2.6.32-131.2.1.el6.x86_64.rpm
-kernel-headers-2.6.32-131.4.1.el6.x86_64.rpm
-kernel-headers-2.6.32-131.6.1.el6.x86_64.rpm
-kernel-headers-2.6.32-220.2.1.el6.x86_64.rpm
-kernel-headers-2.6.32-220.4.1.el6.x86_64.rpm
-kernel-headers-2.6.32-220.el6.x86_64.rpm
-kernel-headers-2.6.32-71.14.1.el6.x86_64.rpm
-kernel-headers-2.6.32-71.18.1.el6.x86_64.rpm
-kernel-headers-2.6.32-71.18.2.el6.x86_64.rpm
-kernel-headers-2.6.32-71.24.1.el6.x86_64.rpm
-kernel-headers-2.6.32-71.29.1.el6.x86_64.rpm
-kernel-headers-2.6.32-71.7.1.el6.x86_64.rpm
-kernel-headers-2.6.32-71.el6.x86_64.rpm
 kexec-tools-2.0.0-145.el6.x86_64.rpm
 kexec-tools-2.0.0-188.el6_1.2.x86_64.rpm
 kexec-tools-2.0.0-188.el6.x86_64.rpm
@@ -3849,25 +3705,7 @@
 mvapich-psm-1.2.0-0.3562.5.el6.x86_64.rpm
 mvapich-psm-1.2.0-0.3563.rc1.3.el6.x86_64.rpm
 mx4j-3.0.1-9.13.el6.noarch.rpm
-mysql-5.1.47-4.el6.x86_64.rpm
-mysql-5.1.52-1.el6_0.1.x86_64.rpm
-mysql-bench-5.1.47-4.el6.x86_64.rpm
-mysql-bench-5.1.52-1.el6_0.1.x86_64.rpm
-mysql-connector-java-5.1.12-2.el6.x86_64.rpm
-mysql-connector-odbc-5.1.5r1144-7.el6.x86_64.rpm
-mysql-devel-5.1.47-4.el6.i686.rpm
-mysql-devel-5.1.47-4.el6.x86_64.rpm
-mysql-devel-5.1.52-1.el6_0.1.i686.rpm
-mysql-devel-5.1.52-1.el6_0.1.x86_64.rpm
-mysql-libs-5.1.47-4.el6.i686.rpm
-mysql-libs-5.1.47-4.el6.x86_64.rpm
-mysql-libs-5.1.52-1.el6_0.1.i686.rpm
-mysql-libs-5.1.52-1.el6_0.1.x86_64.rpm
 MySQL-python-1.2.3-0.3.c1.1.el6.x86_64.rpm
-mysql-server-5.1.47-4.el6.x86_64.rpm
-mysql-server-5.1.52-1.el6_0.1.x86_64.rpm
-mysql-test-5.1.47-4.el6.x86_64.rpm
-mysql-test-5.1.52-1.el6_0.1.x86_64.rpm


My filter:

Id           :               	rhel                     
Description  :               	Standard blacklist       
Type         :               	blacklist                
Package List :               	['^kernel(-.*)?', 'httpd(-.*)?', 'mysql(-.*)?']

[root@per5-ops-pulp1 ~]# rpm -qa | grep pulp
pulp-common-0.0.254-8.el6.noarch
mod_wsgi-3.2-6.pulp.el6.x86_64
python-isodate-0.4.4-4.pulp.el6.noarch
pulp-consumer-0.0.254-8.el6.noarch
pulp-admin-0.0.254-8.el6.noarch
m2crypto-0.21.1.pulp-5.el6.x86_64
pulp-0.0.254-8.el6.noarch
pulp-client-lib-0.0.254-8.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
pulp-selinux-server-0.0.254-8.el6.noarch

Comment 5 Pradeep Kilambi 2012-01-26 14:37:36 UTC
Talking Ashley on irc, looks like this issue is back, reopening.

Comment 7 Sayli Karmarkar 2012-02-14 08:03:42 UTC
I tried to reproduce this today, but I did not see packages getting removed from the repo.

$ sudo pulp-admin repo content --id clone-test
+------------------------------------------+
           Contents of clone-test
+------------------------------------------+

Packages in clone-test: 

pulp-large_100k_test-packageB-0.1.1-1.fc14.noarch.rpm
pulp-large_100k_test-packageA-0.1.1-1.fc14.noarch.rpm
pulp-dot-2.0-test-0.1.2-1.fc11.x86_64.rpm
pulp-test-package-0.2.1-1.fc11.x86_64.rpm

Errata in clone-test: 

 none

Files in clone-test: 

 fileA.txt
 fileC.iso
 updateinfo.xml
 fileB.txt


$ sudo pulp-admin repo info --id clone-test

Id                 	clone-test               
Name               	clone-test               
Repo URL           	https://sunflower/pulp/repos/clone-test/
Feed URL           	file:///var/lib/pulp//repos/repos/pulp/pulp/demo_repos/test_bandwidth_repo_smaller
Feed Type          	local                    
Content Type       	yum                      
Feed Certs         	CA:No   Cert:No
Consumer Certs     	CA:No   Cert:No
Architecture       	noarch                   
Sync Schedule      	None                     
Packages           	4                        
Files              	4                        
Distributions      	None                     
Publish            	True                     
Clones             	[]                       
Groups             	None                     
Filters            	['spacewalk']            
Notes              	{}                       
Preserve Metadata  	False                    
Checksum Type      	sha256                   



$ sudo pulp-admin filter list
+------------------------------------------+
              Available Filters
+------------------------------------------+

Id           :               	spacewalk                
Description  :               	spacewalk                
Type         :               	blacklist                
Package List :               	['spacewalk*', 'rhn*', 'pulp-test-package*', 'pulp-dot*']



$ sudo pulp-admin repo sync --id clone-test -F
Sync for repository clone-test started
Sync: Finished
0/4 new items downloaded
4/4 existing items processed

Item Details: 
RPMs: 2/4

$ sudo pulp-admin repo content --id clone-test
+------------------------------------------+
           Contents of clone-test
+------------------------------------------+

Packages in clone-test: 

pulp-large_100k_test-packageB-0.1.1-1.fc14.noarch.rpm
pulp-large_100k_test-packageA-0.1.1-1.fc14.noarch.rpm
pulp-dot-2.0-test-0.1.2-1.fc11.x86_64.rpm
pulp-test-package-0.2.1-1.fc11.x86_64.rpm

Errata in clone-test: 

 none

Files in clone-test: 

 fileA.txt
 fileC.iso
 updateinfo.xml
 fileB.txt


$ ls /var/lib/pulp/repos/clone-test/

drpms      fileC.iso                                              pulp-large_100k_test-packageB-0.1.1-1.fc14.noarch.rpm  repodata
fileA.txt  pulp-dot-2.0-test-0.1.2-1.fc11.x86_64.rpm              PULP_MANIFEST                                          updateinfo.xml
fileB.txt  pulp-large_100k_test-packageA-0.1.1-1.fc14.noarch.rpm  pulp-test-package-0.2.1-1.fc11.x86_64.rpm


Repo sync summary seems to be misleading with RPMs: 2/4 but it is not actually removing the packages.

Comment 8 Sayli Karmarkar 2012-02-14 08:25:07 UTC
I am able to reproduce it now with spacewalk repo. I will investigate it a bit more tomorrow to figure out what has changed and why is behaviour different for 2 different repos/filters.

Comment 9 Sayli Karmarkar 2012-02-16 21:09:01 UTC
commit 30f86b4c8a25722312b9749818f36395e09fab9e
Author: Sayli Karmarkar <skarmark@redhat.com>
Date:   Thu Feb 16 12:58:23 2012 -0800

    733312 - Make sure sync does not remove already existing packages from a repo during filter operation

Comment 10 Jeff Ortel 2012-02-17 17:17:34 UTC
build: 0.267

Comment 11 Preethi Thomas 2012-02-21 21:02:09 UTC
verified

[root@preethi ~]# pulp-admin filter  add_package --id blacklist -p spacewalk-ssl-cert-check-2.1-1.el6.src.rpm
Successfully added packages to filter [ blacklist ]

[root@preethi ~]# 
[root@preethi ~]# 
[root@preethi ~]# 
[root@preethi ~]# pulp-admin filter list
+------------------------------------------+
              Available Filters
+------------------------------------------+

Id           :               	blacklist                
Description  :               	blacklist                
Type         :               	blacklist                
Package List :               	['rhn*', 'spacewalk-ssl-cert-check-2.1-1.el6.src.rpm']


[root@preethi ~]# pulp-admin repo sync --id=spacewalk-clone -FSync for repository spacewalk-clone started
Sync: Finished
0/85 new items downloaded
85/85 existing items processed

Item Details: 
RPMs: 85/85

[root@preethi ~]# pulp-admin repo content --id spacewalk-clone |grep spacewalk         Contents of spacewalk-clone
Packages in spacewalk-clone: 
spacewalk-reports-1.6.3-1.el6.src.rpm
spacewalk-jpp-workaround-1.0.1-1.el6.src.rpm
spacewalk-certs-tools-1.6.7-1.el6.src.rpm
spacewalk-proxy-html-1.1.1-1.el6.src.rpm
spacewalk-proxy-selinux-1.1.1-1.el6.src.rpm
spacewalk-utils-1.6.6-1.el6.src.rpm
spacewalk-doc-indexes-1.1.1-1.el6.src.rpm
spacewalk-proxy-monitoring-1.6.1-1.el6.src.rpm
spacewalk-java-1.6.102-1.el6.src.rpm
spacewalk-proxy-installer-1.6.7-1.el6.src.rpm
spacewalk-setup-1.6.5-1.el6.src.rpm
spacewalk-web-1.6.38-1.el6.src.rpm
spacewalk-schema-1.6.42-1.el6.src.rpm
spacewalk-config-1.6.4-1.el6.src.rpm
spacewalk-search-1.6.8-1.el6.src.rpm
spacewalk-monitoring-1.4.1-1.el6.src.rpm
spacewalk-proxy-1.6.5-1.el6.src.rpm
spacewalk-branding-1.6.4-1.el6.src.rpm
spacewalk-selinux-1.6.2-1.el6.src.rpm
spacewalk-repo-1.6-1.el6.src.rpm
spacewalk-backend-1.6.66-1.el6.src.rpm
spacewalk-slf4j-1.6.1-1.el6.src.rpm
spacewalk-monitoring-selinux-1.6.2-1.el6.src.rpm
spacewalk-setup-jabberd-1.6.5-1.el6.src.rpm
spacewalk-ssl-cert-check-2.1-1.el6.src.rpm
spacewalk-proxy-docs-1.1.1-1.el6.src.rpm
spacewalk-1.5.1-1.el6.src.rpm
spacewalk-admin-1.6.3-1.el6.src.rpm
spacewalk-remote-utils-1.6.8-1.el6.src.rpm
Errata in spacewalk-clone: 
Files in spacewalk-clone: 
[root@preethi ~]#

Comment 12 Preethi Thomas 2012-02-24 20:10:50 UTC
Pulp v1.0 is released
Closed Current Release.


Note You need to log in before you can comment on or make changes to this bug.