Bug 733377 - [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/samuel350z_40hotmail_2ecom at 0xb71eafac>
Summary: [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError...
Keywords:
Status: CLOSED DUPLICATE of bug 691209
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:81feeaca75d869fc443fc9ec815...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 15:18 UTC by samm
Modified: 2011-11-20 14:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-20 14:38:50 UTC


Attachments (Terms of Use)

Description samm 2011-08-25 15:18:40 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        
comment:        tenía abierto empathy en 2o plano, y después tenía abiertas más aplicacioens, pero derrepente mi cuenta de MSN se desconectó, las demas continuaron desconectadas
component:      telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         2.6.40.3-0.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        telepathy-butterfly-0.5.15-3.fc15
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/samuel350z_40hotmail_2ecom at 0xb71eafac>
time:           Thu Aug 25 09:50:54 2011
uid:            500
username:       samm

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/samuel350z_40hotmail_2ecom at 0xb71eafac>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 425, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/xxxxx_40hotmail_2ecom at 0xb71eafac>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0xb71eab6c>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/samuel350z_40hotmail_2ecom at 0xb71eafac>

Comment 1 Brian Pepple 2011-11-20 14:38:50 UTC

*** This bug has been marked as a duplicate of bug 691209 ***


Note You need to log in before you can comment on or make changes to this bug.