Bug 733419 - /sbin/ip tried to load a kernel module
Summary: /sbin/ip tried to load a kernel module
Keywords:
Status: CLOSED DUPLICATE of bug 726339
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.1
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 16:35 UTC by Matthew Mosesohn
Modified: 2016-07-13 11:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-26 13:53:55 UTC


Attachments (Terms of Use)
selinux alert message (2.21 KB, text/plain)
2011-08-25 16:36 UTC, Matthew Mosesohn
no flags Details
yum recent log, one of these packages causes this issue (24.24 KB, text/plain)
2011-08-25 16:37 UTC, Matthew Mosesohn
no flags Details

Description Matthew Mosesohn 2011-08-25 16:35:46 UTC
Description of problem:
This is occurring on many RHEL 6 systems:
SELinux has prevented ip from loading a kernel module. All confined programs
that need to load kernel modules should have already had policy written for
them. If a compromised application tries to modify the kernel this AVC will be
generated. This is a serious issue. Your system may very well be compromised.


Version-Release number of selected component (if applicable):
iproute-2.6.32-16.el6.x86_64
kernel-2.6.32-131.4.1.el6.x86_64
selinux-policy-3.7.19-93.el6_1.2.noarch

How reproducible:
Often, several times per day

Steps to Reproduce:
1. Try to connect to a VPN connection with NetworkManager
2.
3.
  
Actual results:
The connection fails

Expected results:
The connection should work

Additional info:
This happened only as a result of recent software updates in the past week.  This should be marked a regression.

Comment 1 Matthew Mosesohn 2011-08-25 16:36:55 UTC
Created attachment 519924 [details]
selinux alert message

Comment 2 Matthew Mosesohn 2011-08-25 16:37:28 UTC
Created attachment 519925 [details]
yum recent log, one of these packages causes this issue

Comment 4 Daniel Walsh 2011-08-25 18:51:18 UTC
Yes this is a kernel userspace issue that we will be covering up in 

selinux-policy-3.7.19-107.el6

Nothing was actually blocked.

If you want to try out the policy you can grab it from 

http://people.redhat.com/dwalsh/SELinux/RHEL6

Comment 6 Matthew Mosesohn 2011-08-25 18:55:37 UTC
What wonderful heroism, Dan.  Thanks for saving the day.

Comment 7 Karel Srot 2011-08-26 06:48:13 UTC
Seems to be a duplicete of 726339? Can we close it?

Comment 8 Matthew Mosesohn 2011-08-26 12:08:12 UTC
go ahead


Note You need to log in before you can comment on or make changes to this bug.