Bug 733420 - User permission check missing for CryptoKeysHandler
User permission check missing for CryptoKeysHandler
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
540
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Martin Minar
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2011-08-25 12:43 EDT by Tomas Lestach
Modified: 2016-07-03 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2011-08-25 12:43:00 EDT
Description of problem:
Nowadays any user may create or delete keys using the kickstart.keys APIs.

Version-Release number of selected component (if applicable):
sat541

How reproducible:
always

Steps to Reproduce:
1. Create a simple satellite user.
2. Try to create and delete a GPG a/o SSL key using kickstart.keys API
  
Actual results:
Passed.

Expected results:
Only an org or config admin shall be able to modify GPG/SSL keys (at least there's such restriction in WebUI)
Comment 1 Tomas Lestach 2011-08-25 13:48:27 EDT
Tomas, please fix also cases, when specifying invalid description for delete and getDetails (NoSuchCryptoKeyException)
Comment 2 Tomáš Kašpárek 2012-08-28 07:58:27 EDT
fixed in spacewalk master 1dae339f2c4ef314436bddc3bf9364dbf526bacd
Comment 5 Clifford Perry 2013-10-01 17:56:42 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.