Bug 733428 - Fix rendering of 'tricky' CJK fonts
Summary: Fix rendering of 'tricky' CJK fonts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: freetype
Version: 5.7
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 17:00 UTC by Timothy Lee
Modified: 2014-06-30 04:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:05:44 UTC


Attachments (Terms of Use)
Test file with embedded tricky CJK fonts (106.66 KB, application/octetstream)
2011-08-25 17:00 UTC, Timothy Lee
no flags Details
Backport support for tricky CJK fonts to freetype-2.2.1 (16.22 KB, patch)
2011-08-25 17:14 UTC, Timothy Lee
no flags Details | Diff

Description Timothy Lee 2011-08-25 17:00:03 UTC
Created attachment 519929 [details]
Test file with embedded tricky CJK fonts

Description of problem:
Some 'tricky' CJK fonts requires the use of formerly patented byte-code interpreter to be rendered properly.

Version-Release number of selected component (if applicable):
freetype-2.2.1-28.el5_5.1

How reproducible:
Always

Steps to Reproduce:
1.Open attached 'tricky-cjk.pdf' in evince
  
Actual results:
The glyphs of the CJK characters are misplaced, resulting in malformed characters.

Expected results:
The glyphs of the CJK characters should be shown properly.

Additional info:
The use of patented BCI is required to render those CJK fonts, but the patent has recently expired, and freetype-2.4.4 enables BCI by default.

Comment 1 Timothy Lee 2011-08-25 17:14:59 UTC
Created attachment 519938 [details]
Backport support for tricky CJK fonts to freetype-2.2.1

The attached patch backports the changes in http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=b972a2a294a6d1f53ad403ae2bf0a098a38f0c2b&h=master to provide support for tricky fonts.

This patch also incorporates checksum-based tricky font detection from http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=9f5dd61bf3deee315da14d3aca7f436bbf9cc76a .

The attached patch depends on the freetype-2.1.10-enable-ft2-bci.patch in the SPEC file, which is not used by default.  However since those CJK fonts must use the patented BCI, and that patent has now expired, the BCI patch should always be applied (just as patented BCI is always enabled in freetype >= 2.4.4).

Comment 2 RHEL Product and Program Management 2014-03-07 12:42:16 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 3 RHEL Product and Program Management 2014-06-02 13:05:44 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.