Bug 733431 - NM-openconnect is built against static libopenconnect; needs to be rebuilt against openconnect 3.11
Summary: NM-openconnect is built against static libopenconnect; needs to be rebuilt ag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-openconnect
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 17:06 UTC by Erinn Looney-Triggs
Modified: 2011-09-19 22:56 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-openconnect-0.9.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-28 05:25:21 UTC


Attachments (Terms of Use)

Description Erinn Looney-Triggs 2011-08-25 17:06:11 UTC
Description of problem:
I am not 100% sure on this, as I have never used openconnect on fedora before but reading the documentation it appears that there used to be an option for setting authentication parameters, as in use cert, or use username/password, or maybe both. That option does not, at least for me, appear under F16 alpha, the only thing that would appear to work is certs, though I do not have the configuration to validate that those work.

Version-Release number of selected component (if applicable):
NetworkManager-openconnect-0.8.999-2.fc16.x86_64
NetworkManager-0.8.9997-7.git20110721.fc16.x86_64

How reproducible:
Attempt to create a new openconnect setup under gnome. 
Search in vain for the option that allows you to user username/password.

Comment 1 David Woodhouse 2011-08-25 20:41:59 UTC
When you try to connect, the server *might* ask you for a username/password. Or it might ask for your mother's maiden name and your favourite colour. We have no way of knowing — it's just arbitrary HTTP forms.

We *used* to assume that it'll ask for username/password, and ask for those in advance. That was a bug. Now we don't do it.

Just try to start the connection, and the authentication dialog will pop up and ask you for any information the server requires.

Comment 2 Erinn Looney-Triggs 2011-08-25 20:46:15 UTC
Hmm ok, problem is that is not what I am experiencing, when I attempt to connect it is throwing an SSL error specifically error 40, which from what I gather is a complaint about the client not presenting a certificate to the server. So I assumed it was because the username/password option had disappeared and it was defaulting to certificate auth. Let me see if can get you more information.

Comment 3 Erinn Looney-Triggs 2011-08-25 20:52:23 UTC
Error output exactly:
SSL connection failure
139863678563968:error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure:s3_pkt.c:1193:SSL alert number 40

This might then be a bug in another location but I am not sure where, or well the user sitting in the chair :)

Comment 4 David Woodhouse 2011-08-25 20:57:52 UTC
Hm, probably fixed in OpenConnect v3.11. What is the VPN server address?

Comment 5 Erinn Looney-Triggs 2011-08-25 21:04:24 UTC
cipher.providigm.com, looks like I am running 3.11:
openconnect-3.11-1.fc16.x86_64

Still trying to dig up what alert number 40 really means.

-Erinn

Comment 6 Erinn Looney-Triggs 2011-08-25 21:05:19 UTC
And if it helps any I am able to make a successful openconnect connection via the CLI.

Comment 7 David Woodhouse 2011-08-25 21:20:03 UTC
Ah, right. So yes, I'm fairly sure it was fixed in OpenConnect v3.11. But NetworkManager-openconnect is still built using an older, static, libopenconnect.

I thought we'd rebuilt it against the dynamic library, so this bug would have been fixed... but evidently not.

If you just rebuild NM-openconnect for yourself this bug should go away.

Comment 8 Erinn Looney-Triggs 2011-08-25 21:25:28 UTC
David,
Thanks for taking the time to look into this, and find a solution, I really appreciate it. 

-Erinn

Comment 9 Fedora Update System 2011-08-25 22:44:38 UTC
NetworkManager-openconnect-0.8.999-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/NetworkManager-openconnect-0.8.999-3.fc16

Comment 10 Fedora Update System 2011-08-26 14:18:44 UTC
Package NetworkManager-openconnect-0.8.999-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-openconnect-0.8.999-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-openconnect-0.8.999-3.fc16
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2011-08-28 05:25:16 UTC
NetworkManager-openconnect-0.8.999-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-09-08 10:11:04 UTC
NetworkManager-openconnect-0.9.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/NetworkManager-openconnect-0.9.0-2.fc15

Comment 13 Fedora Update System 2011-09-19 22:56:46 UTC
NetworkManager-openconnect-0.9.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.