Bug 733433 - virt-manager does not update xen guest state properly after shutdown
virt-manager does not update xen guest state properly after shutdown
Status: CLOSED DUPLICATE of bug 746007
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-25 13:20 EDT by Alexander Bienzeisler
Modified: 2012-01-29 13:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-29 13:52:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
what it looks like (87.93 KB, image/png)
2011-08-25 13:22 EDT, Alexander Bienzeisler
no flags Details

  None (edit)
Description Alexander Bienzeisler 2011-08-25 13:20:59 EDT
Description of problem:

virt-manager does not update guest state properly after shutdown, machines show as running after they were shut down (and have shut down)

Version-Release number of selected component (if applicable):

0.9.0

How reproducible:

gracefully shutdown a machine and wait for it to show as shut-off

Steps to Reproduce:
1. shutdown machine gracefully
2. wait
3. check status
  
Actual results:

shows as running

Expected results:

should show as shut-off

Additional info:


root@susi-0:~/virt-manager# git bisect good
743dddf1b917fa1b6d26d645a13edfdc6ae98a36 is the first bad commit
commit 743dddf1b917fa1b6d26d645a13edfdc6ae98a36
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sun Apr 10 18:26:40 2011 -0400

    connection: Refactor _update_vms to be more like other polling

:040000 040000 40d9c0c9beb8eec31ff7010f57259ad67b225495 138658995a29d2791d3aad3f5f6eeba80a91c24c M      src
root@susi-0:~/virt-manager#

---
debug output
---

2011-08-24 23:39:07,773 (engine:1048): Shutting down vm 'winxp1_susi1'.
2011-08-24 23:39:53,286 (domain:1514): Error reading disk stats for 'winxp1_susi1' dev 'hda': internal error Failed to read any block statistics for domain 52
2011-08-24 23:39:53,286 (domain:1515): Adding hda to skip list.
2011-08-24 23:39:53,286 (domain:1480): Error reading net stats for 'winxp1_susi1' dev 'vif52.0': internal error /proc/net/dev: Interface not found
2011-08-24 23:39:53,287 (domain:1481): Adding vif52.0 to skip list.
Comment 1 Alexander Bienzeisler 2011-08-25 13:22:17 EDT
Created attachment 519939 [details]
what it looks like
Comment 2 Cole Robinson 2012-01-29 13:52:53 EST
Okay, I reproduced this issue and it looks like either a libvirt or xen bug that is exposed by that change in virt-manager. What we are doing should work from an API user perspective so one of those other packages is doing something wrong.

Duping to a bug where I provided a simple reproducer

*** This bug has been marked as a duplicate of bug 746007 ***

Note You need to log in before you can comment on or make changes to this bug.