Bug 733455 - Kickstart error "Section does not end with %end"
Kickstart error "Section does not end with %end"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2011-08-25 14:18 EDT by Andrew McNabb
Modified: 2011-09-19 20:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: pykickstart-1.99.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-19 20:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart script (4.50 KB, application/x-java-keystore)
2011-08-25 14:18 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2011-08-25 14:18:30 EDT
Created attachment 519952 [details]
kickstart script

I tried to install Fedora 16 Alpha by tweaking the kickstart script I was using in Fedora 15.  Unfortunately, it failed with the error:

"""
The following problem occurred on line 118 of the kickstart file:

Section does not end with %end.
"""

I have attached the kickstart script, but for convenience, the relevant excerpt is included here (line 118 is the line with the "%include" directive):

"""
%packages --ignoremissing
%include /tmp/packages
rpmfusion-free-release
rpmfusion-nonfree-release
- olpc-logos
%end
"""

This script worked in Fedora 15, but it seems that in Fedora 16 Alpha there is a problem with having a "%include" directive inside of a "%packages" section.

Please let me know if there is any other information that I should provide.  Thanks.
Comment 1 Chris Lumens 2011-08-25 14:38:49 EDT
I can reproduce this with a minimal script, so I shouldn't need any additional info.  It's going to be a little while before I can take a look, though, since I am leaving on vacation tomorrow.

As a workaround, you can put %packages and %end inside your /tmp/packages file, and then include it outside of the %packages section in your main file.  Multiple %packages sections are valid.

You can also %include <url> directly.  You don't need to wget it beforehand.  That doesn't affect anything here - it just might help to shorten up your kickstart file a bit.
Comment 2 Andrew McNabb 2011-08-25 14:46:41 EDT
Thank you for the workaround--I will try this.

It doesn't look like the "%include <url>" functionality is documented.  Is it okay if I add this to the wiki?

And not to add too much stress before you leave, but would it be appropriate to add this as an release blocker?

Thanks again for your help.
Comment 3 Chris Lumens 2011-08-25 14:48:03 EDT
There, a test case added so I won't forget what the problem was:

http://git.fedorahosted.org/git/?p=pykickstart.git;a=commitdiff;h=4ef0647df44ad33b2f7d8451d9c4d6c603d098e5

Now I'll have to fix it if I ever want to do a new build.
Comment 4 Chris Lumens 2011-08-25 14:49:17 EDT
> It doesn't look like the "%include <url>" functionality is documented.  Is it
> okay if I add this to the wiki?

Go for it.

> And not to add too much stress before you leave, but would it be appropriate to
> add this as an release blocker?

I don't know what our criteria for kickstart installs look like, but I would say this is at the least Nice To Have.  You can propose it as a blocker, and then it'll at least get talked about later.
Comment 5 Andrew McNabb 2011-08-25 15:43:33 EDT
(In reply to comment #4)
> > It doesn't look like the "%include <url>" functionality is documented.  Is it
> > okay if I add this to the wiki?
> 
> Go for it.

Done.
Comment 6 Chris Lumens 2011-09-08 13:42:29 EDT
I've committed and pushed a patch that passes my test cases, but I consider medium risk to break behavior elsewhere.  My test cases are still not quite enough in this area to make me confident.
Comment 7 Adam Williamson 2011-09-09 13:56:30 EDT
Discussed at 2011-09-09 blocker review meeting. This doesn't hit our current minimal kickstart criterion and no-one really felt like we needed to add a criterion for this, but we accept it as NTH as it's an installer bug of significant impact. Of course, clumens, it's up to your judgement whether it's safe enough to put in.
Comment 8 Chris Lumens 2011-09-13 13:52:52 EDT
Yeah, I'm going to build this just as soon as an anaconda-related fix goes in too.
Comment 9 Fedora Update System 2011-09-14 15:27:03 EDT
pykickstart-1.99.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pykickstart-1.99.4-1.fc16
Comment 10 Fedora Update System 2011-09-15 11:14:34 EDT
Package pykickstart-1.99.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.4-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/pykickstart-1.99.4-1.fc16
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-09-19 20:09:11 EDT
pykickstart-1.99.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.