Bug 733461 - [abrt] hpijs-1:3.11.7-2.fc14: __libc_start_main: Process /usr/lib/cups/filter/hpcups was killed by signal 6 (SIGABRT)
Summary: [abrt] hpijs-1:3.11.7-2.fc14: __libc_start_main: Process /usr/lib/cups/filter...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:468a310802f80dbc055eb44ecb7...
: 733444 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 18:33 UTC by Rex Dieter
Modified: 2011-11-10 17:50 UTC (History)
2 users (show)

Fixed In Version: hplip-3.11.10-5.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-25 03:43:33 UTC


Attachments (Terms of Use)
File: backtrace (7.12 KB, text/plain)
2011-08-25 18:33 UTC, Rex Dieter
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 839632 None None None Never

Description Rex Dieter 2011-08-25 18:33:35 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 7292 bytes
cmdline: shermiller2-1 361 root 'Test Page' 1 'job-uuid=urn:uuid:d5619ff0-f6f0-3d50-4ff5-11e25f05f8cb job-originating-host-name=localhost time-at-creation=1314294087 time-at-processing=1314294087 AP_D_InputSlot='
component: hplip
Attached file: coredump, 1048576 bytes
crash_function: __libc_start_main
executable: /usr/lib/cups/filter/hpcups
kernel: 2.6.35.14-95.fc14.i686.PAE
package: hpijs-1:3.11.7-2.fc14
rating: 4
reason: Process /usr/lib/cups/filter/hpcups was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1314294090
uid: 4

How to reproduce
-----
1. plugin new printer
2. (try to) print test page

Comment 1 Rex Dieter 2011-08-25 18:33:37 UTC
Created attachment 519957 [details]
File: backtrace

Comment 2 Rex Dieter 2011-08-25 18:34:33 UTC
*** Bug 733444 has been marked as a duplicate of this bug. ***

Comment 3 Rex Dieter 2011-08-25 18:35:13 UTC
cups debug2 error_log is in bug #733444

Comment 4 Jiri Popelka 2011-08-26 07:24:55 UTC
D [25/Aug/2011:12:41:30 -0500] [Job 361] prnt/hpcups/HPCupsFilter.cpp 418:
m_Job initialization failed with error = 48

means that you don't have the proprietary plugin installed.
Does installing it (hp-plugin command) change anything ?

Comment 5 Rex Dieter 2011-08-26 12:44:40 UTC
Yay, that fixed it!

What a horrible experience to figure that out though  :(

Comment 6 Tim Waugh 2011-08-30 09:43:44 UTC
Yes, it ought not to crash in that situation.  Looks like the constructor doesn't do everything it ought to -- missing a "m_pszInputRasterData=0;" I think.

Comment 7 Fedora Update System 2011-10-04 15:49:44 UTC
hplip-3.11.10-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hplip-3.11.10-1.fc16

Comment 8 Fedora Update System 2011-10-04 15:50:49 UTC
hplip-3.11.10-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/hplip-3.11.10-1.fc15

Comment 9 Fedora Update System 2011-10-04 15:51:27 UTC
hplip-3.11.10-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hplip-3.11.10-1.fc14

Comment 10 Fedora Update System 2011-10-04 20:47:53 UTC
Package hplip-3.11.10-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.11.10-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/hplip-3.11.10-1.fc16
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2011-10-25 03:43:33 UTC
hplip-3.11.10-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-11-10 17:34:26 UTC
hplip-3.11.10-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-11-10 17:50:11 UTC
hplip-3.11.10-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.