Bug 73347 - sendmail init script's make printing warnings at startup
sendmail init script's make printing warnings at startup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 06:21 EDT by Jens Petersen
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 08:50:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2002-09-03 06:21:39 EDT
Description of Problem:
When sendmail is started after a fresh install say, warning messages
appear on the console.

Version-Release number of selected component (if applicable):
8.12.5-7

How Reproducible:
everytime

Steps to Reproduce:
1. do a fresh install
2. # service sendmail restart

Actual Results:
make: *** Warning: File `sendmail.cf' has modification time in the future
(2002-09-04 01:50:59 > 2002-09-03 19:28:57)
make: warning:  Clock skew detected.  Your build may be incomplete.

Expected Results:
No warning message.

Additional Information:
Presumably there is a good reason for sendmail.cf being time stamped in the
future?  Adding a "2> /dev/null" to the make command seems a little dangerous
too, since then genuine errors and warnings will not be shown.
Comment 1 Florian La Roche 2002-12-02 16:19:17 EST
I think this is an installer issue to be resolved within anaconda. At least
discarding all error messages from "make" would be really too much.

greetings,

Florian La Roche
Comment 2 Jeremy Katz 2003-01-02 16:14:32 EST
Fixed in CVS
Comment 3 Jens Petersen 2003-02-21 09:06:20 EST
AFAICR I'm still seeing the warnings in recent trees.
Comment 4 Jeremy Katz 2003-02-27 16:18:27 EST
I've been told by a few people that this looks fixed for them.  Note that we can
only do things "right" with NFS/CD installs (not enough data in the instimage
for the other install types).  Is this different than what you're seeing?
Comment 5 Jens Petersen 2003-02-27 20:16:04 EST
Hmmm, strange, I have been seeing this all along with
standard nfs installs.

My "/etc/sysconfig/clock" contains:

ZONE="Asia/Tokyo"
UTC=false
ARC=false

Does anaconda run in UTC?
Comment 6 Jens Petersen 2004-04-20 08:50:00 EDT
I believe this now fixed, though I don't know how...

Note You need to log in before you can comment on or make changes to this bug.