Bug 733491 - Install failed with error: "There was an error installing the bootloader."
Summary: Install failed with error: "There was an error installing the bootloader."
Keywords:
Status: CLOSED DUPLICATE of bug 727679
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 19:31 UTC by Andrew McNabb
Modified: 2011-08-25 19:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 19:41:45 UTC


Attachments (Terms of Use)
storage.log (83.74 KB, text/plain)
2011-08-25 19:32 UTC, Andrew McNabb
no flags Details
program.log (48.31 KB, text/plain)
2011-08-25 19:32 UTC, Andrew McNabb
no flags Details

Description Andrew McNabb 2011-08-25 19:31:01 UTC
In installing Fedora 16 Alpha, I got the error message: "There was an error installing the bootloader.  The system may not be bootable."

The program.log has some information that might be relevant:

"""
12:54:47,449 ERR program: /usr/sbin/grub2-setup: warn: This GPT partition label has no BIOS Boot Partition; embedding won't be possible!.
12:54:47,451 ERR program: /usr/sbin/grub2-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
12:54:47,452 ERR program: /usr/sbin/grub2-setup: error: will not proceed with blocklists.
"""

I'm a bit surprised that it's saying anything about GPT.  This is a virtual machine, and its disk image was previously initialized with the kickstart commands "zerombr" and "clearpart --linux --drives=vda --initlabel", which I would expect to create an MBR partition table.

Anyway, I will attach some log files that seem like they might be helpful.

Comment 1 Andrew McNabb 2011-08-25 19:32:38 UTC
Created attachment 519969 [details]
storage.log

Comment 2 Andrew McNabb 2011-08-25 19:32:57 UTC
Created attachment 519970 [details]
program.log

Comment 3 David Lehman 2011-08-25 19:41:45 UTC

*** This bug has been marked as a duplicate of bug 727679 ***


Note You need to log in before you can comment on or make changes to this bug.