Bug 7335 - PPP doesn't work in 6.1
PPP doesn't work in 6.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-25 19:13 EST by collin
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-07 10:34:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description collin 1999-11-25 19:13:48 EST
I have installed RedHat 6.1 and all the latest rpms and updates, but PPP
refuses to work for me. Below is a copy of what I get when I "tail -
f /var/log/messages". I 'x'ed' out sensitive information. I need to know
if this bug can be fixed.

Nov 25 15:59:26 wuntang gnome-name-server[529]: name server starting
Nov 25 16:00:05 wuntang ifup-ppp: pppd started for ppp0 on /dev/ttyS2 at
57600
Nov 25 16:00:05 wuntang modprobe: can't locate module char-major-108
Nov 25 16:00:05 wuntang kernel: CSLIP: code copyright 1989 Regents of the
University of California
Nov 25 16:00:05 wuntang kernel: PPP: version 2.3.7 (demand dialling)
Nov 25 16:00:05 wuntang kernel: PPP line discipline registered.
Nov 25 16:00:05 wuntang kernel: registered device ppp0
Nov 25 16:00:05 wuntang pppd[587]: pppd 2.3.10 started by root, uid 0
Nov 25 16:00:07 wuntang WvDial: WvDial: Internet dialer version 1.40
Nov 25 16:00:07 wuntang WvDial: Initializing modem.
Nov 25 16:00:07 wuntang WvDial: Sending: ATZ
Nov 25 16:00:07 wuntang WvDial: ATZ
Nov 25 16:00:07 wuntang WvDial: OK
Nov 25 16:00:07 wuntang WvDial: Sending: ATM1L3
Nov 25 16:00:07 wuntang WvDial: ATM1L3
Nov 25 16:00:07 wuntang WvDial: OK
Nov 25 16:00:07 wuntang WvDial: Modem initialized.
Nov 25 16:00:07 wuntang WvDial: Sending: ATDT xxx-xxxx
Nov 25 16:00:07 wuntang WvDial: Waiting for carrier.
Nov 25 16:00:07 wuntang WvDial: ATDT xxx-xxxx
Nov 25 16:00:35 wuntang WvDial: CONNECT 57600
Nov 25 16:00:35 wuntang WvDial: Carrier detected.  Waiting for prompt.
Nov 25 16:00:36 wuntang WvDial: ** i48-25.pdx.du **
Nov 25 16:00:36 wuntang WvDial: i48-25.pdx.du Login:
Nov 25 16:00:36 wuntang WvDial: Looks like a login prompt.
Nov 25 16:00:36 wuntang WvDial: Sending: xxxxxxx
Nov 25 16:00:36 wuntang WvDial: xxxxxxx
Nov 25 16:00:36 wuntang WvDial: Password:
Nov 25 16:00:36 wuntang WvDial: Looks like a password prompt.
Nov 25 16:00:36 wuntang WvDial: Sending: (password)
Nov 25 16:00:36 wuntang WvDial: enabled
Nov 25 16:00:36 wuntang WvDial:     Entering PPP Mode.
Nov 25 16:00:36 wuntang WvDial:     IP address is xxx.xx.x.xx
Nov 25 16:00:36 wuntang WvDial:     MTU is 1524.
Nov 25 16:00:36 wuntang WvDial: Looks like a welcome message.
Nov 25 16:00:36 wuntang pppd[587]: Serial connection established.
Nov 25 16:00:36 wuntang pppd[587]: Using interface ppp0
Nov 25 16:00:36 wuntang pppd[587]: Connect: ppp0 <--> /dev/ttyS2
Nov 25 16:01:07 wuntang pppd[587]: LCP: timeout sending Config-Requests
Nov 25 16:01:07 wuntang pppd[587]: Connection terminated.
Nov 25 16:01:07 wuntang pppd[587]: Hangup (SIGHUP)
Nov 25 16:01:07 wuntang pppd[587]: Exit.


My ifcfg-ppp0 looks like this:

DEVICE=ppp0
NAME=xxxxxxx
WVDIALSECT=xxxxxxx
MODEMPORT=/dev/ttyS2
LINESPEED=57600
PAPNAME=xxxxxx
USERCTL=true
ONBOOT=no
DNS1=xxx.xxx.xxx.xx
DNS2=xxx.xxx.xxx.xx
PPPOPTIONS=noauth


My wvdial.conf looks like this:

[Modem0]
Modem = /dev/ttyS2
Baud = 57600
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L3

[Dialer Defaults]
Modem = /dev/ttyS2
Baud = 57600
Init1 = ATZ
SetVolume = 1
Dial Command = ATDT
Init4 = ATM1L3

[Dialer Teleport]
Username = xxxxxx
Password = xxxxxx
Modem = /dev/ttyS2
Phone = 972-2800
Baud = 57600
Stupid mode = 0
Inherits = Dialer Defaults



My ISP doesn't use PAP; when I use Windows NT I just send a clear text
password. Please help, I love Linux, but I NEED the internet connection.
Please note that I can actually dial into my ISP and see PPP starting on
the ISP side, but I can't get it started on my side. The dialer keeps
redialing and dieing at the Config-Requests point!!. I have the latest
updates including those put out on 11/23/1999.
Comment 1 Michael K. Johnson 1999-11-30 10:54:59 EST
This does not appear to have anything to do with PAP.

This timeout sending config requests means that the PPP daemon
is unable to negotiate a working PPP connection with the remote
side.  There are all sorts of reasons this could be going wrong.
Try adding the line
DEBUG=yes
to your ifcfg-ppp0 file and see what additional information it
produces.
Comment 2 collin 1999-11-30 19:12:59 EST
Added DEBUG=yes to ifcfg-ppp0 file, and I am getting the following:

Unsupported protocol (0x80fd) received
Comment 3 Michael K. Johnson 1999-12-02 17:26:59 EST
Looks like protocol 0x80fd is unsupported and the other side insists
that it work in order to have a connection.  I don't know what
protocol 0x80fd is, though, so I don't have much idea what to tell
you at this point.
Comment 4 collin 1999-12-02 18:46:59 EST
The unsupported protocol problem only showed once and did not appear ever
again. Now, do I need anything in the /etc/resolv.conf, /etc/hosts.deny,
hosts.allow, /etc/networks files??
Comment 5 Michael K. Johnson 1999-12-02 20:29:59 EST
80fd, it turns out, is compression control protocol, which should be
supported.  Not sure why you got the error message, but glad to know
it isn't a continuing problem.

If you have all the latest errata updates, /etc/resolv.conf will be
updated automatically.  You should not need to set up /etc/sysconfig/network
or the /etc/host.* files to get your PPP connection working.

You are still getting "LCP: timeout sending Config-Requests", right?
Comment 6 collin 1999-12-02 21:42:59 EST
Yep, I am still getting the time-outs. I am going to delete evrything from my
host.* files and see what happens. I also have the following entry in
my /etc/networks file
         loopback    127.0.0.0
         localnet     0.0.0.0

Should I have this? I took this from an old config. manual
Comment 7 Michael K. Johnson 1999-12-03 10:02:59 EST
I really don't think those are related.  I have nothing in /etc/networks
and I haven't touched the hosts.* files, but they really shouldn't have
anything to do with this.  Have you tried lowering your
LINESPEED=57600
to
LINESPEED=38400
to see if that helps?
Comment 8 collin 1999-12-03 11:30:59 EST
I haven't tried lowering my line speed. Does that have anythong to do
with 'pppd' at all or is it just related to the connection? That's about the
only recommended thing I haven't done so far!
Comment 9 Michael K. Johnson 1999-12-03 14:50:59 EST
That changes the speed that ppp sets the modem to before connecting.
Please try it.
Comment 10 collin 1999-12-06 11:14:59 EST
I lowered my modem speed, LINESPEED=38400, but the same thing happened. At this
point, I am really baffled. I am just gonna go back to RedHat 6.0. What's the
significance of LCP?
Comment 11 Michael K. Johnson 1999-12-06 15:23:59 EST
LCP is the link control protocol; it's one of the base protocols
that pppd uses to set up other PPP protocols.  It isn't totally
broken -- if it were, then no one would be able to connect via
PPP at all.

One other thing that has caused this problem in the past is a
modem with misconfigured interrupts.  If Linux is misinformed
about what interrupt the modem is on, it will default to polled
mode, and that goes slowly -- too slowly for LCP to work.  Are
your kernel messages at boot time about what IRQ it is using
for ttyS2 correct?  Is it a different IRQ from ttyS0?  (It needs
to be different.)
Comment 12 collin 1999-12-06 18:44:59 EST
That could be it. When I use RP3 to detect the modem, it looks like it finds
something on /dev/ttyS0 (says determining modem type, etc,etc) then comes back
and says no modem detected.
Also, I have an /etc/rc.d/rc.serial with the following command:
       setserial /dev/ttyS2 auto_irq autoconfig skip_test uart 16450


Do I need this command? Another thing, how do I set up the irq for /dev/ttyS2
to be different from /dev/ttyS0 's irq? I know pppd is not broken at all; I
have a Compaq Netelligent plug and play modem.
Comment 13 Michael K. Johnson 1999-12-07 10:34:59 EST
Oooh, a 16450 uart can't handle PPP very well at speeds that are at
all high, particularly if you have IDE hard drives.

plug and play modems are often unsupported "winmodems"; you are sure
that this is not the case?

Try using the isapnp program to set the IRQ for that modem to something
that is not used anywhere on the system, and particularly neither 3 nor
4 (the common ttyS{0,1} IRQs.

In any case, this does not sound like a bug, it sounds like a hardware
configuration issue, so I've marked it as not a bug.
Comment 14 collin 1999-12-28 13:58:59 EST
How do I set up ppp to work with MSCHAP? Do I need to recompile the PPP
packages or is MSCHAP compiled in? I found out my ISP uses an NT server and I
might require MSCHAP.
Comment 15 Nalin Dahyabhai 2000-01-17 09:59:59 EST
Our ppp package does not currently include MSCHAP support because MSCHAP
requires DES encryption, which historically we have not been able to legally
export.  The README.MSCHAP80 file in the ppp source package includes information
on rebuilding pppd with MSCHAP support.

However, before you go to the trouble, I'd suggest asking your ISP to enable
normal CHAP authentication.  If they refuse and you have other options, you
may wish to take your business elsewhere.

Note You need to log in before you can comment on or make changes to this bug.