Bug 73350 - Slow DNS lookups for some sites
Summary: Slow DNS lookups for some sites
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: apr (Show other bugs)
(Show other bugs)
Version: alpha 1
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-03 11:21 UTC by Joe Orton
Modified: 2007-03-27 03:56 UTC (History)
0 users

Fixed In Version: 0.9.3-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 14:46:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2002-09-03 11:21:42 UTC
Description of Problem:
By default, since RHL is an IPv6-capable system, APR passes AF_UNSPEC in the
getaddrinfo hints.  For some sites, the DNS queries for the AAAA record
generated by getaddrinfo() are ignored and get no responses; this can be seen on
www.bloomberg.com, for instance, resulting in retries and timeouts before the A
record is attempted.

Version-Release number of selected component (if applicable):
httpd-2.0.40-6

How Reproducible:
Always

Steps to Reproduce:
1. Add "ProxyRequests On" to default config + LoadModule lines for proxy
2. Configure browser to use server as proxy
3. Go to www.bloomberg.com

Actual Results:
Page is very slow to load

Expected Results:
Page is fast to load, as can be seen when not using the proxy

Additional Information:
Daniel Stenberg (of curl fame) has a tip on how to avoid this: if
socket(AF_INET6, ...) fails, then just pass AF_INET in the getaddrinfo
hints rather than AF_UNSPEC, since the IPv6 module is not loaded.

Comment 1 Joe Orton 2003-06-10 08:39:00 UTC
A proper solution for this is possible in modern glibc; passing AI_ADDRCONFIG in
the getaddrinfo hints.


Note You need to log in before you can comment on or make changes to this bug.