Bug 733534 - Workbench no longer displays dialogs
Summary: Workbench no longer displays dialogs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql-workbench
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 22:40 UTC by Juan Manuel Rodriguez
Modified: 2011-10-04 21:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 17:00:37 UTC


Attachments (Terms of Use)

Description Juan Manuel Rodriguez 2011-08-25 22:40:37 UTC
Description of problem:
Whenever I try to create new schema or alter or create new tables, a window shows up but doesn't fully load. 

Upon debugging, I found this line on the terminal:

(mysql-workbench-bin:2038): Gtk-WARNING **: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead

I'm guessing it's related to the new GTK version in Fedora 16. (Is mysql-workbench using gtk3?)

Version-Release number of selected component (if applicable):
mysql-workbench-5.2.34-1.fc16.x86_64
gtk2-2.24.5-1.fc16.x86_64
gtk3-3.1.12-1.fc16.x86_64

How reproducible:
Very.

Steps to Reproduce:
1. Fire up Workbench
2. Try to alter a table, create a new table or anything
  
Actual results:
Empty popup

Expected results:
A happy alter table window

Additional info:
I can still type commands and run them as usual, but if I knew all the syntax by heart I wouldn't really be needing Workbench, would I? ;)

It's worth saying I'm on KDE, but I'm pretty sure this would affect Gnome too.

Comment 1 Juan Manuel Rodriguez 2011-08-25 22:43:36 UTC
I grepped the source code for mysql-workbench (I kinda need this fixed soon),  
Found this:

grep -r "gtk_scroll" . | more
./ext/scintilla/gtk/PlatGTK.cxx:        scroller = gtk_scrolled_window_new(NULL, NULL);
./ext/scintilla/gtk/PlatGTK.cxx:        gtk_scrolled_window_set_policy(GTK_SCROLLED_WINDOW(scroller),

So, line 1980 on ext/scintilla/gtk/PlatGTK.cxx might be the problem. I'll investigate and try to patch it and will reply if my solution works.

Comment 2 Remi Collet 2011-10-04 17:00:37 UTC
Not able to reproduce.

As version 5.2.35 is now available, I close this one.

Comment 3 Juan Manuel Rodriguez 2011-10-04 21:00:45 UTC
Actually, it was magically fixed. I do have 5.2.35 now and it seems to be working now that you mention it. 

I'm not sure if it was fixed in mysql or in gtk2/3 but it works now :-)


Note You need to log in before you can comment on or make changes to this bug.