Bug 733542 - [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/lima_5ftoni_40hotmail_2ecom at 0xa05ebcc>
Summary: [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError...
Keywords:
Status: CLOSED DUPLICATE of bug 691209
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:388ea7b8762b670d1188fe032aa...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 23:31 UTC by António Lima
Modified: 2011-11-20 14:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-20 14:38:59 UTC


Attachments (Terms of Use)

Description António Lima 2011-08-25 23:31:52 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
component:      telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         2.6.40-4.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        telepathy-butterfly-0.5.15-3.fc15
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/lima_5ftoni_40hotmail_2ecom at 0xa05ebcc>
time:           Thu Aug 25 23:25:50 2011
uid:            500
username:       amrlima

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/lima_5ftoni_40hotmail_2ecom at 0xa05ebcc>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 425, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/lima_5ftoni_40hotmail_2ecom at 0xa05ebcc>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0xa05e78c>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/lima_5ftoni_40hotmail_2ecom at 0xa05ebcc>

comment:
:This problem happens when I have empathy running and I loose internet connection.
:I can reproduce the crash since it happens very often

Comment 1 Brian Pepple 2011-11-20 14:38:59 UTC

*** This bug has been marked as a duplicate of bug 691209 ***


Note You need to log in before you can comment on or make changes to this bug.