Bug 73357 - gdmsetup dont ask for root password
gdmsetup dont ask for root password
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 09:27 EDT by Dams
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-03 03:45:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2002-09-03 09:27:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
gdmsetup dont ask for root password and complain it must be launched as root. As
this can be handled with a sudo or su -c, in the "systeme settings" nautilus
screen this cannot be workarounded.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. double click on the start-here icon.
2. double click on the system settings icon
3. double click on the login screen 
	

Actual Results:  a pop-up error window : You must be the superuser (root) to
configure GDM.


Expected Results:  A pop-up window should ask the root password like other icon
in the system settings nautilus screen ask....

Additional info:
Comment 1 Havoc Pennington 2002-09-03 10:44:58 EDT
which version of gdm?
Comment 2 Dams 2002-09-03 10:46:27 EDT
[dnade@enclume ~]# rpm -q gdm                                                  
                   gdm-2.4.0.7-6

:)
Comment 3 Havoc Pennington 2002-09-25 15:12:44 EDT
This should be fixed in the final release.
Comment 4 Dams 2002-09-30 11:24:24 EDT
Not really fixed... 
It still complains you must be root and dont ask the root password.
Comment 5 Mike McLean 2002-10-01 10:39:38 EDT
I am sitting at a 8.0 box right now and I'm not able to reproduce this bug.  

Is there anything unusual about your setup?
Comment 6 Dams 2002-10-01 10:44:51 EDT
as u user, a popup window says "You must be the superuser (root) to configure
GDM." instead of asking for the root password like other things (like "security
level" or "soundcard detection" do..)
There is really nothing unusual in my setup.
Comment 7 Mike McLean 2002-10-02 14:31:48 EDT
You implied that you were still seeing this bug in 8.0.  Did you install 8.0
fresh or did you upgrade (if so, from what)?

Could you give me the output of the following commands
% rpm -q usermode gdm
% rpm -V usermode gdm
% ls -l /usr/bin/gdmsetup

Could you run /usr/bin/gdmsetup from a terminal (in X) and see what happens?
Comment 8 Dams 2002-10-03 03:33:27 EDT
Psyche fresh install.

[dnade@enclume ~]# rpm -q usermode gdm
usermode-1.63-1
gdm-2.4.0.7-13
[dnade@enclume ~]# rpm -V usermode gdm
..?.....   /usr/sbin/userhelper
..5....T c /etc/X11/gdm/gdm.conf
zsh: exit 2     rpm -V usermode gdm
[dnade@enclume ~]# ls -l =gdmsetup
-rwxr-xr-x    1 root     root        74646 Sep  6 04:23 /usr/sbin/gdmsetup
Comment 9 Dams 2002-10-03 03:44:55 EDT
Okay ! I understand all ! as you can see in my previous message the first
gdmsetup in my $PATH is the /usr/sbin/gdmsetup not the /usr/bin/gdmsetup ! I
will change the order of the directories in my environment.
We can close this bug with a NOTABUG, but can you do something against this
behaviour ? I mean, there is surely a way to workaround the fact that the
/usr/sbin is before /usr/bin in the $PATH of a user...
Comment 10 Havoc Pennington 2002-10-03 09:36:34 EDT
That's the whole way the stuff works though, it's all based on the /usr/bin
links... I don't remember the rationale but there is some reason for it (I think
so root account works properly)

Note You need to log in before you can comment on or make changes to this bug.