Bug 733577 - Rework profiling for DocBook 5
Rework profiling for DocBook 5
Status: CLOSED DUPLICATE of bug 919486
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-26 01:21 EDT by Jeff Fearn
Modified: 2013-07-18 03:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 03:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2011-08-26 01:21:26 EDT
Description of problem:
Attribute changes in DocBook 5 require reworking the profiling code.

Currently profiling can be done on lang, arch, or condition, for DB5 we should support all the "effectivity" attributes

See http://www.docbook.org/tdg5/en/html/ref-elements.html#common.effectivity.attributes

replace contion.arch/lang with a new parameter, 'profiliing' that accepts attribute=value pairs.

e.g.

profiling: "condition=enterprise arch=x86_64"

Consider allowing multiples.

e.g.

profiling: "condition=enterprise arch=x86_64 arch=ia64"

Consider allowing boolean logic.

e.g.

profiling: "condition=enterprise&sme arch=x86_64|ia64"
Comment 1 Jeff Fearn 2013-07-18 03:56:42 EDT

*** This bug has been marked as a duplicate of bug 919486 ***

Note You need to log in before you can comment on or make changes to this bug.