This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 733613 - Add button got disabled, if user cancel the drift creation
Add button got disabled, if user cancel the drift creation
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity medium (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-26 05:20 EDT by Venkat
Modified: 2012-02-07 14:28 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:28:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot_drift (100.71 KB, image/png)
2011-08-26 05:20 EDT, Venkat
no flags Details
ImportButtonIssue (170.33 KB, image/png)
2011-08-29 06:44 EDT, Venkat
no flags Details

  None (edit)
Description Venkat 2011-08-26 05:20:57 EDT
Created attachment 520044 [details]
screenshot_drift

Description of problem:
while creating the drift, if user hits cancel button in between ( while creating) "Add" button got disabled.

Please refer the screen shot attached herewith.

Version-Release number of selected component (if applicable):
RHQ
Version: 4.1.0-SNAPSHOT
Build Number: 3003087


How reproducible:
Every time 

Steps to Reproduce:
1.Login into RHQ
2.Navigate to 'Drift->Configuration' tab of a platform resource and click on Add button.
3.Click on the 'Cancel' button.


  
Actual results:
Add button is disabled.

Expected results:
Add button should be enabled.


Additional info:
If user is goes to another tab or  leaves that UI and come back to that "configuration" tab or by refreshing the page, then that Add button will be enabled.
Comment 1 Venkat 2011-08-29 06:44:01 EDT
Created attachment 520341 [details]
ImportButtonIssue
Comment 2 Venkat 2011-08-29 06:45:32 EDT
Similar kind of issues found at  several places where user is dealing with following actions.
Create Child----> and cancel 
import resource --- and cancel 

While doing this following buttons are getting disabled 
Delete, Import, Create child, Uninventory, Refresh.

Please refer the attached screenshot.
Comment 3 Jay Shaughnessy 2011-08-30 08:59:13 EDT
Was this always like this?  I think something changed. Looking at this...  Something to do with wizards exiting.
Comment 4 Jay Shaughnessy 2011-08-30 09:39:33 EDT
This looks like a regression due to the new Table footer control
disablement put in place to prevent subsequent button clicks while a
button action is already executing.  

The problem is that that each button action is now responsible for
refreshing the encompassing view when the button action is complete. In
other words, the wizards now need to, on cancel/completion, ensure a
table refresh.  Most button actions already are doing this but
certain code paths, like wizard cancel, need to handle this situation.


Looking at fix solution...
Comment 5 Jay Shaughnessy 2011-08-30 13:31:04 EDT
master commit 85882c6e0e00d5d788032d9c4192577c21e4fcc6

Regression due to new footer disablement in Table, on footer action. The
footer actions are now responsible for footer re-enablement upon action
completion (or as soon as it is safe). This commit fixes various instances
of the problem when canceling out of wizards. At the moment there are
no other known occurrences since most actions do perform some sort of
Table refresh on completion.

Test Notes: Fixed for Group creation, Drift config creation, Child resource create
and import, bundle creation wizards.
Comment 6 Venkat 2011-08-31 05:34:26 EDT
I verified buttons which are associated with wizard cancel/completion actions which does table refresh. Now I'm seeing buttons are getting enabled properly.

I had tested according to test note , and all are working fine.

Verified on this following build 
RHQ
Version: 4.1.0-SNAPSHOT
Build Number: 044113e
Comment 8 Mike Foley 2012-02-07 14:28:53 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.