Bug 73363 - Running Loki Installer under Null as guest in VMware Workstation 3.1 can freeze host
Running Loki Installer under Null as guest in VMware Workstation 3.1 can free...
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 11:01 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 14:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-03 11:01:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
When I run Red Hat Linux Beta Null in the VMware Workstation 3.1, and then start
the Loki Installer of the Loki Software's game "Sid Meier's Alpha Centauri",
either of the full version or the demo (that came along with Red Hat Linux 7.0),
the host system freezes.

Version-Release number of selected component (if applicable):
kernel 2.4.18-11, glibc 2.2.90-24

How reproducible:
Always

Steps to Reproduce:
1. Install VMware Workstation 3.1.1-1790
2. Install Red Hat Linux Beta Null as guest
3. E. g. insert and mount the Loki Demo CD that came along with Red Hat Linux
7.0 and install /mnt/cdrom/smacx-demo-x86.run, or alternatively, the
corresponding setup script if the full version CD is available.


Actual Results:  The host operating system freezes. The mouse pointer does not
move and Ctrl-Alt-Fx do not work.

This happens even if VMware Workstation runs under a virtual frame buffer X
server and is being used by VNC. Therefore, the actual host freezes and not just
the X server.

Expected Results:  The text mode Loki Installer of the demo version, or the
graphical installer of the full version comes up.

Additional info:

This problem never occured in any previous Linux that I used under VMware (even
recent ones, like SuSE Linux 8.0) and seems to be specific to the Beta Null.

The host operating system is Red Hat Linux 7.2 with SGI XFS kernel (kernel
version 2.4.9-31SGI_XFS_1.1, glibc version 2.2.4-29, VMware Workstation version
3.1.1-1790).

I am really not sure which component should be attributed to. This problem could
also be related to the glibc component.
Comment 1 Arjan van de Ven 2002-09-03 11:05:04 EDT
How about reporting this bug to SGI since it's their kernel that crashes
Comment 2 Need Real Name 2002-09-03 11:42:24 EDT
I do not think that this is specific to the SGI kernel. I will try to run it on
a stock Red Hat kernel.
Comment 3 Arjan van de Ven 2002-09-03 11:46:51 EDT
I'm not sure that's useful; kernels with the vmware modules loaded I can't do a
lot with generally.
Comment 4 Need Real Name 2002-09-03 11:53:37 EDT
The problem is that the Red Hat Linux Beta is the changing variable. As I have
noted before, other Linux distributions that I ran as guest never exhibited such
a behavior.
Comment 5 Need Real Name 2002-09-03 14:28:49 EDT
I have now checked the problem with a stock Red Hat Linux Beta Null as host. To
my surprise, the problem seems to be disappeared. Also with the NVIDIA kernel
module loaded, the lockup cannot be reproduced.

However, since I also have the OSS modules from 4Front Technologies loaded in my
Red Hat Linux 7.2 host (which produces the lockup) and there seems to be
problems to get their modules run under a GCC 3 compiled kernel, I cannot tell
whether SGI or 4Front Tech. is acutally to blame for the lockup. But since this
is certainly not a problem caused by Red Hat software, I think we can close the
report. Sorry for any inconveniences.

Note You need to log in before you can comment on or make changes to this bug.