Bug 73364 - Gnome-terminal dont select/copy/paste well a more-than-one-line selection
Summary: Gnome-terminal dont select/copy/paste well a more-than-one-line selection
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: vte   
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-09-03 15:07 UTC by Dams
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 18:53:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dams 2002-09-03 15:07:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When I select more than one line in my gnome-terminal, the pasting is not always
well done : I got all the content but not with the same number of line.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Open a gnome-terminal
2. rpm -q glibc
3. You should have 3 lines like that : 

[dnade@enclume]# rpm -q glibc
glibc-2.2.92-2
[dnade@enclume]#

Select those 3 lines.
You may Copy it using the S-C-c shortcut (clipboard stuff...)
4. open another gnome-terminal, and do "cat > /dev/null"
5. Paste the mouse selection with middle button or with the clipboard stuff
(shortcut S-C-v).

Actual Results:  This is what i got when I paste the clipboard (mouse selection
is the same..)

[dnade@enclume]# rpm -q glibc                             glibc-2.2.92-2
[dnade@enclume]#

Expected Results:  I should have something like this
[dnade@enclume]# rpm -q glibc
glibc-2.2.92-2
[dnade@enclume]#

Additional info:

I tried to paste the mouse selection in my emacs and i got the same result.

Comment 1 Havoc Pennington 2002-09-03 22:36:55 UTC
Nalin this may turn out to only happen in very specific cases but may be a big
issue so marking as such initially.

Comment 2 Dax Kelson 2002-09-05 07:17:24 UTC
This seems like a BIG issue. :) 
 
My notes: 
 
I open a GNOME2 terminal and ssh from my Null box to a Red Hat 7.2 
machine. 
 
On that 7.2 machine I run vim /tmp/foo.txt. I select some text (say 
contents of httpd.conf) and paste into the vim running on the 7.2 
machine. 
 
PROBLEM: Although it appears to have pasted properly, all \n's are gone. 
There are no new line characters. 


Comment 3 Nalin Dahyabhai 2002-09-05 18:52:59 UTC
This should be fixed in 0.8.14 and later.  Please grab the vte package from Raw
Hide, close all of your terminals, and give it another go.

Comment 4 Ben Levenson 2002-09-05 19:19:37 UTC
appears to be fixed. verified w/ vte-0.8.17-1.
Closing -> RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.