Bug 73369 - dhclient fails when IP was not released before
dhclient fails when IP was not released before
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Depends On:
  Show dependency treegraph
Reported: 2002-09-03 11:55 EDT by Hans Schippers
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-10 19:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hans Schippers 2002-09-03 11:55:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
when the IP was not released last time (eg reboot from windows, or get IP with dhcpcd, and do killall -15 dhcpcd), then dhclient will fail to get IP information (seems to send DHCPDISCOVER packets, but concludes in the end that no DHCPOFFER was made).
dhcpcd does not suffer from this problem

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1./sbin/service network stop
2./sbin/dhcpcd eth0
3.killall -15 dhcpcd
4./sbin/service network start

Actual Results:  determining ip information... failed

Expected Results:  eth0 succesfully configured with IP address...

Additional info:

I get this in /var/log/messages:

Sep  3 17:39:06 saintpc dhclient: DHCPREQUEST on eth0 to port 67
Sep  3 17:39:06 saintpc dhclient: DHCPNAK from
Sep  3 17:39:06 saintpc dhclient: DHCPDISCOVER on eth0 to port 6
7 interval 8
Sep  3 17:39:07 saintpc su(pam_unix)[1671]: session opened for user root by sain
Sep  3 17:39:14 saintpc dhclient: DHCPDISCOVER on eth0 to port 6
7 interval 13
Sep  3 17:39:27 saintpc dhclient: DHCPDISCOVER on eth0 to port 6
7 interval 8
Sep  3 17:39:35 saintpc dhclient: DHCPDISCOVER on eth0 to port 6
7 interval 11
Sep  3 17:39:46 saintpc dhclient: DHCPDISCOVER on eth0 to port 6
7 interval 11
Sep  3 17:39:57 saintpc dhclient: DHCPDISCOVER on eth0 to port 6
7 interval 10
Sep  3 17:40:07 saintpc dhclient: No DHCPOFFERS received.
Comment 1 Yves Cluckers 2002-11-28 16:51:59 EST
I had the exact same problem connecting to Internet with RH 8.0 after a Win2K boot.
I removed dhclient and installed dhcpcd, ifdown eth0, ifup eth0 and the problem
was solved.
Comment 2 Christopher Hyatt 2002-12-12 09:33:02 EST
I have an opposite problem. I can get an IP address (from Time Warner 
Roadrunner cable servers) during boot only if I first log into Win2K and then 
into Linux. If I reboot into Linux after shutting down from Linux, I can't get 
an IP during boot. However, I can get an IP by manually running dhclient eth0 
from the terminal. 

The IP address I'm assigned using Win2K always has the form 24.24.xxx.xxx. In 
fact, my IP address has never changed in over a year (it IS a dynamic IP 
though). In Linux, I get 24.92.xxx.xxx. Not really a bug, because I'm 
connected, but it's strange that it's not the same IP address as in Win2K.
Comment 3 Christopher Hyatt 2002-12-12 09:34:49 EST
I will trying uninstalling dhclient and installing dhcpd, ifup and ifdown and 
see if that works.
Comment 4 Dennis Björklund 2002-12-29 01:04:01 EST
I have a similar problem when trying to connect to Telia ADSL, the biggest ISP
of sweden. Even though the computer was closed down correctly sometimes when it
is started again it does not work and it ends with "No DHCPOFFERS received". And
this computer only runs linux.

I've been searching the net and it seems more people have problems with telia
and dhclient. That makes this into a big problem in sweden where most people use

Here is one such report from debian (in swedish, but the log output is readable):


where the problem is also solved by going back to dhcpcd. I've seen a number of
more reports about telia and dhclient in swedish mailinglist that I think is
because of this bug.
Comment 5 Daniel Walsh 2003-01-24 15:19:57 EST
This looks like the server is not returning a DHCP address.  Possibly dhclient
is not asking correctly. Could you grab a tcpdump/ethereal of doing this with
dhclient and dhcpd to see if they ask differently?
Comment 6 Jason Vas Dias 2004-08-10 19:54:31 EDT
Clearing out old bugs here.
This does not happen with modern dhclient (dhcp-3.0.1+) -
or at least I cannot reproduce it -

1./sbin/service network stop
2.dhclient eth0
3.killall -15 dhclient
4./sbin/service network start

Works fine for me.

If anyone finds this is still a problem, please do the following:
$ pkill -TERM dhclient
$ tcpdump -vv -i eth0 > /tmp/tcpdump.log 2>&1 &
$ dhclient eth0 
$ pkill tcpdump

And attach the resulting /tmp/tcpdump log to this bug.

Note You need to log in before you can comment on or make changes to this bug.