This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 733697 - Service restart needlessly reports failure
Service restart needlessly reports failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie (Show other bugs)
6.1
All All
unspecified Severity low
: rc
: ---
Assigned To: Marcela Mašláňová
qe-baseos-daemons
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-26 10:27 EDT by Petr Šabata
Modified: 2016-03-01 09:40 EST (History)
4 users (show)

See Also:
Fixed In Version: cronie-1.4.4-9.el6
Doc Type: Bug Fix
Doc Text:
Cause: Restart definition in init file was incorrect. Consequence: Restart reported failure. Fix: Define restart in init file properly. Result: Restart is working flawlesly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:23:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't report a misleading failure on restart (175 bytes, patch)
2011-08-26 10:29 EDT, Petr Šabata
no flags Details | Diff

  None (edit)
Description Petr Šabata 2011-08-26 10:27:54 EDT
Description of problem:
Restarting the crond service needlessly reports failure if the service wasn't running before.

Version-Release number of selected component (if applicable):
cronie-1.4.4-7.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Make sure crond isn't running
2. service crond restart
  
Actual results:
# service crond restart
Stopping crond: [FAILED]
Starting crond: [  OK  ]

Expected results:
# service crond restart
Starting crond: [  OK  ]

Additional info:
Restarting a stopped service should just start it without making an impression of something failing.
Comment 1 Petr Šabata 2011-08-26 10:29:12 EDT
Created attachment 520101 [details]
Don't report a misleading failure on restart
Comment 11 Jakub Prokes 2013-09-25 05:51:53 EDT
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: BZ#733697 - Service restart needlessly reports failure
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Starting crond: [  OK  ]
:: [ 05:49:43 ] :: [ INFO    ] :: rlRun: command = 'service crond restart'; exitcode = 0; expected = 0
:: [   PASS   ] :: Running 'service crond restart' (Expected 0, got 0)
:: [   PASS   ] :: File '/var/tmp/tmp.y162y8Ozf2' should not contain 'FAILED':: :: [   LOG    ] :: Duration: 1s
:: [   LOG    ] :: Assertions: 2 good, 0 bad
:: [   PASS   ] :: RESULT: BZ#733697 - Service restart needlessly reports failure
Comment 12 errata-xmlrpc 2013-11-21 17:23:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1681.html

Note You need to log in before you can comment on or make changes to this bug.