Bug 733706 - FIXED_IN_GIT: There was an error configuring your network interface
FIXED_IN_GIT: There was an error configuring your network interface
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
ppc64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker F16Blockerppc
  Show dependency treegraph
 
Reported: 2011-08-26 10:45 EDT by Mark Hamzy
Modified: 2012-03-14 09:10 EDT (History)
10 users (show)

See Also:
Fixed In Version: systemd-35-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-09 13:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2011-08-26 10:45:50 EDT
Description of problem:
Booting Fedora-20110825-ppc64-netinst-respin.iso with the following options

boot: linux vnc=1 serial

I get the following text dialog box:
    There was an error configuring your network interface

I can configure the network manually from the command line by booting with rd.break.  Networking works and I can ssh into the box.

I see the following in the syslog:

14:30:14,0 NOTICE dbus: [system] Activating via systemd: service name='org.freedesktop.NetworkManager' unit='dbus-org.freedesktop.NetworkManager.service'
14:30:14,0 INFO NetworkManager: <info> NetworkManager (version 0.8.9997-7.git20110721.fc16) is starting...
14:30:14,0 INFO NetworkManager: <info> Read config file /etc/NetworkManager/NetworkManager.conf
14:30:14,0 NOTICE dbus: [system] Activating service name='org.freedesktop.PolicyKit1' (using servicehelper)
14:30:14,0 INFO polkitd: started daemon version 0.101 using authority implementation `local' version `0.101'
14:30:14,0 NOTICE dbus: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: Acquired D-Bus service com.redhat.ifcfgrh1
14:30:14,0 INFO NetworkManager: <info> Loaded plugin ifcfg-rh: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
14:30:14,0 INFO NetworkManager: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh:     read connection 'System eth0'
14:30:14,0 INFO NetworkManager: <info> trying to start the modem manager...
14:30:14,0 NOTICE dbus: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
14:30:14,0 INFO NetworkManager: <info> monitoring kernel firmware directory '/lib/firmware'.
14:30:14,0 NOTICE dbus: [system] Successfully activated service 'org.freedesktop.NetworkManager'
14:30:14,0 INFO NetworkManager: <info> WiFi enabled by radio killswitch; enabled by state file
14:30:14,0 INFO NetworkManager: <info> WWAN enabled by radio killswitch; enabled by state file
14:30:14,0 INFO NetworkManager: <info> WiMAX enabled by radio killswitch; enabled by state file
14:30:14,0 INFO NetworkManager: <info> Networking is enabled by state file
14:30:14,0 INFO NetworkManager: <info> Setting system hostname to 'bluebill' (from system configuration)
14:30:14,0 NOTICE dbus: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
14:30:14,0 NOTICE dbus: [system] Activated service 'org.freedesktop.ModemManager' failed: Cannot launch daemon, file not found or permissions invalid
14:30:14,0 ERR NetworkManager: <error> [1314369014.465614] [nm-device-ethernet.c:751] real_update_permanent_hw_address(): (eth0): unable to read permanent MAC address (error 0)
14:30:14,0 INFO NetworkManager: <info> (eth0): carrier is ON
14:30:14,0 INFO NetworkManager: <info> (eth0): new Ethernet device (driver: 'ibmveth' ifindex: 2)
14:30:14,0 INFO NetworkManager: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
14:30:14,0 INFO NetworkManager: <info> (eth0): now managed
14:30:14,0 INFO NetworkManager: <info> (eth0): device state change: unmanaged -> unavailable (reason 'connection-assumed') [10 20 41]
14:30:14,0 INFO NetworkManager: <info> (eth0): preparing device.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) starting connection 'System eth0'
14:30:14,0 INFO NetworkManager: <info> (eth0): device state change: unavailable -> ip-config (reason 'none') [20 70 0]
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
14:30:14,0 WARNING NetworkManager: <warn> bluez error getting default adapter: The name org.bluez was not provided by any .service files
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 4 of 5 (IP4 Configure Get) scheduled...
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Beginning IP6 addrconf.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 4 of 5 (IP4 Configure Get) started...
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 4 of 5 (IP4 Configure Get) complete.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 4 of 5 (IP6 Configure Get) scheduled...
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 4 of 5 (IP6 Configure Get) started...
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 5 of 5 (IP Configure Commit) scheduled...
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 4 of 5 (IP6 Configure Get) complete.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 5 of 5 (IP Configure Commit) started...
14:30:14,0 INFO NetworkManager: <info> (eth0): device state change: ip-config -> activated (reason 'none') [70 100 0]
14:30:14,0 INFO NetworkManager: <info> Policy set 'System eth0' (eth0) as default for IPv4 routing and DNS.
14:30:14,0 INFO NetworkManager: <info> Policy set 'System eth0' (eth0) as default for IPv6 routing and DNS.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) successful, device activated.
14:30:14,0 INFO NetworkManager: <info> Activation (eth0) Stage 5 of 5 (IP Configure Commit) complete.
14:30:14,0 NOTICE dbus: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
14:30:14,0 WARNING nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/00-netreport' exited with error status 1.
14:30:14,0 WARNING nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/00-netreport' exited with error status 1.
14:30:14,0 INFO NetworkManager: <info> caught signal 15, shutting down normally.
14:30:14,0 WARNING NetworkManager: <warn> quit request received, terminating...
14:30:14,0 INFO NetworkManager: <info> exiting (success)
14:30:14,0 INFO NetworkManager: <info> NetworkManager (version 0.8.9997-7.git20110721.fc16) is starting...
14:30:14,0 INFO NetworkManager: <info> Read config file /etc/NetworkManager/NetworkManager.conf
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: Acquired D-Bus service com.redhat.ifcfgrh1
14:30:14,0 INFO NetworkManager: <info> Loaded plugin ifcfg-rh: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
14:30:14,0 INFO NetworkManager: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh:     read connection 'System eth0'
14:30:14,0 NOTICE NetworkManager:    ifcfg-rh: Ignoring connection 'System eth0' and its device due to NM_CONTROLLED/BRIDGE/VLAN.
14:30:14,0 INFO NetworkManager: <info> trying to start the modem manager...
14:30:14,0 NOTICE dbus: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
14:30:14,0 INFO NetworkManager: <info> monitoring kernel firmware directory '/lib/firmware'.
14:30:14,0 INFO NetworkManager: <info> WiFi enabled by radio killswitch; enabled by state file
14:30:14,0 INFO NetworkManager: <info> WWAN enabled by radio killswitch; enabled by state file
14:30:14,0 INFO NetworkManager: <info> WiMAX enabled by radio killswitch; enabled by state file
14:30:14,0 INFO NetworkManager: <info> Networking is enabled by state file
14:30:14,0 ERR NetworkManager: <error> [1314369014.794890] [nm-device-ethernet.c:751] real_update_permanent_hw_address(): (eth0): unable to read permanent MAC address (error 0)
14:30:14,0 NOTICE dbus: [system] Activated service 'org.freedesktop.ModemManager' failed: Cannot launch daemon, file not found or permissions invalid
14:30:14,0 INFO NetworkManager: <info> (eth0): carrier is ON
14:30:14,0 INFO NetworkManager: <info> (eth0): new Ethernet device (driver: 'ibmveth' ifindex: 2)
14:30:14,0 INFO NetworkManager: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
14:30:14,0 WARNING NetworkManager: <warn> bluez error getting default adapter: The name org.bluez was not provided by any .service files
14:32:15,0 NOTICE dbus: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
14:32:15,0 NOTICE dbus: [system] Activated service 'org.freedesktop.ModemManager' failed: Cannot launch daemon, file not found or permissions invalid
14:34:15,0 NOTICE dbus: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
14:34:15,0 NOTICE dbus: [system] Activated service 'org.freedesktop.ModemManager' failed: Cannot launch daemon, file not found or permissions invalid
14:36:15,0 NOTICE dbus: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
14:36:15,0 NOTICE dbus: [system] Activated service 'org.freedesktop.ModemManager' failed: Cannot launch daemon, file not found or permissions invalid
Comment 1 Mark Hamzy 2011-08-30 10:13:27 EDT
bash-4.2# gdb /mnt/LiveOs/bin/systemd
...
Core was generated by `/sbin/init '.
Program terminated with signal 6, Aborted.
#0  0x00000fff8b6d24a0 in raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
42                               sig);
Missing separate debuginfos, use: debuginfo-install pam-1.1.4-3.fc16.ppc64
(gdb) bt
#0  0x00000fff8b6d24a0 in raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
#1  0x000000001000b880 in crash (sig=<optimized out>) at src/main.c:121
#2  <signal handler called>
#3  0x00000fff8b4665ac in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#4  0x00000fff8b468318 in __GI_abort () at abort.c:93
#5  0x00000fff8b7416d0 in _dbus_abort () at dbus-sysdeps.c:94
#6  0x00000fff8b734c24 in _dbus_warn_check_failed (
    format=0xfff8b748008 "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line %d.\nThis is normally a bug in some application using the D-Bus library.\n") at dbus-internals.c:289
#7  0x00000fff8b722c3c in dbus_message_iter_append_basic (value=0x1001faf1730, type=98, iter=0xfffe313b380) at dbus-message.c:2541
#8  dbus_message_iter_append_basic (iter=0xfffe313b380, type=<optimized out>, value=0x1001faf1730) at dbus-message.c:2506
#9  0x000000001004c884 in bus_execute_append_command (i=0xfffe313b5a8, property=<optimized out>, data=<optimized out>)
    at src/dbus-execute.c:336
#10 0x000000001005751c in bus_default_message_handler (c=0x1001fad2160, message=0x1001fad6390,
    introspection=0x10095098 "<!DOCTYPE node PUBLIC \"-//freedesktop//DTD D-BUS Object Introspection 1.0//EN\"\n\"http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd\">\n<node>\n <interface name=\"org.freedesktop.systemd1.Unit\">\n"...,
    interfaces=<optimized out>, properties=0xfffe313b6e0) at src/dbus-common.c:362
#11 0x0000000010045cc0 in bus_service_message_handler (u=0x1001faf10f0, connection=0x1001fad2160, message=0x1001fad6390)
    at src/dbus-service.c:133
#12 0x00000000100423cc in bus_unit_message_dispatch (message=0x1001fad6390, connection=0x1001fad2160, u=0x1001faf10f0)
    at src/dbus-unit.c:448
#13 bus_unit_message_handler (connection=0x1001fad2160, message=0x1001fad6390, data=<optimized out>) at src/dbus-unit.c:623
#14 0x00000fff8b727e70 in _dbus_object_tree_dispatch_and_unlock (tree=0x1001fad77b0, message=0x1001fad6390)
    at dbus-object-tree.c:858
#15 0x00000fff8b71556c in dbus_connection_dispatch (connection=0x1001fad2160) at dbus-connection.c:4685
#16 0x000000001003d328 in bus_dispatch (m=0x1001facc7f0) at src/dbus.c:521
#17 0x0000000010012700 in manager_loop (m=0x1001facc7f0) at src/manager.c:2426
#18 0x00000000100096dc in main (argc=<optimized out>, argv=<optimized out>) at src/main.c:1317
Comment 2 Mark Hamzy 2011-08-30 10:13:58 EDT
We need a systemd which contains http://cgit.freedesktop.org/systemd/commit/?id=7daa9e6e29b546275566084512ea4e547bc79b91
Comment 3 Adam Williamson 2011-08-31 12:28:51 EDT
For blocker review purposes: Is this PPC-specific? If so, please use the PPC blocker...thanks!
Comment 4 David Cantrell 2011-08-31 13:20:56 EDT
(In reply to comment #3)
> For blocker review purposes: Is this PPC-specific? If so, please use the PPC
> blocker...thanks!

I don't know if it's ppc-specific or not, but it's certainly hitting us there.
Comment 5 Mark Hamzy 2011-08-31 17:33:49 EDT
Got a little further... No core file and systemd is still running...

bash-4.2# cat << __EOF__ > /etc/sysconfig/network-scripts/ifcfg-eth0
> DEVICE="eth0"
> NM_CONTROLLED="yes"
> HWADDR="2A:0F:4A:82:98:04"
> ONBOOT="yes"
> BOOTPROTO=dhcp
> __EOF__
bash-4.2# [  131.676275] RTAS: event: 35, Type: Platform Information Event, Severity: 1
[  139.675007] RTAS: event: 36, Type: Platform Information Event, Severity: 1
[  147.671431] RTAS: event: 37, Type: Platform Information Event, Severity: 1

bash-4.2# /bin/systemctl start NetworkManager.service
[  151.730553] systemd[1]: Accepted connection on private bus.
[  151.730589] systemd[1]: Running GC...
[  151.733642] systemd[1]: Got D-Bus request: org.freedesktop.systemd1.Manager.StartUnit() on /org/freedesktop/systemd1
[  151.733718] systemd[1]: Trying to enqueue job NetworkManager.service/start/replace
[  151.733899] systemd[1]: Installed new job NetworkManager.service/start as 56
[  151.733918] systemd[1]: Installed new job network.target/start as 99
[  151.733930] systemd[1]: Installed new job arp-ethers.service/start as 100
[  151.733944] systemd[1]: Enqueued job NetworkManager.service/start as 56
[  151.734096] systemd[1]: Starting of arp-ethers.service requested but condition failed. Ignoring.
[  151.734115] systemd[1]: Job arp-ethers.service/start finished, result=done
[  151.734267] systemd[1]: About to execute: /usr/sbin/NetworkManager --no-daemon
[  151.763782] systemd[1]: Forked /usr/sbin/NetworkManager as 615
[  151.764048] systemd[1]: NetworkManager.service changed dead -> start
[  151.764247] systemd[1]: Got D-Bus request: org.freedesktop.systemd1.Manager.GetUnit() on /org/freedesktop/systemd1
[  151.764480] systemd[1]: Got D-Bus request: org.freedesktop.DBus.Properties.Get() on /org/freedesktop/systemd1/unit/NetworkManager_2eservice
[  152.200371] systemd[1]: Incoming traffic on syslog.socket
[  152.200407] NetworkManager[615]: <info> NetworkManager (version 0.8.9997-7.git20110721.fc16) is starting...
[  152.200430] systemd[1]: syslog.socket changed listening -> running
[  152.200436] NetworkManager[615]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
[  152.201788] systemd[1]: Incoming traffic on dbus.socket
[  152.201811] systemd[1]: Trying to enqueue job dbus.service/start/replace
[  152.201944] systemd[1]: Installed new job dbus.service/start as 101
[  152.201955] systemd[1]: Enqueued job dbus.service/start as 101
[  152.201976] systemd[1]: dbus.socket changed listening -> running
[  152.202030] systemd[1]: About to execute: /bin/dbus-uuidgen --ensure
[  152.233788] systemd[1]: Forked /bin/dbus-uuidgen as 616
[  152.233870] systemd[1]: dbus.service changed dead -> start-pre
[  152.242162] systemd[1]: Received SIGCHLD from PID 616 (dbus-uuidgen).
[  152.242260] systemd[1]: Got SIGCHLD for process 616 (dbus-uuidgen)
[  152.242572] systemd[1]: Child 616 died (code=exited, status=0/SUCCESS)
[  152.242582] systemd[1]: Child 616 belongs to dbus.service
[  152.242595] systemd[1]: dbus.service: control process exited, code=exited status=0
[  152.242606] systemd[1]: dbus.service running next control command for state start-pre
[  152.242629] systemd[1]: About to execute: /bin/rm -f /var/run/messagebus.pid
[  152.273875] systemd[1]: Forked /bin/rm as 618
[  152.274097] systemd[1]: Accepted connection on private bus.
[  152.274443] systemd[1]: Got D-Bus request: org.freedesktop.systemd1.Agent.Released() on /org/freedesktop/systemd1/agent
[  152.274776] systemd[1]: Got D-Bus request: org.freedesktop.DBus.Local.Disconnected() on /org/freedesktop/DBus/Local
[  152.277556] systemd[1]: Received SIGCHLD from PID 618 (rm).
[  152.277660] systemd[1]: Got SIGCHLD for process 618 (rm)
[  152.277989] systemd[1]: Child 618 died (code=exited, status=0/SUCCESS)
[  152.278000] systemd[1]: Child 618 belongs to dbus.service
[  152.278012] systemd[1]: dbus.service: control process exited, code=exited status=0
[  152.278025] systemd[1]: dbus.service got final SIGCHLD for state start-pre
[  152.278102] systemd[1]: About to execute: /bin/dbus-daemon --system --address=systemd: --nofork --systemd-activation
[  152.313908] systemd[1]: Forked /bin/dbus-daemon as 620
[  152.314324] systemd[1]: dbus.service changed start-pre -> running
[  152.314357] systemd[1]: Job dbus.service/start finished, result=done
[  152.430768] systemd[1]: Successfully connected to system D-Bus bus 44edc23d2a7e479f6be2414100000098 as :1.0
[  152.432543] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameAcquired() on /org/freedesktop/DBus
[  152.432722] systemd[1]: Accepted connection on private bus.
[  152.432958] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  152.432988] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameAcquired() on /org/freedesktop/DBus
[  152.433019] systemd[1]: Successfully acquired name.
[  152.433452] systemd[1]: Got D-Bus request: org.freedesktop.systemd1.Agent.Released() on /org/freedesktop/systemd1/agent
[  152.433939] systemd[1]: Got D-Bus request: org.freedesktop.DBus.Local.Disconnected() on /org/freedesktop/DBus/Local
[  152.525020] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  152.526937] dbus[620]: [system] Activating service name='org.freedesktop.PolicyKit1' (using servicehelper)
[  152.562077] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  152.572014] polkitd[623]: started daemon version 0.101 using authority implementation `local' version `0.101'
[  152.572604] dbus[620]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
[  152.572873] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  152.612887] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  152.613348] NetworkManager[615]: ifcfg-rh: Acquired D-Bus service com.redhat.ifcfgrh1
[  152.613376] NetworkManager[615]: <info> Loaded plugin ifcfg-rh: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
[  152.613672] NetworkManager[615]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
[  152.614035] NetworkManager[615]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
[  152.720738] NetworkManager[615]: ifcfg-rh:     read connection 'System eth0'
[  152.720809] NetworkManager[615]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
[  152.722363] NetworkManager[615]: <info> trying to start the modem manager...
[  152.722875] dbus[620]: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
[  152.726514] NetworkManager[615]: <info> monitoring kernel firmware directory '/lib/firmware'.
[  152.729666] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  152.729731] systemd[1]: NetworkManager.service's D-Bus name org.freedesktop.NetworkManager now registered by :1.1
[  152.730052] systemd[1]: NetworkManager.service changed start -> running
[  152.730072] systemd[1]: Job NetworkManager.service/start finished, result=done
[  152.730412] systemd[1]: network.target changed dead -> active
[  152.730434] systemd[1]: Job network.target/start finished, result=done
[  152.730541] systemd[1]: Got D-Bus request: org.freedesktop.DBus.Local.Disconnected() on /org/freedesktop/DBus/Local
[  152.730740] NetworkManager[615]: <info> WiFi enabled by radio killswitch; enabled by state file
[  152.730770] NetworkManager[615]: <info> WWAN enabled by radio killswitch; enabled by state file
[  152.730792] NetworkManager[615]: <info> WiMAX enabled by radio killswitch; enabled by state file
[  152.730811] NetworkManager[615]: <info> Networking is enabled by state file
[  152.731689] dbus[620]: [system] Activated service 'org.freedesktop.ModemManager' failed: Cannot launch daemon, file not found or permissions invalid
[  152.734026] NetworkManager[615]: <error> [1314825991.163488] [nm-device-ethernet.c:751] real_update_permanent_hw_address(): (eth0): unable to read permanent MAC address (error 0)
[  152.735800] NetworkManager[615]: <info> (eth0): carrier is OFF
[  152.736037] NetworkManager[615]: <info> (eth0): new Ethernet device (driver: 'ibmveth' ifindex: 2)
[  152.736057] NetworkManager[615]: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
[  152.736414] NetworkManager[615]: <info> (eth0): now managed
[  152.736434] NetworkManager[615]: <info> (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
[  152.736530] NetworkManager[615]: <info> (eth0): bringing up device.
[  152.753302] NetworkManager[615]: <info> (eth0): preparing device.
[  152.753320] NetworkManager[615]: <info> (eth0): deactivating device (reason: 2).
[  152.755623] NetworkManager[615]: <info> (eth0): carrier now ON (device state 20)
[  152.755646] NetworkManager[615]: <info> (eth0): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
[  152.756250] NetworkManager[615]: <warn> bluez error getting default adapter: The name org.bluez was not provided by any .service files
[  152.756837] NetworkManager[615]: <info> Auto-activating connection 'System eth0'.
[  152.756937] NetworkManager[615]: <info> Activation (eth0) starting connection 'System eth0'
[  152.756954] NetworkManager[615]: <info> (eth0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
[  152.757093] NetworkManager[615]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
[  152.757289] NetworkManager[615]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) started...
[  152.757310] NetworkManager[615]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
[  152.757330] NetworkManager[615]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
[  152.757347] NetworkManager[615]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
[  152.757393] NetworkManager[615]: <info> (eth0): device state change: prepare -> config (reason 'none') [40 50 0]
[  152.757622] NetworkManager[615]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
[  152.757643] NetworkManager[615]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
[  152.757685] NetworkManager[615]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
[  152.757748] NetworkManager[615]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
[  152.757768] NetworkManager[615]: <info> (eth0): device state change: config -> ip-config (reason 'none') [50 70 0]
[  152.758104] NetworkManager[615]: <info> Activation (eth0) Beginning DHCPv4 transaction (timeout in 45 seconds)
[  152.768800] NetworkManager[615]: <info> dhclient started with pid 628
[  152.769346] NetworkManager[615]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
bash-4.2# [  153.163692] dhclient[628]: Internet Systems Consortium DHCP Client 4.2.2
[  153.163751] dhclient[628]: Copyright 2004-2011 Internet Systems Consortium.
[  153.163774] dhclient[628]: All rights reserved.
[  153.163793] dhclient[628]: For info, please visit https://www.isc.org/software/dhcp/
[  153.191386] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.193510] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.193994] NetworkManager[615]: <info> (eth0): DHCPv4 state changed nbi -> preinit
[  153.195386] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.195593] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.212030] dhclient[628]: Listening on LPF/eth0/2a:0f:4a:82:98:04
[  153.212101] dhclient[628]: Sending on   LPF/eth0/2a:0f:4a:82:98:04
[  153.212283] dhclient[628]: Sending on   Socket/fallback
[  153.212429] dhclient[628]: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
[  153.212498] ibmveth 30000004: DMA-API: device driver frees DMA memory with wrong function [device address=0x0000000003040490] [size=342 bytes] [mapped as single] [unmapped as page]
[  153.212528] ------------[ cut here ]------------
[  153.212533] WARNING: at lib/dma-debug.c:829
[  153.212539] Modules linked in: squashfs nls_utf8 ibmvscsic scsi_transport_srp ibmveth scsi_tgt
[  153.212558] NIP: c000000000343fb0 LR: c000000000343fac CTR: c000000000068324
[  153.212567] REGS: c000000272153090 TRAP: 0700   Not tainted  (3.0.1-5.fc16.kh.ppc64)
[  153.212574] MSR: 8000000000029032 <EE,ME,CE,IR,DR>  CR: 48222482  XER: 00000009
[  153.212592] TASK = c0000002710d4e80[628] 'dhclient' THREAD: c000000272150000 CPU: 0
[  153.212600] GPR00: c000000000343fac c000000272153310 c00000000141a7b8 00000000000000bb
[  153.212613] GPR04: 0000000000000001 c0000000000ac328 0000000000000000 0000000000000002
[  153.212625] GPR08: 0000000000000000 c0000002710d4e80 0000000000017f20 0000000000000001
[  153.212638] GPR12: 0000000084222442 c00000000ee54000 0000000000000000 c000000271318a00
[  153.212651] GPR16: 0000000000000000 0000000020801988 0000000003040490 0000000000000020
[  153.212664] GPR20: 0000000000000e60 0000000000000000 c0000002753ac278 0000000003040490
[  153.212677] GPR24: 0000000000000156 0000000000000000 0000000000000001 c000000002040d00
[  153.212690] GPR28: c0000002760ec420 c000000272153440 c000000001399b88 c000000272153310
[  153.212710] NIP [c000000000343fb0] .check_unmap+0x3dc/0x77c
[  153.212718] LR [c000000000343fac] .check_unmap+0x3d8/0x77c
[  153.212724] Call Trace:
[  153.212728] [c000000272153310] [c000000000343fac] .check_unmap+0x3d8/0x77c (unreliable)
[  153.212738] [c0000002721533d0] [c0000000003445a4] .debug_dma_unmap_page+0x78/0x80
[  153.212750] [c000000272153510] [d0000000048ce194] .ibmveth_start_xmit+0x53c/0x67c [ibmveth]
[  153.212760] [c000000272153640] [c0000000005854fc] .dev_hard_start_xmit+0x5a8/0x7e8
[  153.212769] [c000000272153740] [c0000000005a6104] .sch_direct_xmit+0x7c/0x278
[  153.212777] [c0000002721537f0] [c000000000585e84] .dev_queue_xmit+0x748/0xa48
[  153.212787] [c0000002721538b0] [c00000000067caf8] .packet_sendmsg+0xb54/0xc70
[  153.212796] [c000000272153a00] [c000000000569168] .sock_aio_write+0x138/0x150
[  153.212805] [c000000272153b40] [c0000000001cf95c] .do_sync_write+0xa8/0xe4
[  153.212813] [c000000272153cc0] [c0000000001d00cc] .vfs_write+0xe4/0x188
[  153.212822] [c000000272153d70] [c0000000001d03d8] .SyS_write+0x58/0x88
[  153.212831] [c000000272153e30] [c000000000009928] syscall_exit+0x0/0x40
[  153.212838] Instruction dump:
[  153.212843] e97c001a e93e8048 e87e80e0 e8dd0028 e81d001a e8fd0030 796b1f24 78001f24
[  153.212857] 7d09582a 7d29002a 4835d5b9 60000000 <0fe00000> 480000c4 2f800003 409e0100
[  153.212873] ---[ end trace 23ebc7de1702caf3 ]---
[  153.212878] Mapped at:
[  153.212882]  [<c000000000344b90>] .debug_dma_map_page+0x9c/0x1c0
[  153.212889]  [<d0000000048cdf18>] .ibmveth_start_xmit+0x2c0/0x67c [ibmveth]
[  153.212897]  [<c0000000005854fc>] .dev_hard_start_xmit+0x5a8/0x7e8
[  153.212905]  [<c0000000005a6104>] .sch_direct_xmit+0x7c/0x278
[  153.212912]  [<c000000000585e84>] .dev_queue_xmit+0x748/0xa48
[  153.213305] dhclient[628]: DHCPREQUEST on eth0 to 255.255.255.255 port 67
[  153.213384] dhclient[628]: DHCPOFFER from 9.5.250.185
[  153.213653] dhclient[628]: DHCPACK from 9.5.250.185
[  153.221422] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.222206] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.223081] NetworkManager[615]: <info> (eth0): DHCPv4 state changed preinit -> bound
[  153.223121] NetworkManager[615]: <info> Activation (eth0) Stage 4 of 5 (IP4 Configure Get) scheduled...
[  153.223220] NetworkManager[615]: <info> Activation (eth0) Stage 4 of 5 (IP4 Configure Get) started...
[  153.223472] NetworkManager[615]: <info>   address 9.5.250.146
[  153.223544] NetworkManager[615]: <info>   prefix 24 (255.255.255.0)
[  153.223573] NetworkManager[615]: <info>   gateway 9.5.250.1
[  153.223600] NetworkManager[615]: <info>   nameserver '9.10.244.100'
[  153.223671] NetworkManager[615]: <info>   nameserver '9.10.244.200'
[  153.223699] NetworkManager[615]: <info>   domain name 'rchland.ibm.com'
[  153.224288] NetworkManager[615]: <info> Activation (eth0) Stage 5 of 5 (IP Configure Commit) scheduled...
[  153.224333] NetworkManager[615]: <info> Activation (eth0) Stage 4 of 5 (IP4 Configure Get) complete.
[  153.224566] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.224838] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  153.225977] NetworkManager[615]: <info> Activation (eth0) Stage 5 of 5 (IP Configure Commit) started...
[  153.226040] dhclient[628]: bound to 9.5.250.146 -- renewal in 268 seconds.
[  154.227957] NetworkManager[615]: <info> (eth0): device state change: ip-config -> activated (reason 'none') [70 100 0]
[  154.229133] NetworkManager[615]: <info> Policy set 'System eth0' (eth0) as default for IPv4 routing and DNS.
[  154.229160] NetworkManager[615]: <info> Activation (eth0) successful, device activated.
[  154.230229] NetworkManager[615]: <info> Activation (eth0) Stage 5 of 5 (IP Configure Commit) complete.
[  154.230481] dbus[620]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
[  154.263691] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  154.265094] dbus[620]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
[  154.265330] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  154.276050] nm-dispatcher.action[633]: Script '/etc/NetworkManager/dispatcher.d/00-netreport' exited with error status 1.
[  155.667990] RTAS: event: 38, Type: Platform Information Event, Severity: 1
[  163.662767] RTAS: event: 39, Type: Platform Information Event, Severity: 1
[  165.011042] systemd[1]: Received SIGCHLD from PID 633 (nm-dispatcher.a).
[  165.011221] systemd[1]: Got SIGCHLD for process 633 (nm-dispatcher.a)
[  165.011491] systemd[1]: Child 633 died (code=exited, status=0/SUCCESS)
[  165.011512] systemd[1]: Running GC...
[  165.011933] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  165.011965] systemd[1]: Got D-Bus request: org.freedesktop.DBus.NameOwnerChanged() on /org/freedesktop/DBus
[  171.659875] RTAS: event: 40, Type: Platform Information Event, Severity: 1

bash-4.2# [  179.656435] RTAS: event: 41, Type: Platform Information Event, Severity: 1
ifconfig
eth0      Link encap:Ethernet  HWaddr 2A:0F:4A:82:98:04
          inet addr:9.5.250.146  Bcast:9.5.250.255  Mask:255.255.255.0
          inet6 addr: 2002:905:150e:302:280f:4aff:fe82:9804/64 Scope:Global
          inet6 addr: fe80::280f:4aff:fe82:9804/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:362 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:31283 (30.5 KiB)  TX bytes:1090 (1.0 KiB)
          Interrupt:20

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Comment 6 Bill Nottingham 2011-08-31 17:44:36 EDT
That trace is very much a kernel bug, not systemd - please file that separately.
Comment 7 Fedora Update System 2011-08-31 20:35:00 EDT
systemd-35-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/systemd-35-1.fc16
Comment 8 Mark Hamzy 2011-09-01 10:03:49 EDT
(In reply to comment #6)
> That trace is very much a kernel bug, not systemd - please file that
> separately.

There is already a separate bug for "ibmveth 30000004: DMA-API: device driver frees DMA memory with wrong function" 733766.  If that is what you are talking about.  This is for anaconda not being able to bring up the network.  I can bring up the network on the command line.
Comment 9 Fedora Update System 2011-09-01 15:03:02 EDT
Package systemd-35-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-35-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/systemd-35-1.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-09-09 13:07:24 EDT
systemd-35-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.