Bug 733721 - grub2 - default kernel needn't be set
Summary: grub2 - default kernel needn't be set
Keywords:
Status: CLOSED DUPLICATE of bug 816230
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kdump
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 771819 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 15:39 UTC by melchiaros
Modified: 2014-01-13 00:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-14 09:53:10 UTC


Attachments (Terms of Use)
the stacktrace - python affected (143.37 KB, image/jpeg)
2011-08-26 15:41 UTC, melchiaros
no flags Details

Description melchiaros 2011-08-26 15:39:45 UTC
Description of problem:
Grubby is not able to find the kernel and react with a stacktrace: see screenshot

Version-Release number of selected component (if applicable):
2.0.5-4.fc15
How reproducible:

Install fedora16 alpha 64 bit

Steps to Reproduce:
1.Install fedora16 alpha 64 bit
2.Install grubby
3.exeecute it and see
  
Actual results:


Expected results:


Additional info:
kdump and crash are also installed

Comment 1 melchiaros 2011-08-26 15:41:24 UTC
Created attachment 520112 [details]
the stacktrace - python affected

Comment 2 Brian Lane 2011-08-26 16:56:12 UTC
That traceback is actually from kdump, do you have more details from grubby?

Comment 3 melchiaros 2011-08-27 09:30:50 UTC
My bad!

I mainly use openSUSE and be a bit without orientation on fedora.

So, you right. It´s a bug of kdump and not bug-buddy.

Please reassign it to one of yours which maintain on kdump.

Comment 4 Américo Wang 2011-11-11 08:20:24 UTC
This BZ should belong to system-config-kdump, not kexec-tools.

Comment 5 Roman Rakus 2011-11-11 12:19:05 UTC
Thanks for the report.
Are you trying it on installed system or on live media? What is the architecture?

Comment 6 melchiaros 2011-11-11 12:30:39 UTC
Between:)

I´ve used KVM on fedora 15 to virtualise fedora16 alpha on x86_64 (CPU AMD T1100 when you want it exactly).

Comment 7 Roman Rakus 2011-11-11 13:08:45 UTC
Can you please run as root in terminal  `/usr/share/system-config-kdump/system-config-kdump-backend.py' and as a user in other terminal `system-config-kdump -d' and post here outputs?

Comment 8 melchiaros 2011-11-11 13:20:27 UTC
The original vm is gone(see the date of the ticket!), so direct performing of your suggestion is not possible.

I´am low in time; do you think that getting the settings in a fedora16 final (fresh istall) would bring any benefit? -> Would take some time to do that, for me.

Comment 9 Roman Rakus 2011-11-17 22:51:56 UTC
I've tried it now on fresh install of Fedora 16 and with all up2date I didn't hit this bug.

Comment 10 Roman Rakus 2011-11-28 11:02:12 UTC
Now I hit the bug. Looks like it depends if you use grub or grub2.

Comment 11 Nicolas Chauvet (kwizart) 2012-01-02 20:25:19 UTC
I've hit this bug.
I'm using grubby --default-kernel as RPM %post section which return void.
As this case is not handled by my script, it fails. (xorg-x11-drv-nvidia FYI).

The installation was done with the update repository enabled from x86_64 DVD default installation (as of 20111230).

Comment 12 Nicolas Chauvet (kwizart) 2012-01-02 20:27:12 UTC
Sorry, I've miss-read the report, not my bug

Comment 13 Nicolas Chauvet (kwizart) 2012-01-02 20:29:46 UTC
(found it as #736188 sorry for the noise)

Comment 14 Roman Rakus 2012-01-09 17:18:42 UTC
*** Bug 771819 has been marked as a duplicate of this bug. ***

Comment 15 Roman Rakus 2012-06-14 09:53:10 UTC
There is new version available. Please test it and eventualy comment on bug #816230

*** This bug has been marked as a duplicate of bug 816230 ***


Note You need to log in before you can comment on or make changes to this bug.