Bug 733764 - Instances: download link for ec2 cert disappears after a few seconds
Summary: Instances: download link for ec2 cert disappears after a few seconds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Jiri Tomasek
QA Contact: wes hayutin
URL: https://hp-bl480c-01.rhts.eng.bos.red...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 18:39 UTC by wes hayutin
Modified: 2012-05-15 21:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:52:46 UTC


Attachments (Terms of Use)
ss1 (86.71 KB, image/png)
2011-08-26 18:40 UTC, wes hayutin
no flags Details
ss2 (74.64 KB, image/png)
2011-08-26 18:40 UTC, wes hayutin
no flags Details
download key (233.23 KB, image/png)
2012-01-25 05:31 UTC, Aziza Karol
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description wes hayutin 2011-08-26 18:39:51 UTC
Description of problem:

When you create a new deployment in aeolus for ec2, you can click on the deployment to get the instance details.

I'm assuming we have some sort of javascript that is updating the status of the instance and that is causing the link for the cert to disappear.

see screenshots for details

[root@hp-bl480c-01 ~]# rpm -qa | grep aeolus
aeolus-configure-2.0.2-1.20110823163326gitc322d7f.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110823203319gitcf40883.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110824113236git15b6922.fc15.noarch
aeolus-conductor-0.4.0-0.20110823203319gitcf40883.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110823203319gitcf40883.fc15.noarch
aeolus-all-0.4.0-0.20110823203319gitcf40883.fc15.noarch

Comment 1 wes hayutin 2011-08-26 18:40:16 UTC
Created attachment 520125 [details]
ss1

Comment 2 wes hayutin 2011-08-26 18:40:39 UTC
Created attachment 520126 [details]
ss2

Comment 3 wes hayutin 2011-08-26 18:41:25 UTC
if you refresh the page, the download link reappears and then after a few seconds disappears.. :)  playing hard to get I assume.

Comment 4 wes hayutin 2011-09-28 16:40:50 UTC
making sure all the bugs are at the right version for future queries

Comment 6 wes hayutin 2012-01-12 16:52:49 UTC
adding to sprint tracker

Comment 7 Aziza Karol 2012-01-25 05:30:56 UTC
This issue is not reproducible.Download key does not disappear after a refresh.

verified on:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-3.el6.noarch
aeolus-conductor-doc-0.8.0-11.el6.noarch
rubygem-aeolus-cli-0.3.0-5.el6.noarch
aeolus-configure-2.5.0-7.el6.noarch
aeolus-conductor-daemons-0.8.0-11.el6.noarch
aeolus-conductor-0.8.0-11.el6.noarch
aeolus-all-0.8.0-11.el6.noarch

Comment 8 Aziza Karol 2012-01-25 05:31:36 UTC
Created attachment 557377 [details]
download key

Comment 10 errata-xmlrpc 2012-05-15 21:52:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.