Bug 733805 - the name in the subscription-manager installed product listing is changing after a valid subscribe is performed
Summary: the name in the subscription-manager installed product listing is changing af...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-08-26 22:51 UTC by John Sefler
Modified: 2011-12-06 17:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:23:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-08-26 22:51:04 UTC
Description of problem:
When testing against the stage environment with username stage_test_12 on a client with the "Red Hat Enterprise Linux 6 Server" 69.pem product cert, the name of product in the subscription-manager list --installed changes to "Red Hat Enterprise Linux Server" after subscribing to a pool that satisfies the requiredTags in the content set.  I believe the name of the installed product should remain the same and equal to the oid value in the product cert (and, it breaks our automated tests when the name changes).




Steps to Reproduce:

First, If 69.pem is not installed on your client in /etc/pki/product, you can get it from here: https://docspace.corp.redhat.com/docs/DOC-71135

[root@jsefler-stage-6server ~]# grep hostname /etc/rhsm/rhsm.conf
# Server hostname:
hostname=subscription.rhn.stage.redhat.com
proxy_hostname=
[root@jsefler-stage-6server ~]# subscription-manager register --username=stage_test_12 --password=redhat
The system has been registered with id: 17a3bd44-02cb-4fd6-b413-af338ec42e8a 
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Status:             	Not Subscribed           
Expires:            	                         
SerialNumber:       	                         
ContractNumber:     	                         
AccountNumber:      	                         

[root@jsefler-stage-6server ~]# 

^^^^^  NOTICE THE ProductName is "Red Hat Enterprise Linux 6 Server" WITH 6 BEFORE WE SUBSCRIBE TO THE COVERING SUBSCRIPTION

[root@jsefler-stage-6server ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	92                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	400                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	virtual                  


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf4201309911639a0c51
Quantity:          	96                       
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf420130991163ac0c56
Quantity:          	unlimited                
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	virtual                  

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad7101d3a
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad7101d3a
[root@jsefler-stage-6server ~]# subscription-manager list --installed+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Status:             	Subscribed               
Expires:            	06/08/2012               
SerialNumber:       	4688902467014671797      
ContractNumber:     	2394344                  
AccountNumber:      	1465502                  

[root@jsefler-stage-6server ~]# 

^^^^ BANG!, THE ProductName CHANGED TO "Red Hat Enterprise Linux Server" WITHOUT THE 6.  WHERE DID THAT NAME COME FROM?

THIS NAME SHOULD STAY THE SAME AS WHAT IS IN THE PRODUCT CERT...

[root@jsefler-stage-6server ~]# openssl x509 -text -in /etc/pki/product/69.pem | grep -A1 1.3.6.1.4.1.2312.9.1.69.1:
            1.3.6.1.4.1.2312.9.1.69.1: 
                .!Red Hat Enterprise Linux 6 Server
[root@jsefler-stage-6server ~]# 


Version-Release number of selected component (if applicable):
[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.7-1.el6.x86_64
Not sure if this bug is client side or candlepin server side

Comment 1 John Sefler 2011-08-26 23:23:16 UTC
[root@jsefler-stage-6server ~]# openssl x509 -text -in /etc/pki/entitlement/4688902467014671797.pem | grep -A1 1.3.6.1.4.1.2312.9.1.69.1:
            1.3.6.1.4.1.2312.9.1.69.1: 
                ..Red Hat Enterprise Linux Server
[root@jsefler-stage-6server ~]# 

^^^ IT LOOKS LIKE THE NAME IN THE list --installed IS COMING FROM THE ENTITLEMENT CERT AFTER THE SUBSCRIBING EVENT

Comment 2 John Sefler 2011-08-27 04:15:46 UTC
Upon further review, I am lowering the severity of this bug.
Although the observed behavior in comment 0 is indeed true, I am undecided on the correct behavior now that I better understand comment 1.

It may be best to close this bug with "working as designed".

Comment 3 John Sefler 2011-09-24 02:59:50 UTC
This was fixed by bug 736424

[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.11-1.git.7.15fc9d2.el6.x86_64


[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Version:            	6.1                      
Arch:               	x86_64                   
Status:             	Not Subscribed           
Starts:             	                         
Expires: 

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad4a41d37
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad4a41d37


[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Version:            	6.1                      
Arch:               	x86_64                   
Status:             	Subscribed               
Starts:             	                         
Expires:            	                         


^^^^ NOTICE THE NAME OF THE LISTED PRODUCT NOW REMAINS THE SAME AFTER A SUBSCRIBE AND EQUAL TO THE VALUE IN THE PRODUCT CERT (NOT THE ENTITLEMENT CERT)

Moving to VERIFIED.

Comment 4 errata-xmlrpc 2011-12-06 17:23:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.