Bug 733812 - clementine runs 100%cpu on exit until killed
Summary: clementine runs 100%cpu on exit until killed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: clementine
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-27 00:03 UTC by Geoff King
Modified: 2012-08-07 17:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 17:34:12 UTC


Attachments (Terms of Use)

Description Geoff King 2011-08-27 00:03:08 UTC
Description of problem:
I have 100% on one cpu when closing clementine.  Have to killall clementine to fully close.  

Version-Release number of selected component (if applicable):
Using fedora package 0.7.1-1.fc15.


How reproducible:
Close clementine and watch cpu meter. 

Steps to Reproduce:
1.Close clementine and watch cpu meter. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Orcan Ogetbil 2011-08-27 00:48:31 UTC
Hi Geoff, sorry but I cannot reproduce this bug. Does it happen every time? Could you isolate a case where it happens 100% of the time?

Comment 2 Geoff King 2011-08-31 01:07:09 UTC
Hi.  Yes- happens every time.  No other ill effects noted and works fine until closing.  Tried changing some audio output and settings, but no effect.  

I tried to capture some output for you... All of this is at startup and no error messages at close... Had to ctrl-c to close in the terminal.
$ clementine
Couldn't load icon "clementine-panel" 
Couldn't load icon "clementine-panel-grey" 
virtual bool QxtGlobalShortcutBackend::DoRegister() 
Couldn't load icon "find" 
Application asked to unregister timer 0x2200000b which is not registered in this thread. Fix application.
^C

If I try to run in gdb, then it closes normally and I do not have this problem and i get the following output:
...[snip]
[Thread 0x7fffdeffd700 (LWP 1575) exited]
[Inferior 1 (process 1564) exited normally]


Geoff

Comment 3 Dave M 2011-09-09 21:05:56 UTC
I can confirm this issue.  I was wondering what was bogging down my system when I realized I had five clementine processes running.  The "killall clementine" line works, but is inconvenient.

Please let me know if you need further information.

Comment 4 Orcan Ogetbil 2011-09-09 23:02:18 UTC
Just out of curiosity (usual suspect) are you guys running pulseaudio by any chance?

Comment 5 Dave M 2011-09-09 23:26:05 UTC
I am.  Should I not be running it?

Comment 6 Orcan Ogetbil 2011-09-10 00:03:39 UTC
Just try without running it

Comment 7 Geoff King 2011-09-10 13:34:16 UTC
I tried turning off pulse as you suggested, but still not working.  
I turned off pulse autospawn in this file (/etc/pulse/client.conf).
Then killed pulse. 
Confirmed pulse is off via "ps -ef | grep pulse"
Then started clementine and tried as is (using pulse) and got this repeating error:

"pulsesink.c(549): gst_pulseringbuffer_open_device (): /GstPipeline:pipeline/GstBin:audiobin/GstPulseSink:pulsesink-89" 
Gstreamer error: "Failed to connect: Connection refused" 
QTimeLine::start: already running
QTimeLine::start: already running

Then changed clementine to use ALSA as output, restarted clementine and got this repeating error:

"gstalsasink.c(702): gst_alsasink_open (): /GstPipeline:pipeline/GstBin:audiobin/GstAlsaSink:alsasink-193:
Playback open error on device 'default': Connection refused" 
Gstreamer error: "Could not open audio device for playback." 
QTimeLine::start: already running
QTimeLine::start: already running

I also tried entering hw:0 into the custom line. 
Not sure why alsa wouldn't play the music. No sounds at all as it says connection refused and skips through each file. 
Still have to kill clementine with 100% cpu 

Any other ideas.  
At this point at least the pulseaudio plays the music.

Comment 8 Orcan Ogetbil 2011-09-10 18:19:01 UTC
Geoff, just remove the pulseaedio and try. It used to solve problems:

# yum remove pulseaudio alsa-plugins-pulseaudio

Comment 9 Dave M 2011-09-10 21:38:00 UTC
Hi,

That doesn't seem like a good solution.  Removing pulseaudio will remove most of gnome with it:

yum remove pulseaudio alsa-plugins-pulseaudio
<snip>
Dependencies Resolved

================================================================================
 Package                                Arch   Version         Repository  Size
================================================================================
Removing:
 pulseaudio                             x86_64 0.9.22-5.fc15   @anaconda-InstallationRepo-201105131943.x86_64
                                                                          1.9 M
Removing for dependencies:
 bluez                                  x86_64 4.87-7.fc15     @updates   1.1 M
 gnome-bluetooth                        x86_64 1:3.0.1-1.fc15  @updates   538 k
 gnome-panel                            x86_64 3.0.0.1-4.fc15  @updates   9.4 M
 gnome-shell                            x86_64 3.0.2-4.fc15    @updates   3.0 M
 gnome-shell-extension-remove-accessibility-icon
                                        noarch 20110603-1.fc15 @updates   3.0 k
 gnome-shell-extension-theme-selector   noarch 0.9-3.fc15      @updates   630 k
 gnome-shell-theme-atolm                noarch 1.0-1.fc15      @updates   369 k
 gnome-shell-theme-dark-glass           noarch 1.0-1.fc15      @updates   352 k
 gnome-shell-theme-gaia                 noarch 1.0-1.fc15      @updates   316 k
 gnome-shell-theme-orta                 noarch 1.0-1.fc15      @updates   899 k
 gnome-shell-theme-smooth-inset         noarch 1.0-1.fc15      @updates   352 k
 gnome-tweak-tool                       noarch 3.0.5-2.fc15    @updates   255 k
 pulseaudio-esound-compat               x86_64 0.9.22-5.fc15   @fedora    3.2 k
 pulseaudio-module-bluetooth            x86_64 0.9.22-5.fc15   @anaconda-InstallationRepo-201105131943.x86_64
                                                                          161 k
 pulseaudio-module-gconf                x86_64 0.9.22-5.fc15   @anaconda-InstallationRepo-201105131943.x86_64
                                                                           20 k
 pulseaudio-module-x11                  x86_64 0.9.22-5.fc15   @anaconda-InstallationRepo-201105131943.x86_64
                                                                           48 k

Transaction Summary
================================================================================
Remove       17 Package(s)

Installed size: 19 M
Is this ok [y/N]:

Comment 10 Orcan Ogetbil 2011-09-10 21:47:41 UTC
Hmm, that's really bad, making a DE depend on a sound server. Well I'm glad I'm not using Gnome.

How about just removing alsa-plugins-pulseaudio and disabling the autospawning of pulseaudio daemon like Geoff did?

For alsa, the name of a particular card can be found in the output of 
   $ cat /proc/asound/cards
for each card it is the string between square brackets without the trailing blanks. I think pulseaudio steals "default" card somehow. But maybe removing alsa-plugins-pulseaudio will help with that, i.e. you will be able to use "default" again.

Comment 11 John Armitage 2012-05-30 22:53:43 UTC
This continues into Fedora 17 and looks like it is related to the nvidia drivers, see http://code.google.com/p/clementine-player/issues/detail?id=2088
The  __GL_NO_DSO_FINALIZER=1 workaround fixes it here

Comment 12 Fedora End Of Life 2012-08-07 17:34:14 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.