Bug 733814 - GPU lockup and/or kernel fault?
Summary: GPU lockup and/or kernel fault?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-27 02:03 UTC by Patrick Dubois
Modified: 2012-05-28 10:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-28 10:29:32 UTC


Attachments (Terms of Use)

Description Patrick Dubois 2011-08-27 02:03:32 UTC
Description of problem:  Lockup of GPU.  Reboot presents the same problem over again.  Transparency and 3d acceleration appear to trigger the bug.

Fedora 15 with all updates applied as of August 25th 2011.

How reproducible: always.


Steps to Reproduce:
1. Log into KDE account with 3d enabled.
2. enable window transparency or play 3d screensaver
3. Enjoy GPU lockup, now with added user frustration.
  
Actual results: GPU lockup with any 3d accel feature.


Expected results:  Normal user experience.


Additional info:

Package:    	kernel
Latest Crash:	Fri 26 Aug 2011 09:19:24 PM 
Command:    	not_applicable
Reason:     	WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:235 radeon_fence_wait+0x22e/0x2cd [radeon]()

Comment:    	This card has traditionally been bulletproof.   The last round of updates I performed last week appear to have introduced a regression in either the radeon drivers or Xorg.
		
		Video card is ATI Sapphire HD2600. 
		CPU Intel Q6600 quad core.
		Board is Giabyte P35.
		
		--
		   description: Desktop Computer
		    product: P35-DS3R ()
		    vendor: Gigabyte Technology Co., Ltd.
		    width: 64 bits
		    capabilities: smbios-2.4 dmi-2.4 vsyscall64 vsyscall32
		    configuration: boot=normal chassis=desktop uuid=00000000-0000-0000-0000-001A4D53AC73
		  *-core
		       description: Motherboard
		       product: P35-DS3R
		       vendor: Gigabyte Technology Co., Ltd.
		       physical id: 0
		     *-firmware
		          description: BIOS
		          vendor: Award Software International, Inc.
		          physical id: 0
		          version: F11
		          date: 01/04/2008
		          size: 128KiB
		          capacity: 960KiB
		          capabilities: pci pnp apm upgrade shadowing cdboot bootselect edd int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification
		     *-cpu
		          description: CPU
		          product: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
		          vendor: Intel Corp.
		          physical id: 4
		          bus info: cpu@0
		          version: Intel(R) Core(TM)2 Quad CPU
		          slot: Socket 775
		          size: 1600MHz
		          capacity: 4GHz
		          width: 64 bits
		          clock: 266MHz
		          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm tpr_shadow vnmi flexpriority cpufreq
		
		           *-display
		                description: VGA compatible controller
		                product: RV630 [Radeon HD 2600 Series]
		                vendor: ATI Technologies Inc
		                physical id: 0
		                bus info: pci@0000:01:00.0
		                version: 00
		                width: 64 bits
		                clock: 33MHz
		                capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
		                configuration: driver=radeon latency=0
		                resources: irq:44 memory:e0000000-efffffff memory:f5000000-f500ffff ioport:b000(size=256) memory:f4000000-f401ffff
		           *-multimedia
		                description: Audio device
		                product: RV630/M76 audio device [Radeon HD 2600 Series]
		                vendor: ATI Technologies Inc
		                physical id: 0.1
		                bus info: pci@0000:01:00.1
		                version: 00
		                width: 64 bits
		                clock: 33MHz
		                capabilities: pm pciexpress msi bus_master cap_list
		                configuration: driver=HDA Intel latency=0
		                resources: irq:46 memory:f5010000-f5013fff
		
Bug Reports:	Kernel oops report was uploaded

Comment 1 Jason Smith 2012-05-28 01:54:35 UTC
Thank you for taking the time to report this bug and I apologize for the delayed reponse. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update kernel' and 'yum update xorg-x11-drv-ati'  or using the graphical updater, Software Update.

If this error is still persistient with current software, please respond & attach an output of dmesg in plain text format as well as a copy of your Xorg.0.log file for us to further review this report.

---
Jason
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Patrick Dubois 2012-05-28 10:29:32 UTC
Hello Jason,

The ATI card in question has been scrapped in favor of a newer card that did not seem to be affected by this bug.

This unfortunatly means I have no way of testing the updates with regards to this bug report.

I'll close this issue.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.