Bug 733827 - dib0700: tx buffer length is larger than 4. Not supported.
dib0700: tx buffer length is larger than 4. Not supported.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-27 05:43 EDT by Juhani Jaakola
Modified: 2011-11-17 18:28 EST (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.41.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-17 18:28:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juhani Jaakola 2011-08-27 05:43:51 EDT
Description of problem:
When I try to watch digital television (DVB-T standard) with Kaffeine, no picture is shown. After a while I get a "read error" dialog box from Kaffeine. dmesg shows the following error:

  dib0700: tx buffer length is larger than 4. Not supported.

My digital TV card is Artec T14BR DVB-T, which uses the dvb_usb_dib0700 module.

Version-Release number of selected component (if applicable):
kaffeine-1.2.2-1.fc15.i686
kernel-2.6.40-4.fc15.i686 and also 2.6.40.3-0

How reproducible:
Always

Steps to Reproduce:
1. Try to watch digital TV with Kaffeine using the dib0700 driver
2.
3.
  
Actual results:
No picture, error message (see above) in dmesg.

Expected results:
Picture is shown.

Additional info:
This works when I boot to kernel-2.6.38.6-26.rc1.fc15.i686.
See also the following link:
http://comments.gmane.org/gmane.linux.drivers.video-input-infrastructure/36393
Comment 1 Josh Boyer 2011-10-20 16:04:54 EDT
(In reply to comment #0)
> Additional info:
> This works when I boot to kernel-2.6.38.6-26.rc1.fc15.i686.
> See also the following link:
> http://comments.gmane.org/gmane.linux.drivers.video-input-infrastructure/36393

Thanks for the link.  All 3 of those patches are in linux-next, but never made it to 3.0-stable.  I'll grab them and try adding them to a scratch build F15 kernel.
Comment 2 Josh Boyer 2011-10-20 20:42:37 EDT
I've started a scratch build kernel that includes those 3 patches.  When this completes, could you please test it and let us know if the issues are resolved?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3448197
Comment 3 Juhani Jaakola 2011-10-22 08:39:27 EDT
Josh, your scratch built kernel-2.6.40.7-1.1.fc15.i686 works fine! The issue is resolved! I can now watch TV and record programmes with Kaffeine with no problems. Thanks!
Comment 4 Jan Bušta 2011-10-23 08:21:04 EDT
Thank you, works for me fine. Switching programs works as before.
Comment 5 Josh Boyer 2011-10-24 09:13:29 EDT
OK, I have added the patches to F15-rawhide.  They will be in the next official kernel build.
Comment 6 Fedora Update System 2011-10-24 11:12:34 EDT
kernel-2.6.40.7-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.7-3.fc15
Comment 7 Fedora Update System 2011-10-26 23:58:56 EDT
Package kernel-2.6.40.7-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40.7-3.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14978
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-10-27 10:12:46 EDT
kernel-2.6.40.8-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.8-2.fc15
Comment 9 Fedora Update System 2011-11-01 15:58:57 EDT
kernel-2.6.40.8-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.8-4.fc15
Comment 10 Fedora Update System 2011-11-11 19:08:01 EST
kernel-2.6.41.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.1-1.fc15
Comment 11 Fedora Update System 2011-11-17 18:28:42 EST
kernel-2.6.41.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.