This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 733851 - UEFI system no longer boots after 3.1 kernel update
UEFI system no longer boots after 3.1 kernel update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-27 13:17 EDT by Lars Seipel
Modified: 2013-01-10 02:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-29 10:20:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of lshw (15.28 KB, text/plain)
2011-08-27 13:17 EDT, Lars Seipel
no flags Details
output of dmesg when booting with kernel 3.0 (86.41 KB, text/plain)
2011-08-27 13:18 EDT, Lars Seipel
no flags Details

  None (edit)
Description Lars Seipel 2011-08-27 13:17:07 EDT
Created attachment 520174 [details]
output of lshw

Description of problem:
After installing F16's last kernel update my system no longer boots. Instead, the following is shown on screen:

Trying to allocate 1059 pages for VMLINUZ
Got pages at 0xd59d5000
[Linux-EFI, setup=0x10cc, size=0x422db0
_

From this point on nothing happens anymore, while the caps lock LED is blinking. The value for setup varies if booted with different kernel parameters. The system is a Thinkpad X220 (exakt model: 4290W1B, see attached lshw output) with BIOS compatibility module disabled. Fedora is installed on a GPT disk with EFI system partition and gets started from Grub legacy. Pretty much the standard Anaconda recommendation for UEFI systems.

With the 3.0 kernel from the initial installation the system starts fine. Naturally, there are no syslog entries from the failed boot attempts with the 3.1 kernel.

Version-Release number of selected component (if applicable):
$ rpm -q kernel
kernel-3.0.1-3.fc16.x86_64
kernel-3.1.0-0.rc3.git0.0.fc16.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. Install 3.1 kernel from updates-testing repo
2. Reboot system
3. 
  
Actual results:
System hangs after hitting enter in Grub

Expected results:
System comes up like with previous 3.0 kernel

Additional info:
Output from lshw
dmesg output from successfull boot
Comment 1 Lars Seipel 2011-08-27 13:18:02 EDT
Created attachment 520175 [details]
output of dmesg when booting with kernel 3.0
Comment 2 Josh Boyer 2011-08-27 17:57:48 EDT
Matthew, any ideas?
Comment 3 Matthew Garrett 2011-08-27 19:04:25 EDT
I'll try to reproduce on Monday.
Comment 4 Lars Seipel 2011-08-29 10:12:58 EDT
After I looked at it again today this is not kernel related at all. The problem seems to be grubby not creating a proper initrd entry for the new kernel in grub.conf. Argh. How could I have missed _that_?
Comment 5 Josh Boyer 2011-08-29 10:20:30 EDT
(In reply to comment #4)
> After I looked at it again today this is not kernel related at all. The problem
> seems to be grubby not creating a proper initrd entry for the new kernel in
> grub.conf. Argh. How could I have missed _that_?

Thanks for letting us know.  If you have logs that show errors from grubby, you might want to open a bug against it or probably dracut.
Comment 6 Mads Kiilerich 2011-09-09 09:04:10 EDT
The missing initrd entry is probably bug 725185

Note You need to log in before you can comment on or make changes to this bug.