Bug 733865 - F16 alpha cannot be installed, anaconda exception
Summary: F16 alpha cannot be installed, anaconda exception
Keywords:
Status: CLOSED DUPLICATE of bug 731177
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-27 21:02 UTC by Reartes Guillermo
Modified: 2011-08-29 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 20:26:24 UTC


Attachments (Terms of Use)

Description Reartes Guillermo 2011-08-27 21:02:53 UTC
Description of problem:

F16 alpha cannot be installed because of an anaconda issue. It terminates abnormally after selecting basic storage devices.
The LiveCD boots correcly but installation cannot be performed.
Setting severity to urgent sice f16a cannot be installed.

Version-Release number of selected component (if applicable):
F16 alpha, KDE ISO.


How reproducible:


Steps to Reproduce:
1. boot F16 alpha iso (KDE-LiveCD)
2. find "install to hardisk" 
3. anaconda get exeptions
  
Actual results:
cannot install f16a

Expected results:
install f16a

Additional info:

executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         DeviceTreeError: MD RAID device md121 not in devicetree after scanning all slaves
time:           Sat Aug 27 13:40:54 2011
version:        16

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 753, in addUdevMDDevice
:    "scanning all slaves" % name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 999, in addUdevDevice
:    device = self.addUdevMDDevice(info)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1832, in _populate
:    self.addUdevDevice(dev)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1789, in populate
:    self._populate(progressWindow)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 474, in reset
:    cleanupOnly=cleanupOnly)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 103, in storageInitialize
:    storage.reset()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:DeviceTreeError: MD RAID device md121 not in devicetree after scanning all slaves

END:

Since it appears to be a problem/issue with mdadm, my setup is:

1 x SSD (i intend to test f16 in sda5)
2 x HD 1TB WDBLACK with mdadm raid1 and raid0 partitions
2 X HD 2TB WDGREEN with mdadm raid1 partitions.

The SSD is MBR partitioned, the other disks are GPT partitioned.

Comment 1 Gabriel Machado 2011-08-28 20:28:12 UTC
I have the same problem with my laptop Dell L502X.

Core i7 2630MQ
Nvidia GT540M (optimus)

Comment 2 Brian Lane 2011-08-29 20:26:24 UTC

*** This bug has been marked as a duplicate of bug 731177 ***


Note You need to log in before you can comment on or make changes to this bug.