Bug 733874 - RFE: May we have "shutdown -F" back?
Summary: RFE: May we have "shutdown -F" back?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 04:29 UTC by Todd
Modified: 2014-03-17 03:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-25 23:03:01 UTC


Attachments (Terms of Use)

Description Todd 2011-08-28 04:29:22 UTC
Would you please consider add back the force fsck (-F) at next reboot back to the "shutdown" program?

From RHEL 5.6:  
man shutdown

    OPTIONS
    ...
    -F     Force fsck on reboot.

Many thanks,
-T

Comment 1 Elad Alfassa 2011-08-29 14:16:52 UTC
Moving to systemd, which provides /sbin/shutdown according to yum.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Lennart Poettering 2011-08-29 14:22:03 UTC
-F was already removed in Upstart.

I am tempted to say that "fsck.mode=force" as a kernel cmdline argument is the much nicer choice, given that modifying the root fs to check the root fs is a bit of a paradoxon.

Comment 3 Bill Nottingham 2011-08-29 15:05:22 UTC
Also, note that 'touch /forcefsck ; shutdown -r ...' still works.

Comment 4 Fedora Admin XMLRPC Client 2011-10-20 16:29:03 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Jóhann B. Guðmundsson 2012-01-25 10:55:01 UTC
I have to agree with Lennart in comment 2 that the right thing to do is for users to add fsck.mode=force to the kernel command line at startup and given that as Bill points out that this 'touch /forcefsck ; shutdown -r ...' Still works any reason we cant close this RFE ?

Comment 6 Todd 2012-01-25 18:04:20 UTC
Bit to be obstreperous or unappreciative, but work arounds are not solutions to what is "expected" from past experience with Red Hat products.  Removing the "-F" did not make the products better.  Its made things more confusing.  Please do not close this RFE until you have fixed the actual problem.  I realize there is a zeal to closed things as soon as possible, but please do not do that with this RFE.  Please put things back the way they are expected.  Googling how to force an fsck every time your need to run one is not a solution

Many thanks,
-T

Comment 7 Jóhann B. Guðmundsson 2012-01-25 19:04:50 UTC
When was the last time you actually used this Fedora since as Lennart mentions that this was already removed in upstart?

Comment 8 Todd 2012-01-25 19:19:33 UTC
I still have CentOS 5.7 server out "in the wild".  They just work.  So to answer your question, all the time.  I am slowly upgrade everyone to Scientific Linux 6.x, but it is going to be a while.

Comment 9 Todd 2012-01-25 20:38:28 UTC
Jóhann,

   I am perplexed by the "removed in upstart" from your above statement.  Why do we care if someone else screwed something up?  And why would we want to perpetuate their screw up?

   I can not tell you how many times I have issued the "shutdown -rF 22:00 &" command to fix a server whose kernel fail to properly mount an AHCI removable backup hard drive.  The "-F" to get the fsck out of the way so as to avoid it happening to the customer during the middle of their work day when they have to do a manual reboot for whatever reason.  (They get really, really mad/pissed while they have to wait and wait while their business slips by and they look stupid to their customers).

   I have used Red Hat products for about 15 years now.  I have tried other Linux distro and just don't care for them.  I just like the culture that Red Hat presents (no I don't own stock).  Red Hat just does a good job.  That being said, we all expect a continuity from your products.  Yes, things have changed for the better and we all are excited about that, but when they don't improve, we expect that you will see the error of your ways and fix it.

   Please forgive me if I am misinterpreting you and it is not your intention, but you are coming off as looking for an excuse close the RFE/Bug and avoid helping.  As I previously stated, why do we care if someone else screwed up?

   Speaking of screw ups, who in their right mind thought it was a good idea to remove the status bar from the boot up fsck, yes I know another bug (https://bugzilla.redhat.com/show_bug.cgi?id=679492).  Both my customers and I have thrown the power switch thinking the boot up has crashed.  One of these days, someone is going to trash a hard drive.  Is that covered by "removed from upstart" too?  Why do we care if others have screwed up?  (I have a few customer that power off their machines on the weekends.  And, we have a lot of power problems out these parts.)

-T

Comment 10 Todd 2012-01-25 20:45:09 UTC
Who stuck this is Fedora?  This should be a RHEL bug.  Actually it is both.  I really need this fixed in RHEL first, then Fedora second.  I use Fedora for my customer's workstations.  I use RHEL (clones) for my servers.  These are the critical systems, not the workstations.

Comment 11 Jóhann B. Guðmundsson 2012-01-25 21:18:47 UTC
With my admin hat on I do believe you have made a reasonable argument on why "touch /forcefsck ; shutdown -r ..." and fsck.mode=force aren't sufficient.
( reboot with fsck at precise time ).

With regards to RHEL that is something that you need to argue with your Red hat support contact.

Comment 12 Jóhann B. Guðmundsson 2012-01-25 23:03:01 UTC
So after a bit of discussion and to put long story short this got ripped out because the interface is seriously broken.

This will not be implemented or officially supported in systemd in any shape or form until there's a sane way to request an fsck for the next boot without actually mucking with the fs in question for example if/when pstore one day would allow this. ( The solution will most likely be implemented in dracut ).

What this means is that the "F" option is not coming back but reboot with fsck at precise time might sometime in the distant future ( think year or two ). 

Closing this as wontfix. 

You can open a new bug against RHEL to see if they will fix in their release thanks.

Comment 13 Michal Schmidt 2012-01-26 09:34:30 UTC
Just correcting some misunderstanding...

(In reply to comment #9)
> Jóhann,
> 
>    I am perplexed by the "removed in upstart" from your above statement.  Why
> do we care if someone else screwed something up?  And why would we want to
> perpetuate their screw up?

upstart is the init system that Fedora used since F-9 (released in 2008) until F-15 (where it was replaced by systemd). Upstart is also the init system that RHEL6 uses, so "already removed in upstart" implies "already removed in RHEL6".

Whether it is a screw up or not is a matter of opinion. And yours would carry more weight if it were expressed as a RHEL customer's request through your support contacts.

> we all expect a continuity from your products.

Jóhann is a volunteer contributor to Fedora and is not a Red Hat employee. He is not expected to care about RHEL, the product.

Comment 14 Todd 2012-01-26 19:11:36 UTC
Hi Michal,

Thank you for the heads up.  I reopened the bug back at RHEL:

https://bugzilla.redhat.com/show_bug.cgi?id=784960

It really should have never been over here at Fedora anyway.

By the way, I have no support contract.  I am from the "community", meaning I am using one of the clones.  They will still work with you over at RHEL's bugzilla as long as you tell them you are from the "community".  You get last priority, but so far its has always worked for me.  (They fixed the kernel error where cutting a DVD corrupted your hard drive for me.  They are good guys.)

Interesting that RHEL used systemd from FC15.  Seems they used most of everything else from FC13/14.

I now concur on the closing of the bug.  Thanks to everyone for the patience with me (especially Jóhann).

-T

Comment 15 Michal Schmidt 2012-01-27 09:00:32 UTC
(In reply to comment #14)
> Interesting that RHEL used systemd from FC15.

That's not what I said. RHEL6 uses upstart.

Comment 16 Todd 2012-01-27 17:56:45 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > Interesting that RHEL used systemd from FC15.
> 
> That's not what I said. RHEL6 uses upstart.

Oooops.  Thank you.


Note You need to log in before you can comment on or make changes to this bug.