Bug 733875 - RuntimeError: Returning partitions to state prior to edit failed
Summary: RuntimeError: Returning partitions to state prior to edit failed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: David Lehman
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:a3d63d67bdcbd154ec78f232280...
Depends On: 519526
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 04:32 UTC by Xiaoqing Wei
Modified: 2011-10-17 19:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-17 19:31:25 UTC


Attachments (Terms of Use)
/tmp/anaconda-tb* (290.10 KB, text/plain)
2011-09-01 02:33 UTC, Xiaoqing Wei
no flags Details

Description Xiaoqing Wei 2011-08-28 04:32:16 UTC
abrt version: 2.0.5
executable:     /mnt/runtime/usr/bin/python
hashmarkername: anaconda
kernel:         2.6.32-191.el6.x86_64
product:        Red Hat Enterprise Linux
reason:         RuntimeError: Returning partitions to state prior to edit failed
time:           Sun Aug 28 12:30:43 2011
version:        6.2

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.134 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/iw/partition_gui.py", line 1698, in editPartition
:    raise RuntimeError, ("Returning partitions to state "
:  File "/usr/lib/anaconda/iw/partition_gui.py", line 1638, in editCB
:    self.editPartition(device)
:  File "/usr/lib/anaconda/iw/partition_gui.py", line 1169, in treeActivateCB
:    self.editCB()
:RuntimeError: Returning partitions to state prior to edit failed

Comment 3 David Lehman 2011-08-30 13:51:16 UTC
Please attach files matching /tmp/anaconda-tb-* to this report as plain text attachments, Thanks.

Comment 4 Xiaoqing Wei 2011-08-31 01:39:14 UTC
(In reply to comment #3)
> Please attach files matching /tmp/anaconda-tb-* to this report as plain text
> attachments, Thanks.

Hi David,

I will try to reproduce it and attach the file you asked,

Thanks and Best Regards,

Xiaoqing.

Comment 5 Xiaoqing Wei 2011-09-01 02:33:16 UTC
Created attachment 520940 [details]
/tmp/anaconda-tb*

Comment 6 Xiaoqing Wei 2011-09-01 05:12:55 UTC
Hi,

This bug is reported automatically by anaconda,
Let me describe the detail steps :

1st, I boot my host into rescue mode by pxe, with tree RHEL6.2-20110823.1 .

2nd, then I type anaconda to install os.

3rd, in partitioning screen,I click return to previous screen(or sth like that).

4th, just login my bz account and anaconda report this bug.

Thanks and Best Regards,
Xiaoqing Wei

Comment 7 David Lehman 2011-09-01 14:22:34 UTC
First of all, the traceback you attached does not match the one that caused this bug to be reported.

Second, here's what happened to lead to the traceback you did attach: it looks like you selected to do an upgrade, then you went and started anacron inside the mounted system (/mnt/sysimage), and then tried to back up and do an install instead of an upgrade. You cannot go and start applications/daemons inside the mounted system and then expect anaconda to be able to unmount it afterwards. This is an unsupported scenario.

If you would like to attach the crash report from your original bug, please do so.

Comment 8 Xiaoqing Wei 2011-09-02 04:54:46 UTC
(In reply to comment #7)
> the mounted system (/mnt/sysimage), and then tried to back up and do an install
aha, I boot my host into rescue mode for data recovery, 
#chroot /mnt/sysimage 
after backed up my data , I exit from chroot and decide run anaconda to reinstall my host, then the anaconda crashes at partitioning.

So,that should be my mis-operation .

Thanks and Best Regards,
Xiaoqing Wei

Comment 9 David Lehman 2011-10-17 19:31:25 UTC
This bug involves running anaconda from the command line inside the mounted system in rescue mode, which is not supported.


Note You need to log in before you can comment on or make changes to this bug.