Bug 733892 - cannot install any 389 EPEL packages without error
Summary: cannot install any 389 EPEL packages without error
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: 389-ds-base
Version: el6
Hardware: i686
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 11:42 UTC by Dan MacDonald
Modified: 2011-08-29 15:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 15:50:41 UTC


Attachments (Terms of Use)

Description Dan MacDonald 2011-08-28 11:42:57 UTC
Description of problem:

I cannot install any 389 packages from EPEL under Scientific Linux 6.1 (32 bit) without getting errors like these:

Error: Package: 389-adminutil-1.1.10-1.el6.i686 (epel)
           Requires: libldap60.so
Error: Package: 389-admin-1.1.11-0.5.rc1.el6.i686 (epel)
           Requires: libldap60.so
Error: Package: 389-adminutil-1.1.10-1.el6.i686 (epel)
           Requires: libssldap60.so
Error: Package: 389-admin-1.1.11-0.5.rc1.el6.i686 (epel)
           Requires: libldif60.so
Error: Package: 389-adminutil-1.1.10-1.el6.i686 (epel)
           Requires: libprldap60.so
Error: Package: 389-admin-1.1.11-0.5.rc1.el6.i686 (epel)
           Requires: libssldap60.so
Error: Package: 389-adminutil-1.1.10-1.el6.i686 (epel)
           Requires: libldif60.so
Error: Package: 389-admin-1.1.11-0.5.rc1.el6.i686 (epel)
           Requires: libprldap60.so
Error: 389-ds-base conflicts with selinux-policy-targeted
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):

Seems to apply to all current stable and testing EPEL 389 packages such as 389-ds-base.i386 1.2.8.3-1.el6

How reproducible:

Try installing any EPEL 389 packages under SL 6.1 - the same problem exists under RHEL 6.1 too I'm told. 

Steps to Reproduce:
1. Add EPEL repo to SL 6.1
2. Try installing any EPEL 389 packages using yum
3. Weep
  
Actual results:

389 doesn't install. I'm told you can use --skip-broken to force the installs through but I'd be wary of doing so on production servers.


Expected results:

Install complete 389 admin environment/packages under SL 6.1

Additional info:

NA

Comment 1 Rich Megginson 2011-08-29 15:50:41 UTC
Unfortunately the required packages are still in updates testing.  Follow the directions at http://directory.fedoraproject.org/wiki/Download for RHEL6/EPEL6 for Testing repo packages.  This bug will be fixed as soon as the packages are pushed to Stable.


Note You need to log in before you can comment on or make changes to this bug.