Bug 733927 - radeon driver default power profile causes overheating
Summary: radeon driver default power profile causes overheating
Keywords:
Status: CLOSED DUPLICATE of bug 682851
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 17:29 UTC by Pasi Karkkainen
Modified: 2018-04-11 06:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 16:58:38 UTC


Attachments (Terms of Use)

Description Pasi Karkkainen 2011-08-28 17:29:02 UTC
Description of problem:

Laptops with ATI/AMD Radeon graphics (for example HP EliteBook 8530p with ATI HD 3650) runs very hot and causes laptop overheating and thermal shutdowns making Fedora 16 unusable.


Version-Release number of selected component (if applicable):
Fedora 16 Alpha x64 live-CD / Linux 3.0.0.

How reproducible:
Always.

Steps to Reproduce:
1. Boot Fedora 16 Alpha live CD.
2. The laptop becomes very hot and overheats, even when there is no CPU
usage and the system is idle.
  

Actual results:
Laptop runs too hot, and overheats often causing thermal shutdowns and crashes.


Expected results:
Laptop runs cool like in Windows, or when using the proprietary fglrx driver.


Additional info:

As a default power_profile "default" is in use:

$ cat /sys/class/drm/card0/device/power_profile
default

Changing the power_profile to "mid" or "low" makes the temperature go down at
least 10-20 degrees celsius on my laptop:

$ echo low > /sys/class/drm/card0/device/power_profile

This overheating issue is caused by a driver bug or unimplemented features in the opensource radeon driver. For the time being the "default" radeon power_profile should not be used as a default.

"dynpm" might be better default power_profile..

Related bugzillas:
https://bugzilla.redhat.com/show_bug.cgi?id=702953
https://bugzilla.redhat.com/show_bug.cgi?id=714474
https://bugzilla.redhat.com/show_bug.cgi?id=682851

Comment 1 Pasi Karkkainen 2011-08-29 19:01:09 UTC
Hmm, actually "dynpm" doesn't seem to be accepted option for some reason. "auto" seems to be valid, I'll try if that works.

Comment 2 Matěj Cepl 2011-09-06 16:58:38 UTC
I don't think it makes much more sense if we concentrate all our efforts on the upstream bug. Closing as duplicate of bug 682851, which is closed against the upstream http://bugs.freedesktop.org/show_bug.cgi?id=36438

*** This bug has been marked as a duplicate of bug 682851 ***

Comment 3 Armando Perico 2012-01-29 15:15:58 UTC
I'm running FC16 with a Lenovo - ThinkPad Edge quadcore....
It was impossible to work, computer shutting down almost all the time, it was running with 90 degrees :S, after your suggestion:
echo low > /sys/class/drm/card0/device/power_profile it is now down to 65degrees!!
very nice!!

Is there anything else that could be done in order to run with lower temperatures than this ?

Thanks

Comment 4 Pasi Karkkainen 2012-01-29 15:29:19 UTC
The upstream bug is this:
https://bugs.freedesktop.org/show_bug.cgi?id=41762

I recommend you to comment on that upstream bug, and also post to dri-devel mailinglist about the issue. It seems AMD/ATI developers are not putting efforts into fixing/implementing proper power management for the opensource radeon driver.

.. and thus the radeon driver is unusable out-of-the-box in laptops, especially when testing new Live CD's.. quite often the laptop overheats and shuts down before you even get to the desktop to be able to switch the power_profile!

It's very annoying and frustrating.

Comment 5 Pasi Karkkainen 2012-01-29 15:32:03 UTC
And another upstream bug about the same issue:
https://bugs.freedesktop.org/show_bug.cgi?id=36438


Note You need to log in before you can comment on or make changes to this bug.